PDA

Visualizza la versione completa : crash di xserver (xfree) senza errori...


kylnas1
15-07-2005, 18:42
Allora, tentando di ritornare a xfree da xorg (che non mi funge) reinstallo i pacchetti di xfree mantenendo però xorg-common (troppe dipendenze se provo a cancellarlo). Quando lancio startx il server crasha, se guardo il file di log di XFree non vedo nessun errore.
Come faccio ad essere sicuro che "startx" faccia partire xfree, e soprattutto perchè crasha senza errori?

Sto impazzendo...

andy caps
15-07-2005, 19:44
:bhò: in questi casi devi tirare giu tutto dipendenze comprese magari con il --purge remove poi reinstallare
installa xfree che mette da se poi magari con synaptic riprovi xorg

a me con sid il dist-upgrade non metteva alcuni file di xorg

kylnas1
15-07-2005, 21:11
Originariamente inviato da andy caps
:bhò: in questi casi devi tirare giu tutto dipendenze comprese magari con il --purge remove poi reinstallare
installa xfree che mette da se poi magari con synaptic riprovi xorg

a me con sid il dist-upgrade non metteva alcuni file di xorg
Già, ma mi chiede di disinstallare 500mb di roba (tipo anche anjuta)... :(

andy caps
15-07-2005, 22:12
:bhò: si chiaramente tuttti i file che hanno come dipendenza xserver

kylnas1
16-07-2005, 10:56
Originariamente inviato da andy caps
:bhò: si chiaramente tuttti i file che hanno come dipendenza xserver
Anche se ho xserver-common installato?

andy caps
16-07-2005, 11:03
mancano dei pacchetti ancora comunque almeno con kde3.4.1 non vanno completamente daccordo (installandoi -dev di xserver toglie tutto anche a me ed ha problemi con glut )

se lo vuoi avviare io credo sa necessario

poi i pacchetti li reinstalla al volo se non hai pulito archives

kylnas1
16-07-2005, 11:09
Originariamente inviato da andy caps
mancano dei pacchetti ancora comunque almeno con kde3.4.1 non vanno completamente daccordo (installandoi -dev di xserver toglie tutto anche a me ed ha problemi con glut )

se lo vuoi avviare io credo sa necessario

poi i pacchetti li reinstalla al volo se non hai pulito archives
Farò così allora...disinstallerò tutto senza pulire archives e senza cancellare i files di configurazione dei programmi...e da 0 provo a reinstallare xorg, sono curioso di provarlo.

kylnas1
16-07-2005, 15:55
Stesso problema di prima.
Tirato giù tutto e installato di nuovo x-window-system-core (prima xfree86 e poi xorg)...di nuovo mi crasha senza che i file di log mi indichino alcun errore...possono essere le impostazioni dei font?

kylnas1
16-07-2005, 16:55
Ho risolto cancellando i file di configurazione di xorg (non gli bastava la disinstallazione)...ora potrei provare la stessa cosa per installare xorg, solo che non voglio cancellare i file di configurazione di xserver.

andy caps
16-07-2005, 17:02
:bhò: difficile da dire

secomdo me è la rimozione della dir che ha causato il pasticcio
se non ha ricreato i file correttamente non credo che non risolvi facilmente

ritogliere semmai tutto con il --purge e mettere provvisoriamente un server della sarge come sources.list
e reinstallare x-window-systen-core e i vari file del server poi rifare l'upgrade a server avviato

Loading