PDA

Visualizza la versione completa : Intel hd Audio


UnNamed
18-07-2005, 12:26
Avendo da poco acquistato un portatile ed essendo novizio di linux, sto trovando particolarmente difficile far funzionare l'audio sul computer. Essendo piattaforma Sonoma, il chipset ac97 stato sostituito con lIntel HD 97 e ovviamente Ubuntu non lo riconosce.

Avete per caso qualche dritta da darmi?

grazie

Sergej_D
18-07-2005, 12:49
Che distribuzione usi?

UnNamed
18-07-2005, 13:43
Si, scusa, la distribuzione Ubuntu.

Ho scaricato e compilato gli alsa-driver ma anche se viene riconosciuto l'audio non si sente.

Sergej_D
18-07-2005, 13:49
Prova a postare l'output del comando:

lspci

Sergej

virusbye
18-07-2005, 13:51
Originariamente inviato da UnNamed
Si, scusa, la distribuzione Ubuntu.

Ho scaricato e compilato gli alsa-driver ma anche se viene riconosciuto l'audio non si sente.

Hai provato ad alzare i volumi con un mixer come "aumix" o qualcosa del genere?

UnNamed
18-07-2005, 15:14
0000:00:00.0 Host bridge: Intel Corp. Mobile Memory Controller Hub (rev 03)
0000:00:02.0 VGA compatible controller: Intel Corp. Mobile Graphics Controller (rev 03)
0000:00:02.1 Display controller: Intel Corp. Mobile Graphics Controller (rev 03)0000:00:1b.0 0403: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
0000:00:1d.0 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
0000:00:1d.1 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
0000:00:1d.2 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
0000:00:1d.3 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
0000:00:1d.7 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev d4)
0000:00:1f.0 ISA bridge: Intel Corp. 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
0000:00:1f.1 IDE interface: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 04)
0000:01:03.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
0000:01:03.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
0000:01:03.2 0805: Ricoh Co Ltd: Unknown device 0822 (rev 17)
0000:01:03.3 System peripheral: Ricoh Co Ltd: Unknown device 0592 (rev 08)
0000:01:03.4 System peripheral: Ricoh Co Ltd: Unknown device 0852 (rev 03)
0000:01:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:01:05.0 Network controller: Intel Corp. PRO/Wireless 2200BG (rev 05)

Come interfaccia uso GNOME e per impostare il volume uso il Volume Control nel men Audio-Video. Inoltre quando vado su Preferenze>Selettore di sistemi multimediali , impostando per l'audio i driver ALSA in tutti i campi e provando a fare il test, mi da questo errore
Failed to construct test pipeline for 'ALSA - Advanced Linux Sound Architecture' ,mentre se setto ESD o OSS non da nessun errore ma il sonoro non si sente comunque.

stai_tranquillo
18-07-2005, 16:16
guglando intorno sembra che usi il driver SND_INTEL8X0 (che in teoria dovresti avere nel kernel generico distribuito da ubuntu)..

prova a caricare il modulo (da rutt)

# modprobe snd-intel8x0m

UnNamed
18-07-2005, 16:57
Originariamente inviato da stai_tranquillo
guglando intorno sembra che usi il driver SND_INTEL8X0 (che in teoria dovresti avere nel kernel generico distribuito da ubuntu)..

prova a caricare il modulo (da rutt)

# modprobe snd-intel8x0m

Visto anche io, ma mi sa che quello che dici tu riferito al chipset ac97. Poi ho provato cmq a vedere se il modulo c' ma nisba.

Dovrei trovare qualcuno che ha lo stesso chipset audio nel portatile.

stai_tranquillo
18-07-2005, 17:06
hai gi visto su www.linux-laptop.net se trovi il tuo?

UnNamed
18-07-2005, 22:42
Visto, ma purtroppo il mio portatile non c' e mancano altri portatili sonoma con cui fare il confronto.

La cosa che non riesco a capire perch scegliendo in Sistemi multimediali i driver ALSA il test mi da errore.

Loading