PDA

Visualizza la versione completa : [UBUNTU] Connessione ADSL => mani nei capelli


Rabelais
22-07-2005, 16:31
Ciao a tutti!
Sono sempre io: ho definitivamente installato Ubuntu con l'intenzione di tenermelo stretto. Pero' il problema della connessione adsl non l'ho ancora risolto.
Dopo letture varie su vari forum nella rete, tra cui questo, ho smanettato un po' e ho scoperto:
-ho due schede di rete (che scoperta!): una PCI e una onBoard alla mobo praticamente identiche (chipset Realtek), la SUSE mi vedela la PCI come eth1 e la onboard come eth0, Ubuntu il contrario (lo so perche' pppoeconf mi trova un concentratore di accesso collegato a eth1...)
-facendo ifconfig vedo che ho un ppp0. Ma se digito adsl-start e poi adsl-status mi dice che sono linkato a ppp1 ma ppp1 e' down. Provo a fare ifconfig ppp1 up ma dice che non esiste.
E' possibile far collegare la connessione adsl a ppp0 e non a ppp1?
Altra cosa: avevo settato la connessione con pppoeconf prima, con rp-pppoe poi. C'e' un conflitto?
Pensate che sia solo qui il mio problema??
Ciao e grazie!

RB

PS l'interfaccia grafica di rp-pppoe dice che la connessione e' andata in time out...
:master:

hfish
22-07-2005, 16:52
mah...
a me basta dare dhclient e il router mi assegna un indirizzo IP, poi mi basta aprire firefox e navigo senza problemi...

Rabelais
22-07-2005, 22:54
Quante schede di rete hai nel tuo pc?
Scusa la mia frustrazione, ma sono 2 settimane che navigo, come un naufrago, tra la rete per cercare una soluzione ma non ho trovato nulla.
Anzi, ho trovato altre persone con il mio stesso problema, ma nessuna soluzione (a parte cambiare distro...).
Pero' a me piace Ubuntu...
:rollo:

RB

Rabelais
23-07-2005, 00:45
Notizia buona: la connessione parte!!
:unz:
Notizia cattiva: ne' firefox ne qualsiasi altro programma riesce ad accedere alla rete. Sembra che lo scambio di dati sia solo tra il pc e il modem, e non anche con l'esterno...
Se digito ifconfig mi escono 3 device:
eth1 - scheda di rete
lo - loop back
ppp0 - modem
Se poi vado a fare la configurazione di ppp0 mi dice che non e' configurato e quindi non attivo; cerco di fare qualcosa ma non trova nessun modem...

MA CHE E'????
:dh: :dh: :dh: :dh:

RB

andy caps
23-07-2005, 00:57
:bh: probabilmente durante l'installazione hai detto di fare un installazione tramite ppp ( connessione analogica ) o hai impostato un gateway nella configurazione della rete

con ubuntu nasta solo fare pppoeconfig se hai un modem ethernet per essere connessi

al limite devi dare un pon al posto di adsl-start

prova a tirare giu ppp0 - modem

ifconfig ppp0 down
poi rifai pppoeconf

se compaiono due ppp tirane giu' uno

es ifconfig ppp1 down

se hai setato un gateway lo devi rimuovere


digitando

route -n

ti da l'elenco dei gateway e li devi rimuovere con

route del default gw 192.168.0.0 se ad esempio route -n lo mostra

poi rifare ancora pppoeconf

Rabelais
23-07-2005, 01:31
Sembra un campo di battaglia...
Allora: tolto ppp0, tolto gateway 198.162.1.1 (ho lasciato 0.0.0.0 pero'...), rifatto pppoeconf ed e' andato per circa 30 secondi, poi il buio. Ho controllato e c'era un ppp0, l'ho ritolto e ho rifatto pppoeconf. BUIO. Ho controllato e non c'erano pppX o gateway.
Sembra quasi che senza pppX o gateway non vada, mentre con un ppp0 va per quei trenta secondi...
:dh:
Come e' la Fedora Core 3??
:incupito:
O la Gentoo??
:master:
O qualche altra??
:dott:

RB

andy caps
23-07-2005, 01:37
ppp0 lo devi lasciare natualmente
lo devi rimuovere nel caso ne crei due

se hai alice scrivi in /etc/resolv.conf

nameserver 212.216.112.112
nameserver 212.216.172.62

e poi riprova

se ubunutu da troppi problemi prova sarge da cui stata fatta ubuntu la debian originale

le distro vanno tutte bene in genere

Rabelais
23-07-2005, 01:56
Ora sto rispondendo da UBUNTU!!!
:unz: :unz: :unz:
Una piccola domanda: prima mi era andata down la connessione, in realta' risultavo collegato ma non caricava nulla. Ho aspettato qualche secondo, circa 15, ed e' ripartito da solo...
C'e' un parametro da settare per il timeout?? Se si' dove??
Grazie comunque!!!

RB

PS quando mi collego il ppp0 si genera da solo con tanto di gateway 192.168.100.1, quando mi scollego scompaiono entrambi.
E' giusto???
Scusa le domande ma sono novello novello...

Rabelais
23-07-2005, 02:14
Adesso va un po' peggio: devo far ripartire la connessione a mano se resto fermo per piu' di 20-30 secondi...
Dove e' il timeout??
:cry:

andy caps
23-07-2005, 10:04
guarda bel file /etc/ppp/options se hai in basso la riga

#idle <n>

decommentata ed eventualmente mettila come sopra

Loading