PDA

Visualizza la versione completa : Sendmail lentissimo nell'invio delle email!


andrea_NET-_DSL
25-07-2005, 16:40
Utilizzo Slackware 10.1 e oggi ho creato una semplice pagina in Php che utilizza la funzione mail() del Php per inviare una email, soltanto che prima che la pagina si carichi e compaia il messaggio "Messaggio inviato correttamente" passa circa 1 minuto.
Come server mail utilizzo Sendmail e vorrei cercare di utilizzare tale programma invece che passare ad altri come Postfix.
La email che cerco di inviare un semplice messaggio formato da una sola parola di testo.

Come posso fare per risolvere ? Da che potrebbe essere provocato tale problema ? :( :dh:


Grazie mille! :)


ps Se puo' essere utile il mio Pc dotato di 512mb di Ram DDR e CPU Athlon XP 2400+.

andrea_NET-_DSL
26-07-2005, 09:23
Up

Grazie :dh: :dh: :dh: :)

l.golinelli
26-07-2005, 09:42
I DNS sono buoni? Posta i log di quando mandi una mail...

andrea_NET-_DSL
26-07-2005, 13:02
I dns li ho in automatico perch sono connesso ad alice adsl tramite modem ethernet (non un Lan solo il mio pc ma ho la scheda di rete dove ho collegato il modem adsl)

Ecco il log che mi chiedevi

root@linux:/home/andr3anet# tail /var/log/maillog
Jul 26 09:08:24 linux sendmail[3138]: j6Q77dwd003138: to=andrea.voci@alice.it, ctladdr=nob
ody (99/99), delay=00:00:45, xdelay=00:00:45, mailer=relay, pri=30049, relay=[127.0.0.1] [
127.0.0.1], dsn=2.0.0, stat=Sent (j6Q77drd003139 Message accepted for delivery)
Jul 26 09:08:25 linux sm-mta[3148]: j6Q77drd003139: to=<andrea.voci@alice.it>, ctladdr=<no
body@linux.andrea.org> (99/99), delay=00:00:01, xdelay=00:00:00, mailer=esmtp, pri=120316,
relay=smtp.aliceposta.it. [62.211.72.24], dsn=2.0.0, stat=Sent (<42E4B45D00032630> Mail a
ccepted)
Jul 26 09:26:43 linux sendmail[3320]: j6Q7QhvD003320: from=nobody, size=49, class=0, nrcpts=1, msgid=<200507260726.j6Q7QhvD003320@linux.andrea.org>, relay=nobody@localhost
Jul 26 09:27:07 linux sendmail[3553]: j6Q7R6n5003553: from=nobody, size=49, class=0, nrcpts=1, msgid=<200507260727.j6Q7R6n5003553@linux.andrea.org>, relay=nobody@localhost
Jul 26 09:27:27 linux sm-mta[3321]: j6Q7QhFL003321: from=<nobody@linux.andrea.org>, size=316, class=0, nrcpts=1, msgid=<200507260726.j6Q7QhvD003320@linux.andrea.org>, proto=ESMTP,daemon=MTA, relay=localhost [127.0.0.1]
Jul 26 09:27:27 linux sendmail[3320]: j6Q7QhvD003320: to=andrea.voci@alice.it, ctladdr=nobody (99/99), delay=00:00:44, xdelay=00:00:44, mailer=relay, pri=30049, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (j6Q7QhFL003321 Message accepted for delivery)
Jul 26 09:27:27 linux sm-mta[3563]: j6Q7QhFL003321: to=<andrea.voci@alice.it>, ctladdr=<nobody@linux.andrea.org> (99/99), delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=120316, relay=smtp.aliceposta.it. [62.211.72.23], dsn=2.0.0, stat=Sent (<42D236EB0028A9A8> Mail accepted)
Jul 26 09:28:10 linux sm-mta[3554]: j6Q7R7Vc003554: from=<nobody@linux.andrea.org>, size=316, class=0, nrcpts=1, msgid=<200507260727.j6Q7R6n5003553@linux.andrea.org>, proto=ESMTP,daemon=MTA, relay=localhost [127.0.0.1]
Jul 26 09:28:10 linux sendmail[3553]: j6Q7R6n5003553: to=andrea.voci@alice.it, ctladdr=nobody (99/99), delay=00:01:04, xdelay=00:01:03, mailer=relay, pri=30049, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (j6Q7R7Vc003554 Message accepted for delivery)
Jul 26 09:28:11 linux sm-mta[3568]: j6Q7R7Vc003554: to=<andrea.voci@alice.it>, ctladdr=<nobody@linux.andrea.org> (99/99), delay=00:00:01, xdelay=00:00:01, mailer=esmtp, pri=120316, relay=smtp.aliceposta.it. [62.211.72.23], dsn=2.0.0, stat=Sent (<42E4B98300027421> Mail accepted)
root@linux:/home/andr3anet#

andrea_NET-_DSL
27-07-2005, 12:56
Up :)

Grazie :stordita:

l.golinelli
27-07-2005, 12:59
Lo risolve linux.andrea.org?

andrea_NET-_DSL
27-07-2005, 13:06
No solo un host di fantasia che ho impostato durante l'installazione di Slackware 10.1, ma dipende da quello ? Cosa c'entra nell'invio delle email da parte di sendmail ?

O meglio lo risolve dal mio pc, in locale cio, ma non su internet perch non esiste come dominio, infatti dentro /etc/hosts c'

andr3anet@linux:~$ cat /etc/hosts
#
# hosts This file describes a number of hostname-to-address
# mappings for the TCP/IP subsystem. It is mostly
# used at boot time, when no name servers are running.
# On small systems, this file can be used instead of a
# "named" name server. Just add the names, addresses
# and any aliases to this file...
#
# By the way, Arnt Gulbrandsen <agulbra@nvg.unit.no> says that 127.0.0.1
# should NEVER be named with the name of the machine. It causes problems
# for some (stupid) programs, irc and reputedly talk. :^)
#

# For loopbacking.
127.0.0.1 localhost
192.168.0.1 linux.andrea.org linux

# End of hosts.

andr3anet@linux:~$



Dipende da questo? Se si come risolvo? :)

Grazie

l.golinelli
27-07-2005, 13:35
Quello a posto, allora non saprei cosa sia... :bh:

andrea_NET-_DSL
27-07-2005, 13:42
Forse dipende dal php.ini ? Sul path di sendmail impostato in questo file che impostazioni devo mettere ?
Ora cosi':


[mail function]
; For Win32 only.
;SMTP = localhost
;smtp_port = 25

; For Win32 only.
;sendmail_from = me@example.com

; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
sendmail_path = sendmail -t -i

E' ok ?
Dovrei cambiare qualche cosa per risolvere questo problema?

Grazie ancora :)

l.golinelli
27-07-2005, 13:45
Prova a mandarti una mail dalla shell col comando:

sendmail -t -i

E' lenta lo stesso?

Loading