PDA

Visualizza la versione completa : Server Web Apache2 in LAN


KaZaA
02-08-2005, 15:24
Salve a tutti! Ho un problema: ho una rete di 2 pc, uno con installato Linux e l'altro (il gateway) con Win2k, quest'ultimo collegato direttamente ad internet (senza firewall o roba varia, solo modem adsl usb). Sul pc con Linux (ke si connette ad internet tramite il pc cn win2k) ho installato, configurato e avviato il server web Apache2, e ora mi kiedevo come fare per renderlo visibile da internet! Grazie a tutti x l'attenzione!

hope for us
02-08-2005, 15:43
Installa Apache anche su Windows e settagli 1 reverse proxy...
mmmh, forse ci sono soluzioni migliori...

KaZaA
02-08-2005, 22:35
Come faccio a impostare un reverse proxy? Ho provato a inserire tra le righe del file di configurazione di Apache2 su Windows queste istruzioni:

<Proxy *>
Order deny,allow
Allow from all
</Proxy>

ProxyPass / http://linux
ProxyPassReverse / http://linux

(linux è il nome dell'host con il server Apache2 configurato)
ma nn funziona lo stesso! (premetto ke praticamente ho cancellato tutto il file di configurazione di Apache su Win e ho lasciato solo Listen 80, ServerRoot e il caricamento dei Moduli)...cosa stò sbagliando? (credo tutto, x il semplice fatto ke è la prima volta ke provo ad impostare Apache...) :cry: :cry: :cry:

hope for us
02-08-2005, 22:51
Beh, intanto non sarebbe male sapere che messaggio di errore ti viene mostrato. E poi Winzozz sa a che cosa corrisponde linux? Prova ad aggiungere 1 voce tipo


192.168... Linux
nel file C:\Windows\System32\drivers\etc\hosts o a usare l'indirizzo di linux invece che il nome nelle direttive ProxyPass e ProxyPassReverse...

EDIT: Ma Apache su win è configurato bene, cioè con http://indirizzo_apache_su_windows ti appare la pagina di prova di Apache?

KaZaA
02-08-2005, 23:15
De hi hi...l'errore è l'accesso negato al server

Forbitten
You don't have access / on this server

sia su locale (ho provato con l'indirizzo di loopback 127.0.0.1) ke su un host in rete!
Ho provato anke ad aggiungere l'indirizzo IP e nome del pc cn linux al file hosts ma nulla!

P.S. Ho provato anke a mettere l'indirizzo IP al posto del nome dell'host ma nn cambia nulla...

hope for us
02-08-2005, 23:25
Prova stupida, prova a mettere una riga Deny from All prima di Allow from All...

Kandalf
02-08-2005, 23:30
Vedi se fra le Options hai -Indexes....togli il meno

hope for us
02-08-2005, 23:36
E comunque ci vuole la slash finale nell'indirizzo http://linux/

KaZaA
03-08-2005, 17:08
Niente...neanke così funziona! Stò cominciando a perdere la speranza...(è la prima volta ke uso Apache2 e mi doveva toccare una cosa del genere...d'oh) :cry: :cry: :cry:

Kandalf
03-08-2005, 17:40
ma hai visto quello che ti ho detto nel file httpd.conf o apache2.conf?

Loading