PDA

Visualizza la versione completa : audio scomparso


giannis
06-08-2005, 11:33
Venerdì ho aggiornato la Suse 8.2 con la 9.3 e a parte qualche problemino, le cose che contano hanno funzionato subito. Da questa mattina però l'audio non c'è più. Naturalmente ho controllato che la scheda sia ancora viva, ho anche provato a rimuovere e reinstallare la scheda (integrata) con yast, ma non c'è stato niente da fare. C'è qualcuno che mi può dare un consiglio?

gianni

Sergej_D
06-08-2005, 12:17
Ma cosa succede? Non viene vista per niente?

Sergej

andy caps
06-08-2005, 12:51
probabilmente devi caricare il modulo della tua scheda e fargli aggiornare i moduli

che scheda integrata è ?

gio14
06-08-2005, 13:51
Prova in modalità testuale (loggato come root) dare alsaconf, dovrebbe trovarti il modulo esatto, oppure alsamixer (magari è il volume che è su mute)

giannis
07-08-2005, 11:25
Innanzitutto ringrazio gio14 per il consiglio, alsaconf ha risolto il problema. Però, quello che mi ha incuriosito è il fatto che l'audio è sparito dalla sera alla mattina senza che io mettessi mano all'hardware o ai tool di configurazione. Alla fine ho scoperto che a far sparire l'audio era il tentativo di vedere i video, i quali per default lanciano noatun il quale per qualche misterioso motivo corrompe i file di configurazione della scheda audio. Adesso sto provando con Kaffeine, il quale non fa danni ma va in esecuzione senza l'audio. Speriamo di venirne fuori....

gianni

giannis
08-08-2005, 12:36
Deve fare una rettifica su quanto detto in precedenza.Non è solo noatun a togliere l'audio al sistema, è sufficente riavviare il PC, dopodichè devo rilanciare alsaconf oppure andare in yast->hardware->audio e l'audio torna. Sembrerebbe che le impostazioni non vengano memorizzate....

gianni

gio14
08-08-2005, 14:40
Dopo aver rifatto alsaconf prova dare
alsa ctrl (forse però serve solo per memorizzare il volume)
comunque controlla in /etc/modprobe.d dovrebbere avere creato il file sound (mi sembra) contenente "modprobe nonemodulo_tua_scheda" (volendo penso si possa anche creare) oppure cerca dove Suse carica i moduli dovrebbe essere /etc/modules oppore /etc/modules.conf (purtroppo non conosco Suse) e ci scrivi dentro il nome del modulo della tua scheda

giannis
08-08-2005, 17:34
Il comando alsa ctrl non viene accettato.
In /etc/modprobe.d oltre al file sound c'è anche sound.yast2, il primo contiene queste 2 righe:
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0

il secondo contiene:
options snd-intel8x0 enable=1 index=0
# 1sCg.AfNzNgGnwMA:Sound Controller
alias snd-card-0 snd-intel8x0

mentre /etc/modules.conf.- contiene parecchie righe, le uniche che ho trovato relative all'audio sono queste:

alias char-major-14 off
alias sound off
alias midi off

può essere che tutto dipenda da quei 2 "off"?
che ne dici?

gianni

gio14
08-08-2005, 19:47
Io proverei ha togliere il file sound (spostandolo da qualche altra parte in modo che non interferisca e cancellarlo eventuamente in un secondo tempo) e lascerei solo quello creato da yast2 /che mi sembra più corretto)oppure invertire le cose (togliere il file creato da yast2) e modificare sound così

alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0

poi proverei ha modificare le righe in /etc/modprobe.conf in questo modo

alias char-major-116 snd (prova inserire anche questa)
alias char-major-14 soundcore
alias sound-slot-0 snd-intel8x0

Loading