PDA

Visualizza la versione completa : problema apt


tutuccio
09-08-2005, 00:34
ho provato a fare:

LINUX:~ # apt-get install mldonkey-stable

e mi da:

Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these:
The following packages have unmet dependencies:
amarok: Depends: postgresql-libs but it is not going to be installed
Depends: libpq.so.3
E: Unmet dependencies. Try 'apt-get --fix-broken install' with no packages (or specify a solution).[/CODE]
allora io do
LINUX:~ # apt-get --fix-broken install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
postgresql-libs
The following NEW packages will be installed:
postgresql-libs
0 upgraded, 1 newly installed, 0 removed and 217 not upgraded.
Need to get 0B/37.2kB of archives.
After unpacking 482kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Committing changes...
Preparing... ########################################### [100%]
1:postgresql-libs ########################################### [100%]
error: unpacking of archive failed: cpio: Bad magic
apt executing: /sbin/SuSEconfig
Starting SuSEconfig, the SuSE Configuration Tool...
Running in full featured mode.
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.automake...
Executing /sbin/conf.d/SuSEconfig.desktop-file-utils...
File '/opt/kde3/share/applications/kde/knights.desktop' contains invalid MIME type 'application/x-chess-pgn,Application' that contains invalid characters
Executing /sbin/conf.d/SuSEconfig.fonts...
Creating cache files for Xft .............................
Creating fonts.{scale,dir} files ..........
Executing /sbin/conf.d/SuSEconfig.gdm...
Executing /sbin/conf.d/SuSEconfig.groff...
Executing /sbin/conf.d/SuSEconfig.gtk2...
Executing /sbin/conf.d/SuSEconfig.guile...
Executing /sbin/conf.d/SuSEconfig.isdn...
Modify isdn.conf
provider provider0 done
Executing /sbin/conf.d/SuSEconfig.ispell...
Executing /sbin/conf.d/SuSEconfig.kde...
Executing /sbin/conf.d/SuSEconfig.kdm3...
Executing /sbin/conf.d/SuSEconfig.libxml2...
Executing /sbin/conf.d/SuSEconfig.news...
Executing /sbin/conf.d/SuSEconfig.pango...
Executing /sbin/conf.d/SuSEconfig.perl...
Executing /sbin/conf.d/SuSEconfig.permissions...
Executing /sbin/conf.d/SuSEconfig.postfix...
Setting up postfix local as MDA...
Setting SPAM protection to "off"...
Executing /sbin/conf.d/SuSEconfig.profiles...
Executing /sbin/conf.d/SuSEconfig.scpm...
Executing /sbin/conf.d/SuSEconfig.sgml-skel...
Executing /sbin/conf.d/SuSEconfig.sortpasswd...
Executing /sbin/conf.d/SuSEconfig.susehelp...
DOCALLOW: localhost
Executing /sbin/conf.d/SuSEconfig.syslog-ng...
Executing /sbin/conf.d/SuSEconfig.words...
Executing /sbin/conf.d/SuSEconfig.xdm...
Executing /sbin/conf.d/SuSEconfig.zmessages...
Finished.
apt executing: /sbin/ldconfig [/CODE]
ma
]W: Some errors occurred while running transaction


insomma 'sta postgresql-libs nn cosa a istallarla. provo a dare apt-get postgresql-libs ma niente. l'ho scaricata da google ma ha errore di dipendenza che rimandano ad altri errori... guardate qua:
[CODE]LINUX:~ # rpm -i '/home/mezzapesa/postgresql-libs-7.4.8-0.6.i586.rpm'
error: Failed dependencies:
libkrb5.so.17 is needed by postgresql-libs-7.4.8-0.6
LINUX:~ # rpm -i '/home/mezzapesa/heimdal-lib-0.6.1rc3-55.15.i586.patch.rpm'
error: Failed dependencies:
libdb-4.2.so is needed by heimdal-lib-0.6.1rc3-55.15
libreadline.so.4 is needed by heimdal-lib-0.6.1rc3-55.15
heimdal-lib = 0.6.1rc3-51 | heimdal-lib = 0.6.1rc3-55.12 is needed by heimdal-lib-0.6.1rc3-55.15
LINUX:~ # rpm -i '/home/mezzapesa/db-4.2.52-86.i686.rpm'
package db-4.3.27-3 (which is newer than db-4.2.52-86) is already installed
file /usr/lib/libdb-4.so from install of db-4.2.52-86 conflicts with file from package db-4.3.27-3
file /usr/lib/libdb_cxx-4.so from install of db-4.2.52-86 conflicts with file from package db-4.3.27-3
file /usr/lib/tls/libdb-4.so from install of db-4.2.52-86 conflicts with file from package db-4.3.27-3
file /usr/lib/tls/libdb_cxx-4.so from install of db-4.2.52-86 conflicts with file from package db-4.3.27-3
LINUX:~ # rpm -i '/home/mezzapesa/heimdal-lib-0.6.1rc3-55.15.i586.patch.rpm'
error: Failed dependencies:
libdb-4.2.so is needed by heimdal-lib-0.6.1rc3-55.15
libreadline.so.4 is needed by heimdal-lib-0.6.1rc3-55.15
heimdal-lib = 0.6.1rc3-51 | heimdal-lib = 0.6.1rc3-55.12 is needed by heimdal-lib-0.6.1rc3-55.15
LINUX:~ # rpm -i '/home/mezzapesa/heimdal-lib-0.6.1rc3-55.15.i586.patch.rpm'
error: Failed dependencies:
libdb-4.2.so is needed by heimdal-lib-0.6.1rc3-55.15
libreadline.so.4 is needed by heimdal-lib-0.6.1rc3-55.15
heimdal-lib = 0.6.1rc3-51 | heimdal-lib = 0.6.1rc3-55.12 is needed by heimdal-lib-0.6.1rc3-55.15
LINUX:~ # rpm -i '/home/mezzapesa/postgresql-libs-7.4.8-0.6.i586.rpm'
error: Failed dependencies:
libkrb5.so.17 is needed by postgresql-libs-7.4.8-0.6

e queste dipendenze conflittano pure!!!!!!!!!!!!!

:master: datemi qualche dritta xk altrimenti nn posso + istallare niente, mi dice sempre di controllare la dipendenza di quella libreria ad amaroK ... help help

andy caps
09-08-2005, 00:55
se non le trova apt installale con yum

cercale ed installale

yum search krb5

yum search readline

heimdal

db


e cosi via

cacao74
09-08-2005, 01:44
Non sarebbe pi conveninente e pratico utilizzare yast per aggiornare (217 pacchetti) il sistema ed installa/rimuovere il software.
:madai!?:

ciao

francofait
09-08-2005, 02:13
Originariamente inviato da cacao74
Non sarebbe pi conveninente e pratico utilizzare yast per aggiornare (217 pacchetti) il sistema ed installa/rimuovere il software.
:madai!?:

ciao

yast non vede le repositri apt di Suse .
Con Suse comunque praticamente mezzo suicidio usare apt senza appoggiarsi a synatic.

cacao74
09-08-2005, 02:18
Originariamente inviato da francofait
yast non vede le repositri apt di Suse .
Con Suse comunque praticamente mezzo suicidio usare apt senza appoggiarsi a synatic.
Quindi non sarebbe possibile installare quel pacchetto con yast?
Solo perch non presente nei suoi repository, non per altro giusto?


0 upgraded, 1 newly installed, 0 removed and 217 not upgraded.

Vedendo che un buon numero di pacchetti potrebbe essere aggiurnato, magari dopo un aggiornamento non avrebbe problemi di dipendenze. Come se non avesse fatto "apt-get update".

ciao

andy caps
09-08-2005, 09:31
:fagiano: io pensavo a fedora ho cannato distro

il sistema per risolvere comunque lo stesso

a me lo ha installato senza problemi

Preparing... ########################################### [100%]
1:mldonkey-stable ########################################### [100%]
Done.


i naturalmente ho aggiornato i pacchetti aggiornabili

io do un apt-get dist-upgrade poi aggiorno i paccheti che so che non danno problemi manualmente incollando le righe che fornsce apt-get dist-upgrade

con apt non conviene aggiornare il kernel di suse perche spesso da problemi seri
quindi meglio evitarlo

tutuccio
09-08-2005, 09:57
l'avevo dato l'apt-get update ma nulla
ora provo a fare l'aggiornamento con yast...

andy caps
09-08-2005, 10:16
devi dare semmai apt-get dist-upgrade e aggiornare quelli che ti fa aggiornare senza problemi

puoi aggiornare anche a rate tranquillamente




tipo

apt-get install MozillaFirefox MozillaFirefox-translations OpenOffice_org OpenOffice_org-Quickstarter OpenOffice_org-kde acroread amarok amarok-libvisual arts cifs-mount fontconfig freetype2 gaim glib2 gnutls gtkpod iptables ispell ispell-american ispell-british k3b k3b-mad kde3-i18n-it kdeaddons3-kate kdeaddons3-kicker kdeaddons3-konqueror kdeartwork3-sound kdeartwork3-xscreensaver kdebase3 kdebase3-kdm kdebase3-ksysguardd kdebase3-nsplugin kdebase3-samba kdebase3-session kdebindings3-python kdegames3 kdegraphics3 kdegraphics3-fax kdegraphics3-kamera kdegraphics3-postscript kdegraphics3-scan kdelibs3 kdelibs3-doc kdemultimedia3 kdemultimedia3-CD kdemultimedia3-jukebox kdemultimedia3-mad kdemultimedia3-mixer kdemultimedia3-sound kdenetwork3 kdenetwork3-InstantMessenger kdenetwork3-news kdenetwork3-vnc kdepim3 kdepim3-kpilot kdepim3-networkstatus kdepim3-sync kdeutils3 kdeutils3-laptop


poi ridai apt-get dist-upgrade e prosegui con il resto

tutuccio
09-08-2005, 12:23
apt-get dist-upgrade tutto di un colpo! tanto l'adsl ke sta a fare? :D

mo provo

tutuccio
10-08-2005, 00:21
mad.... vedete che esce se provo:

LINUX:~ # apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these.
The following packages have unmet dependencies:
koffice-database: Depends: libpq.so.3
libpqxx: Depends: libpq.so.3
E: Unmet dependencies. Try using --fix-broken.


provo a fare come mi dice... ma niente

LINUX:~ # apt-get --fix-broken install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
postgresql-libs
The following NEW packages will be installed:
postgresql-libs
0 upgraded, 1 newly installed, 0 removed and 7 not upgraded.
Need to get 0B/37.2kB of archives.
After unpacking 482kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Committing changes...
Preparing... ########################################### [100%]
1:postgresql-libs ########################################### [100%]
error: unpacking of archive failed: cpio: Bad magic
apt executing: /sbin/SuSEconfig
Starting SuSEconfig, the SuSE Configuration Tool...
Running in full featured mode.
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.automake...
Executing /sbin/conf.d/SuSEconfig.desktop-file-utils...
File '/opt/kde3/share/applications/kde/knights.desktop' contains invalid MIME type 'application/x-chess-pgn,Application' that contains invalid characters
Executing /sbin/conf.d/SuSEconfig.fonts...
Creating cache files for Xft .............................
Creating fonts.{scale,dir} files ..........
Executing /sbin/conf.d/SuSEconfig.gdm...
Executing /sbin/conf.d/SuSEconfig.groff...
Executing /sbin/conf.d/SuSEconfig.gtk2...
Executing /sbin/conf.d/SuSEconfig.guile...
Executing /sbin/conf.d/SuSEconfig.isdn...
Modify isdn.conf
provider provider0 done
Executing /sbin/conf.d/SuSEconfig.ispell...
Executing /sbin/conf.d/SuSEconfig.kde...
Executing /sbin/conf.d/SuSEconfig.kdm3...
Executing /sbin/conf.d/SuSEconfig.libxml2...
Executing /sbin/conf.d/SuSEconfig.news...
Executing /sbin/conf.d/SuSEconfig.pango...
Executing /sbin/conf.d/SuSEconfig.perl...
Executing /sbin/conf.d/SuSEconfig.permissions...
Executing /sbin/conf.d/SuSEconfig.postfix...
Setting up postfix local as MDA...
Setting SPAM protection to "off"...
Executing /sbin/conf.d/SuSEconfig.profiles...
Executing /sbin/conf.d/SuSEconfig.scpm...
Executing /sbin/conf.d/SuSEconfig.sgml-skel...
Executing /sbin/conf.d/SuSEconfig.sortpasswd...
Executing /sbin/conf.d/SuSEconfig.susehelp...
DOCALLOW: localhost
Executing /sbin/conf.d/SuSEconfig.syslog-ng...
Executing /sbin/conf.d/SuSEconfig.words...
Executing /sbin/conf.d/SuSEconfig.xdm...
Executing /sbin/conf.d/SuSEconfig.zmessages...
Finished.
apt executing: /sbin/ldconfig
W: Some errors occurred while running transaction

riprovo a dare apt-upgrade

LINUX:~ # apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these.
The following packages have unmet dependencies:
koffice-database: Depends: libpq.so.3
libpqxx: Depends: libpq.so.3
E: Unmet dependencies. Try using --fix-broken.

ma stesso problema...

Loading