PDA

Visualizza la versione completa : OpenSuse 10.0beta64: ati, apt, flash, mp3


edriv
15-08-2005, 21:25
Ho installato OpenSuse 10.0, beta1, su un portatile AMD64.
I problemi che ora cerco di risolvere sono molti, chiedo consiglio a voi solo per i più importanti e difficili.

premessa:
- Sono già 5 giorni che giro su internet cercando di risolvere, quindi non ditemi stfw.
- Non serve dire "è una beta ovvio che non va niente dovevi aspettartelo", se non riuscite o non avete tempo di darmi una mano non rispondete


Problema 1 - I driver ATI
- Ho scaricato dei pacchetti dal mirror della suse 9.3 (fglrx-8.14.13-0.1.x86_64.rpm e km_fglrx-8.14.13-0.1.x86_64.rpm), ma al momento della compilazione del modulo mi da errori, come fossero errori di programmazione.
/usr/src/kernel-modules/fglrx/2.6.x/nvidia-agp.c:57: error: static declaration of ‘__fgl_agp_try_unsupported’ follows non-static declaration
/usr/src/kernel-modules/fglrx/2.6.x/agp_backend.h:92: error: previous declaration of ‘__fgl_agp_try_unsupported’ was here

Ho pensato che potesse essere una versione a 32bit... boh... comunque non andava.

Allora ho scaricato i driver proprietari della ATI, ho seguito il semplice installer grafico, ho eseguito fgrlxconfig... anche riavviato...

Però se avvio tuxracer (voglio i driver solo per quello :) ) mi dice che non trova l'accelerazione hardware ed infatti va lento (e perdo tutte le partite).

Dimenticavo, la mia scheda è una Ati Mobility Radeon 9700.
Cosa posso provare?
Posso fare qualche test... boh?

2 - APT-get per rpm/suse
Ecco quello che ho fatto:
- Ho scaricato, configurato, compilato ed installato il codice sorgente. Ora mi ritrovo solo un nuovo eseguibile:
aptate (non so a cosa serva).
Se lo avvio da un errore che non trova dei moduli perl:
Can't locate XML/LibXML.pm in @INC
Perhaps some missing perl modules? The required modules are:
XML::LibXML-Common
XML::NamespaceSupport
XML::SAX
XML::GDOME
XML::LibXML

Ma io ho installato i pacchetti libxml, libxml-common...
Poi ho provato dai pacchetti: apt, apt-libs, apt-server... solo che mi incasino con le dipendenze, ad esempio:
librpm-4.1.so is needed by apt-libs-0.5.15cnc7-0.suse093.rb0
Eppure apt risolverebbe molti altri problemi...

3 - Flash su firefox
Il plugin che si scarica dal sito macromedia non si installa, dice che la mia architettura non è supportata.
Copio i plugin nella cartella apposita ma non sembra accorgersene... eppure suse dovrebbe far girare anche programmi a 32...

Poi ho scaricato gplflash da sorgente.. ma... boh.
Io compilo, do un sudo make install...
e poi riavvio firefox ed è come niente. Che fare?

4 - Mp3, su amaroK possibilmente.
Mcz dice di esserci riuscito... mi puoi spiegare che pacchetti (e dove) hai installato?
Io, travolto dalla disperazione, ho ricompilato dal sorgente "ufficiale" del rispettivo sito:
amarok
gstreamer
gst-plugins
e relative dipendenze.

Poi ho fatto anche:
libmad
madplay(+ libid3 per dipendenza)

Ma se do: madplay file.mp3
Mi da:audio: /dev/dsp: Dispositivo o risorsa occupata
Che errore è?
L'audio è configurato e funziona e si sente, addirittura nessuna app lo usa...


Beh grazie a tutti che almeno leggono un problema e cercano di darmi una mano... ciao

:ciauz:

mcz
16-08-2005, 00:12
Parlo per la versione a 64bit, ma probabilmente vale anche per la 32bit.

1) Per quel che riguarda i drivers ata non so che dirti. Io ho nvidia e sono riuscito a montarli nonostante non sia riuscito a trovarli tramite Yast.

2) per apt e synaptic ho usato gli rpm che avevo scaricato a suo tempo da
apt4suse (http://linux01.gwdg.de/apt4rpm/home.html#config)

3) Sembra che OpenSuse non fornisca più pacchetti proprietari (OpenOffice, flash player, Acrobat Reader, ecc.), come spiegato in questa revcensione:
Quo vadis, Suse? (tedesco) (http://www.pro-linux.de/berichte/opensuse10beta.html).
Comunque vi sono le soluzioni.
Per il flash-player è semplice. Basta installare la versione a 32bit di FireFox con Yast (attenzione c'è anche quella a 64bit) e dal sito di FireFox seguire le istruzioni per l'installazione del plugin flash. In 5 minuti funziona.
Il discorso per Konqueror è più complicato, ma credo fattibile. Appena avrò tempo e voglia ci proverò.

Per OpenOffice, se mi ricordo bene, ho installato quello di Suse-9.3.
Acrobat Reader non lo uso (uso kpdf) per cui non so dirti niente.

4) mp3. Come già detto è bastato scaricare con Yast xmms-mad-plugin (mi piacerebbe che qualcuno mi spiegasse cosa c'entra con gli mp3) e tutto è andato a posto da solo (anche per amarK).
A buon conto comunque avevo copiato le vecchie librerie libmp3lame e libdvdcss (che conservo gelosamente) in /usr/lib64, quindi non so se l'installazione di xmms-mad-plugin sia sufficente o se occorra anche la libreria lame (con la sola libreria però non si sentiva niente).

Quindi per i punti 2,3,4 niente compilazioni (la compilazione di apt e l'avevo tentata anch'io, ma non era andata a buon fine).

Per vedere i DVD ho installato da PacMan la nuova libxine (1.1.0). Mi dava errore perchè chiedeva libFAC.so.6, mentre in Suse-10 c'è la libFAC.so 7. Comunque ho forzato l'installazione e adesso vedo i dvd con xine (ma non con kaffeine) e ho un pacchetto 'deffettoso' installato, il che significa che probabilmente verrà disinstallato ad ogni installazione nuova effettuata con apt (o synaptic).

Conclusione: aspettiamo a vedere cosa succederà con la versione stabile. Certo che se le cose resatano così (mancanza di OpenOffice, FlashPlayer, Kaffeine ritoccata, ecc., ecc.) ....

mcz :ciauz:

edriv
17-08-2005, 01:10
YAUHUUUUUUUU :D

Sono riuscito ad ascoltare il mio primo mp3 (degli Anathema per precisione :zizi: )

Ecco come ho fatto:
(nota: con libmad già installato)
- Scaricato XMMS2 development release 2 ( :oVVoVe: ) da sourceforge
- Scaricato scons (make automake configure ecc. alternativo) da www.scons.org (ultima versione), compilato come da install
- cd sui sorgenti di xmms2
- scons
- sudo scons install
- su -
- ldconfig
Ecco come funzia:
- xmms2d &>/dev/null (deve esserci il demone)
- xmms2 è un rudimentale player a linea di comando
- xmms2 add /windows/D/Musica/albums/Resonance\ Best\ of\ Anathema/Anathema\ -\ 10\ Inner\ Silence.mp3
- xmms2 play
- FUNZIONA :sbav:

bon è un po' rudimentale

Nota:
xmms2 è un progetto completamente separato da xmms, con la riscrittura completa del codice.
Per scelta dell'autore supporta solo la musica e non i video.
Ha un'architettura client-server... di client ce ne sono tanti (http://wiki.xmms2.xmms.se/index.php/XMMS2_Clients), io ho provato questo:
http://wejp.homelinux.org/wejp/xmms2/
(tutto questo alle ore 19)
--------------------------------
Ore 00 e precedenti:
- Compinstallato xine-libs
- Compinstallato amarok1.3 non beta

E va da dio, abbasso i casini inutili! :unz:

edriv
18-08-2005, 12:49
Ok, anche flash va.
Basta che avvio "firefox32" e posso vedere anche i flash.

Apt invece mi dà ancora quell'errore...

E i driver non ho idea di come farli andare :dhò:

bakuryu
18-08-2005, 12:52
http://distrowatch.com/2839 :stordita:

francofait
18-08-2005, 13:29
Originariamente inviato da bakuryu
http://distrowatch.com/2839 :stordita:
Che palle.! su 5cdrom , un' iso x un unico dvd a questi gli deve proprio puzzare
:D :D :maLOL: :maLOL:

edriv
18-08-2005, 14:20
Sì lo so che devo aspettare :dhò:
http://www.opensuse.org/index.php/Roadmap

E comunque non cambia molto...
http://www.opensuse.org/index.php/Bugs:most_annoying_bugs
Solo che hanno aggiunto openoffice (senza dover sacricarlo).

mcz
18-08-2005, 16:02
Che palle.! su 5cdrom...
Perchè non ti aggiorni tutto con Yast direttamente da internet ?

Togliendo java a OpenOffice, oltre a renderlo velocissimo, cosa si perde?

mcz :ciauz:

francofait
18-08-2005, 16:15
Originariamente inviato da mcz

Che palle.! su 5cdrom...
Perchè non ti aggiorni tutto con Yast direttamente da internet ?

Togliendo java a OpenOffice, oltre a renderlo velocissimo, cosa si perde?

mcz :ciauz:

Semplicissimo, x poter aggiornare da beta1 a beta2 , bisogna pur averela la beta1 . io l' ho eliminata e riciclato i rescrivibili con altre iso.

Loading