PDA

Visualizza la versione completa : Configurare la scheda wireless su Ubuntu


Dias
19-08-2005, 04:58
Ciao

Questa volta il mio problema riguarda il collegamento wireless. Con Ubuntu default (2.6.10), mi bastava fare network-admin per vedere la mia scheda wireless e quindi configurarla, con il kernel ricompilato (2.5.12.5, ho usato lo stesso config) con quel comando non vedo più la scheda. :master:

Eppure lspci me la trova:


0000:02:03.0 Network controller: Intel Corp. PRO/Wireless 2200BG (rev 05)


Che cosa potrei/dovrei fare? :fagiano:

Dias
19-08-2005, 13:29
Ho risolto. :yuppi:

cacao74
19-08-2005, 14:11
Originariamente inviato da Dias
Ho risolto. :yuppi:
Bravo.

Rendi però il tuo contributo utile anche per altri utenti, postando tutto quello che hai fatto per arrivare alla soluzione.

grazie. ciao

Dias
19-08-2005, 15:06
Si, hai ragione.

Il link dovrebbe essere questo (ora non mi va, boh):

http://www.google.it/url?sa=t&ct=res&cd=1&url=http%3A//ubuntuforums.org/showthread.php%3Ft%3D26623&ei=uNgFQ-3zBpmEiALUg7X6DQ



Da li ho fatto questi passaggi:




sudo tar xvzf ipw2200-fw-2.3.tgz
sudo cp ipw-2.3-*.fw /usr/lib/hotplug/firmware/


sudo tar xvzf ieee80211-1.0.3.tgz
cd ieee80211-1.0.3


sudo sh remove-old


cd ..
sudo tar xvzf ipw2200-1.0.6.tgz
cd ipw2200-1.0.6


sudo sh remove-old


cd ..
cd ieee80211-1.0.3
make
sudo make install


cd ..
cd ipw2200-1.0.6
make
sudo make install



sudo apt-get install wpasupplicant



sudo gedit /etc/wpa_supplicant.conf // create this file and paste this script

ctrl_interface=/var/run/wpa_supplicant

network={
ssid="your_network_name"
scan_ssid=1
proto=WPA
key_mgmt=WPA-PSK
psk="your_secret_key"
}


//examples /usr/share/doc/wpasupplicant/examples/wpa_supplicant.conf.gz


reboot

dmesg | grep ipw

sudo wpa_supplicant -B -i eth1 -c /etc/wpa_supplicant.conf -D ipw -w -dd //if there are errors, miss -w flag

indre
08-05-2007, 15:54
ho seguito la medesima guida ma mi ha incasinato tutto :D

Loading