PDA

Visualizza la versione completa : Impossibile installare Amule- per favore aiutatemi


lucacrea
20-08-2005, 13:30
Ciao non riesco a installare amule.
Mi dice che mancano dei pacchetti (precisamente 2) e sono libwx_gtk2-2.4.so.0 e libwx_gtk2-2.4.so.0(WXGTK2_2.4)
Ho provato ad installare alcuni pacchetti ma non cambiato niente. Sono nuovo di linux ed ho la versione fedora core 4.
Come posso fare??

Ikitt
20-08-2005, 13:45
Originariamente inviato da lucacrea
Ciao non riesco a installare amule.
Mi dice che mancano dei pacchetti (precisamente 2) e sono libwx_gtk2-2.4.so.0 e libwx_gtk2-2.4.so.0(WXGTK2_2.4)
Ho provato ad installare alcuni pacchetti ma non cambiato niente. Sono nuovo di linux ed ho la versione fedora core 4.
Come posso fare??

Aggiungi alla configurazione di yum il repository livna come indicato qui:

http://rpm.livna.org/configuration.html

quindi puoi installare amule automaticamente usando yum.

lucacrea
20-08-2005, 13:50
Grazie adesso provo e ti faccio sapere

lucacrea
20-08-2005, 13:54
non mi installa niente mi dice che non ho i permessi necessari :confused:

Ikitt
20-08-2005, 13:56
Originariamente inviato da lucacrea
non mi installa niente mi dice che non ho i permessi necessari :confused:
Tutte le operazioni vanno fatte come root, hai fatto cosi` anche tu?

lucacrea
20-08-2005, 14:08
non conosco per niente linux non so che devo fare :dh:

Ikitt
20-08-2005, 14:15
Originariamente inviato da lucacrea
non conosco per niente linux non so che devo fare :dh:

Consiglio senz'altro la lettura di qualche buon manuale, allora.
I passaggi necessari, a grandi linee sono:
0. assumendo di avere una connessione a internet funzionante
1. aprire un terminale (sinonimi: emulatore di terminale, console, gnome-terminal, konsole...)
2. digitare: cd /tmp (invio)
3. digitare: wget -v http://rpm.livna.org/fedora/4/i386/RPMS.lvn/livna-release-4-0.lvn.5.4.noarch.rpm (invio)
4. all'avvenuto download (con successo, si spera) del pacchetto, digitare: su - (invio)
5. immettere la password di root. La password non viene visualizzata mentre viene immessa, neppure oscurata (asterischi al posto dei caratteri giusti) per ragioni di sicurezza
6. digitare: cd /tmp (invio)
7. digitare: rpm -ivh livna-release-4-0.lvn.5.4.noarch.rpm (il nome del pacchetto scaricato insomma)(invio)
8. digitare: yum install amule

Al termine di queste operazioni dovresti avere amule installato. Ci sono metodi alternativi, forse piu` semplici, forse meno, per fare quanto su detto in modo grafico, ma non ho sottomano una Fedora Core 4 per cui non posso essere piu` esaustivo.

Se l'operazione si conclude con successo, puoi chiudere il terminale aperto e usare amule o fare quanto preferisci, altrimenti se, ahime, qualcosa va storto, riporta cosa hai fatto esattamente e quale messaggio hai ottenuto in risposta.

HTH,

andy caps
20-08-2005, 14:16
per essere root in un terminale per installare i pacchetti
devi scrivere

su

nel terminale e mettere la pasword di root

:bh: altrimenti fai il login come root alla maschera di login diretamente

premi ctrl + alt + backspace e scrivi root come logn con relativa password

lucacrea
20-08-2005, 14:23
Mi blocco alla 3 operazione.
[casa@localhost tmp]$ wget -v http//rpm.livna.org/fedora/4/I386/....5.4.noarch.rpm
--14:21:48-- http://http//rpm.livna.org/fedora/4/I386/....5.4.noarch.rpm
=> `....5.4.noarch.rpm'
Resolving http... failed: Host non trovato.

Perch???

Ikitt
20-08-2005, 14:25
Originariamente inviato da lucacrea
Mi blocco alla 3 operazione.
[casa@localhost tmp]$ wget -v http//rpm.livna.org/fedora/4/I386/....5.4.noarch.rpm
--14:21:48-- http://http//rpm.livna.org/fedora/4/I386/....5.4.noarch.rpm
=> `....5.4.noarch.rpm'
Resolving http... failed: Host non trovato.

Ho provato adesso (e ricontrollato il link), funziona bene.
Nella riga di comando che hai inviato noto un errore (evidenziato in grasseto, manca ':' tra 'http' e '//'), e` un refuso dovuto alla copia o un errore vero e proprio?

Loading