PDA

Visualizza la versione completa : Reiser4 finalmente!


Meskalamdug
28-08-2005, 15:56
Nel caso interessasse a qualcuno,ecco un paio di info utili
su reiser4.
Se siete possessori di amd64,scaricate e fatevi un cd bootabile di slamd64-current,visto che permette di scegliere reiser4 in fase di installazione.
Ricordate si tratta di un fs in fase di testing..il rischio di perdere dati e' concreto,ma ce chi lo usa da piu' di un anno senza problemi.
Non usate le reiser4utils 1.0.4 o inferiori in quanto vi segnalano corruzzioni inesistenti,scaricate da ftp.namesys.com le 1.0.5.
Se volete fare fsck non usate la procedura classica
telinit 1,umount /,etc in quanto manda in panic il kernel
se volete fare il check dovete,salvare su cd o su una partizione le librerie di reiser4(librepair,libaal,libreiser4 si trovano su /lib64 )
oltre che fsck.reiser4(che DEVE essere il 1.0.5).
Avviate con il cd bootabile di slamd e copiate fsck.reiser4 in /sbin
e le libreirie sudette in /lib64,dopodiche potete fare fsck.reiser4 sulla partizione :)
Ecco infine una lista di kernel che supportano reiser4

2.6.13-rc6-mm2(NON USATELO INCASINA HOTPLUG)

2.6.12.4(kernel di slamd64-current,lento ma affidabile)

2.6.13-rc7-ckpp(crasha,non affidabile)

2.6.13-rc6-ckx2(per ora mi sembra il piu' affidabile tra i kernel testing)

http://kernel.damouse.co.uk/ck/ckx/2.6.13-rc6-ckx2/2.6.13-rc6-ckx2.bz2

Guglie
28-08-2005, 16:05
sai se si pu˛ patchare direttamente un kernel vanilla per avere reiser4?

Meskalamdug
28-08-2005, 16:08
Originariamente inviato da Guglie
sai se si pu˛ patchare direttamente un kernel vanilla per avere reiser4?
Si , il 2.6.12 o il 2.6.13-rc6.

Meskalamdug
28-08-2005, 16:15
A proposito..si sta discutendo se mettere reiser4 nella 2.6.13,speriamo...

Guglie
28-08-2005, 16:46
Originariamente inviato da Meskalamdug
Si , il 2.6.12 o il 2.6.13-rc6.
non riesco a trovare la patch :fagiano:

Meskalamdug
28-08-2005, 16:47
Originariamente inviato da Guglie
non riesco a trovare la patch :fagiano:
Per quale kernel ti serve?

Guglie
28-08-2005, 17:33
Originariamente inviato da Meskalamdug
Per quale kernel ti serve?
in generale per i vanilla 2.6 (adesso sto usando il 2.6.12.5)

Meskalamdug
28-08-2005, 17:50
Originariamente inviato da Guglie
in generale per i vanilla 2.6 (adesso sto usando il 2.6.12.5)

ftp://ftp.namesys.com/pub/reiser4-for-2.6/2.6.12

weatherman
29-08-2005, 12:35
Originariamente inviato da Meskalamdug
A proposito..si sta discutendo se mettere reiser4 nella 2.6.13,speriamo...
se non sbaglio non l'hanno messo :dh˛: speriamo accada presto

Meskalamdug
29-08-2005, 13:28
Originariamente inviato da weatherman
se non sbaglio non l'hanno messo :dh˛: speriamo accada presto
A giorni esce cmq la patch di namesys
:zizi:

Loading