PDA

Visualizza la versione completa : VNC in una rete wireless


Daisyland
31-08-2005, 17:04
All'interno di una rete wireless ho installato UltraVNC come viewer su un PC e come server sul PC che fa da server e su un altro PC preso a caso nella rete.
Quando mi connetto al server non ci sono problemi, riesco ad avere il controllo del PC, invece non riesco a connettermi all'altro PC. Precisazione: con la configurazione della wireless io da un PC della rete non vedo, col ping, gli altri PC, ma vedo esclusivamente il server. E quindi penso che per prendere controllo, tramite VNC, di un PC della Lan che non sia il server, devo passare per il router. Solo che non capisco cosa devo configurare sul router stesso.

Ho provato ad aggiungere una porta (ho messo la 5900) nella finestra di port forwarding e in quella di port triggering (non sapevo con certezza quale configurare, mi sembra che il port triggering gestisca gli ip dinamici, poi quando lancio il viewer di UltraVNC metto l'ip del router, quello con cui esce su internet che vedo nel router status e mi aspetto che mi ridirezioni la conessione a quel PC ma questo non avviene. In cosa sbaglio ? non è sul port forwarding (o triggering) che devo intervenire ?
grazie.

seclimar
01-09-2005, 09:14
se tutti i pc sono sulla stessa rete non serve il port forwarding..che serve solo dall'esterno ... (ora penso che abbia aperto a internet il vnc)

prova il ping e basta...quando ti va il ping .. allora potra' andare anche il vnc

togli TUTTI i firewalls per le prove (xp ne ha uno interno)

Daisyland
01-09-2005, 16:43
Scusa, adesso col ping dalla mia macchina vedo l'altra della LAN (e ovviamente viceversa), però se lancio il viewer di UltraVNC con quell'ip mi chiede la password, digito la password che ho messo nel server VNC che c'è lì ma non mi fa entrare, mi risponde

---------------------------
VNC authentication failed!
---------------------------
Il settaggio attuale è identico a quello dell'ultraVNC sul server dove entro senza problemi (e nemmeno mi chiede la password).
cos'altro devo settare ?

seclimar
01-09-2005, 16:49
immagino che tu abbia un semplice problema di password ...

ti dice
autenticazione fallita

Daisyland
01-09-2005, 16:54
Infatti.
ma sai che ho provato adesso a reinstallarlo, solo su quel PC, e di default mi mette una password (che non conosco perchè vedo i caratteri protetti). Ho provato a cambiarla nella maschera di configurazione(cambiando il numero di caratteri) e ho visto che ha ripreso la vecchia password messa di default (perchè il numero di caratteri era quello di prima e non quello della password messa da me). Come faccio a leggerla o cambiarla ? E perchè sul server non mi ha dato nessun problema e si connette in automatico ?

seclimar
01-09-2005, 17:41
se vuoi cambiare la password.. lo fai dal server
vai nelle impostazioni e la modifichi!
non preoccuparti della lunghezze dei caratteri mascherati
non corrisponde a volte alla lunghezza reale (come nella connessione remota)...

Daisyland
01-09-2005, 17:47
Finalmente reinstallandolo è partito e mi accetta la nuova password che ho fissato.
era ora.

Daisyland
01-09-2005, 17:50
Originariamente inviato da seclimar
se vuoi cambiare la password.. lo fai dal server
vai nelle impostazioni e la modifichi!
non preoccuparti della lunghezze dei caratteri mascherati
non corrisponde a volte alla lunghezza reale (come nella connessione remota)...
ti ho letto ora.
come dicevo ho reinstallato ed è partito accettando il cambio di password.
al limite se sarai disponibile in futuro ti romperò :D quando dovrò vedere la connessione verso un pc esterno per vedere se è giusta la configurazione del router.
grazie

Loading