PDA

Visualizza la versione completa : Problema con l'installazione di Glade


Sechi Paolo
11-09-2005, 01:12
Salve a tutti.
Stavo cercandodi installare il programma Glade e mi da quest'errore:
checking for pkg-config... /usr/bin/pkg-config
checking for libxml-2.0 >= 2.4.1 gtk+-2.0 >= 2.6.0... Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found

configure: error: Library requirements (libxml-2.0 >= 2.4.1 gtk+-2.0 >= 2.6.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
[root@localhost glade-2.10.0]# Eppure io ho installato il gtk e il libxml!!!!

che devo fare???? E' tutta la sera che cerco di installare programmi senza riuscirne a installar nemmeno uno :(:(:(

Caleb
11-09-2005, 01:15
echo $PKG_CONFIG_PATH

che ti dice?

Sechi Paolo
11-09-2005, 01:20
Ma digitato sul Shell dopo che ha finito il "./configure"??
Se si questo
[root@localhost glade-2.10.0]# echo $PKG_CONFIG_PATH

[root@localhost glade-2.10.0]#

Caleb
11-09-2005, 01:26
ti manca il path a pkgconfig

prova con export PKG_CONFIG_PATH="/opt/gtk/lib/pkgconfig" o roba simile, non so dove sia sulla tua distro

ps hai vinto il premio per "layout meglio sfanculato della giornata"

Sechi Paolo
11-09-2005, 01:39
Originariamente inviato da Caleb
ps hai vinto il premio per "layout meglio sfanculato della giornata" :D :D :D

Adesso sto scaricando il file in formato rpm, vediamo se riesco ad installarlo in questo formato.
In caso contrario riproviamo

Sechi Paolo
11-09-2005, 10:23
:incupito: :incupito: :incupito: Fastidioooo!!! :incupito:

Non sono risucito a installare glade neppure cosė :(:(:(:(

Ma cosa devo fare???

Ho provato anche con export PKG_CONFIG_PATH="/opt/gtk/lib/pkgconfig" ma nulla
ma questa riga va scritta sulla riga di comando del shell? cosa dovrebbe fare?

Ikitt
11-09-2005, 10:38
Originariamente inviato da Sechi Paolo
Stavo cercandodi installare il programma Glade e mi da quest'errore:[CODE]checking for pkg-config... /usr/bin/pkg-config
checking for libxml-2.0 >= 2.4.1 gtk+-2.0 >= 2.6.0... Package gtk+-2.0 was not found in the pkg-config search path.
[...]
Hai installato i pacchetti di sviluppo di gtk?
Perche` non usi i pacchetti binari della tua distribuzione per glade (che sara` fornito al 99.99975%)?

Sechi Paolo
11-09-2005, 12:19
Ciao, tutto installato dal Centro controllo Mandrake.
Ho digitato gtk e ho scaricato tutto l'elenco (sicuramente anche qualcosa che non aveva nulla a che fare col gtk), poi ho digitato glade e non ha trovato nulla :(:(:(:(

Non so pių che fare :cry:

Loading