PDA

Visualizza la versione completa : Configurazione Cell UMTS


apsoft
22-09-2005, 23:09
salve a tutti e grazie a chi mi risponderÓ, uso la suse 9.0 prof e sto cercando di configurare un Samsung SGH-Z300 UMTS sulla quale ho attivata una promozione tim per la navigazione su internet. Ho seguito tutte le istruzioni per la configurazione dalla guida di Stefano Melchio ed ho eseguito con successo i seguenti passaggi :

- ho collegato il blue tooth adapter all'interfaccia usb ed Ŕ stato regolarmente riconosciuto
- ho eseguito hciconfig che ha dato esito positivo
- ho trovato il cellulare trami teil comando hcitool scan e neho preso l'indirizzo MAC
- l'ho pingato e l'ho "ri"rilevato usando il comando sdptool search DUN
- ho eseguito il comando rfcomm bind 0 00:etc che ho verificato con il comando rfcomm show che mi ha dato come risultatao rfcomm0: 00:etc channel 1 clean
- ho creato la dev con mknod /dev/rfcomm0 c 216 0
- ho verificato che nel file /etc/bluetooth/hcid.conf vi fosse decommentata la riga pin_helper /usr/bin/bluez-pin; che nella suse dovrebbe essere pin_helper /bin/bluepin;
- ho editato il file /etc/bluetooth/pin inserendo il classico 1234
ho creato il file di configurazione /etc/ppp/peers/con_umts con il seguente listato :
noauth
connect "/usr/sbin/chat -v -f /etc/ppp/peer/chat-con_umts"
defaultroute
/dev/rfcomm0
460800
persist
crtscts
lock
modem
noipdefault
debug
nodetach
usepeerdns
remotename chat-con_umts
ipparam chat-con_umts
novj
ipcp-accept-remote
ipcp-accept-local
lcp-echo-interval 0
lcp-echo-failure 0

- ho editato il file chat-con_umts con il seguente listato :
#TIMEOUT 5
#ECHO ON
ABORT BUSY
ABORT 'NO CARRIER'
ABORT VOICE
ABORT 'NO DIALTONE'
ABORT 'NO DIAL TONE'
ABORT 'NO ANSWER'
ABORT DELAYED
'' ATZ
OK-AT-OK AT_OPSYS=3
OK-AT-OK AT+CGDCONT=1,"IP","ibox.tim.it"
OK-AT-OK ATDT*99***1#
CONNECT

-quando eseguo il comando pppd call con_umts mi vien fuori la scritta :
Failed to open /dev/frcomm0: Connection Refused

- nel cellulare (che purtroppo con winzoz ha funzionato benissimo) ho eseguito le seguenti operazioni :
ho attivato ovviamente il bluetooth e la visibilitÓ del telefonino e ho anche associato il dispositivo inserendo il codice 1234 indicato nel file di configurazione precedentemente indicato. ho provato anche cambiando il pin (1111) ed in effetti devo riassociare il dispositivo con il nuovo pin, ergo la comunicazione avviene eccome.

Se avete qualche test da consigliarmi vi sarei veramente grato.

Alberto

alex86
23-09-2005, 01:30
Originariamente inviato da apsoft
-quando eseguo il comando pppd call con_umts mi vien fuori la scritta :
Failed to open /dev/frcomm0: Connection Refused


sicuro non sia rfcomm0?

apsoft
23-09-2005, 08:31
sicuro non sia rfcomm0? si, ho semplicemente sbagliato scrivendo l'errore me lo da su rfcomm0 :dh˛:

Alberto

Loading