PDA

Visualizza la versione completa : kernel panic ma errore di lilo :(


giaco31
02-10-2005, 19:06
ciao a tutti, non ho fatto niente alla mia slack ieri, ho solo cambiato il file lilo.conf e salvato le modifiche, ma quando oggi ho riaccesso mi Ŕ comparso il bootloader nel modo in cui lo avevo configurato, ma all'apertura della slack mi Ŕ comparso dopo alcuni tra i soliti comandi che esegue all'avvio:

VFS mounted root readonly
Freeing unused kernel memory 120k freed
Warning: unable to open an initial console
Kernel panic: no init found. Try passing init option to kernel

che posso fare?
grazie a tutti

andy caps
02-10-2005, 19:38
cambiare lilo.conf puo' dare questo

probabilmente lino precedente aveva initrd e tu l'hai tolto
cosa hai cambiato in lilo ?

giaco31
02-10-2005, 21:15
a dire la veritÓ non ricordo di preciso le righe che ho tolto.. ma prima c'era come default windows e sotto linux, ora avevo messo primo linux (default) e sotto windows..

andy caps
02-10-2005, 21:22
probabilmente hai omesso una riga o scritto male

per avviare slackware comunque basta avviare da cd digitando

rescue root=/dev/hdxx il dico su cui Ŕ installata

giaco31
02-10-2005, 21:45
ciao, ora sto scrivendo dalla slax live, ho aperto il file lilo.conf, sai dirmi cosa mettere per farlo funzionare..

andy caps
02-10-2005, 21:50
rinominalo poi ripristina il beckup che trovi li accando
con il nome di lilo.conf~ rinominandolo lilo.conf

giaco31
02-10-2005, 21:52
ehm.. non ho capito.. praticamente ho aperto lilo.conf con kedit, non ho un baclup di quello vecchio... cmq questo e il contenuto..

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot="/dev/hda"
message = /boot/boot_message.txt
prompt
timeout="1200"
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga="773"
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins

image="/boot/vmlinuz"
root="/dev/hda1"
label="Linux"
read-only
# Linux bootable partition config ends

other=/dev/hda1
label="Winzoz"

andy caps
02-10-2005, 21:57
hai messo root="/dev/hda1"

e in hda1 hai windows

digita in un altro terminale fdisk -l e controlla in che partizione hai slack e correggi con
root="/dev/hda5" o quello che Ŕ

giaco31
02-10-2005, 21:58
azz che svista!
linux [ nella hda2, ora sistemo..

ciao!!! e grazie!

EDIT
ho salvato il file ma come aggiorno lilo.. esiste un eseguibile?

eddis
02-10-2005, 22:02
lilo (da Root).
lilo -v se vuoi avere un output di quello che succede.

Loading