PDA

Visualizza la versione completa : modem ericsson e ubuntu


elalmadecuba
03-10-2005, 01:00
dopo ore di battaglia ho deposto le armi e chiedo aiuto.
ho un problema abbastanza insolito che ora vi descriverò minuziosamente:
ho per le mani un portatile compaq presario 700Mhz e devo farlo connettere ad internet con un modem ethernet ericsson hm220dp, sopra c'è installata ubuntu 5.04. di insolito c'è che non ha la porta ethernet ma almeno una porta pciYMCA (pcimcia) con una ethernet di una marca sconosciuta a 10 Mbit/sec che viene riconosciuta e se attaccata a un router riesce pure a navigare in internet. bene, ma ora c'è un problemino, pppoeconf non funziona col suddetto modem ho cercato su google per ore ma niente... non so nemmeno come configurare un file di configurazione (anche perché non lo trovo...)
venitemi in aiuto, ho un abbonamento adsl e non riesco ad utilizzarlo!

andy caps
03-10-2005, 01:12
dai un ifconfig e controlla che la scheda venga vista

:bhò: io ho il tuo modem e gira perfettamente da anni
il problema magari si riduce a caricare preventivamente il modulo della scheda

dai un lspci o un dmesg e controlla cosa vede

elalmadecuba
03-10-2005, 01:19
con ifconfig la scheda viene vista, poi in dmesg dice che carica un modulo ppp generico, ora non ce l'ho sottomano e vado a dormire :) proverò con lspci e vedo se mi da qualche info in più, spero non sia il modem che è andato, anche se si accendono tutti i led e pure quello della eth

andy caps
03-10-2005, 01:24
si magari scriviti come viene riconosciuta

per sicurezza

e installa
pcmcia-cs dai pacchetti che potrebbe essee utile

elalmadecuba
03-10-2005, 17:19
questo e' quello che mi dice mentre e' attaccato al mio router(attualmente sto postando dal compaq):
--dmesg
eth0: NE2000 Compatible: io 0x300, irq 3, hw_addr
00:A0:0C:14:89:84
--lspci
0000:00:0b.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 01)

credo sia questo, non e' che sia molto semplice capire da lspci quale sia la riga giusta ma per esclusione... il pacchetto pcmcia era aggiornato :(

elalmadecuba
04-10-2005, 00:36
bello come il sole l'autore di questo sito ha risolto anche il mio problema!
http://3hm220dp4all.cjb.net/
cliccate subito termina caricamento pagina che se no vi ridirige a pagine vuote spazioinwind o robaccia del genere

andy caps
04-10-2005, 20:21
prova a dare un mdprobe ne2k-pci e poi dai un infconfig eth0 up

se non carica quello prova
modprobe ne2

elalmadecuba
22-10-2005, 11:26
sono tornato... sono riuscito a farlo funzionare su una linea business del vecchio tin (ora credo sia alice) come isp, ora avendo fatto la stessa procedura su una linea alice da 640kbps non funziona più. vedo il modem vado nella sua pagina di configurazione ma proprio non riesco a connettermi a internet. andy caps, come è configuaro il tuo? vc vp incapslation pap o chap... non riesco proprio a venirne a capo

andy caps
22-10-2005, 12:04
io ho un semplice modem ethernet

se hai gia configurato da windows il router non c'è bisogno di riconfigurarlo

guarda nelle istruzioni del router
sapendo il modello esatto su google

configurazione router xxxxxx trova anche le pagine specifiche per il tuo router

andy caps
22-10-2005, 12:10
:D nel senso che se lo utilizzi come modem ethernet non deviconfigurarlo dall'interfaccia


con i modem ethernet tipo ericsson 220 nd basta dare il comando adsl-setup o pppoeconf con le debian based per fare la connessione

Loading