PDA

Visualizza la versione completa : TCP/IP


zEuSsE
03-10-2005, 21:22
raga ho bisogno di voi....
ho scritto un e-mail al supporto del mio modem x kiedere come si installava il loro prodotto su linux e mi hanno rx così:
Salve,
Il modem DC-214 può funzionare su sistemi Linux solo se collegato via
ethernet ed il S.O. supporta il protocollo TCP/IP. Una volta impostato
il
protocollo TCP/IP del computer per rilevare in automantico
l'indirizzo IP è
sufficiente collegare il modem (già configurato con il computer
Windows) per
navigare senza problemi.

Cordiali saluti,

ora la domanda è: come lo imposto il protocollo TCP/IP su SUSE 9.3 considerate ke sn completamente nuovo a linux!!!
risp please!!!!!! :cry:

Trusty
03-10-2005, 21:56
è un modem ethernet ?

da console di root : dhcpd eth0

oppure se vai nel setup della suse (Yast) ->dispositivi di rete-> modem ; scheda di rete!

trovi tutto lì!

ricorda che devi fornire + informazioni se vuoi ottenere una risposta decente (cioè non come la mia...visto che hai dato 2 dettagli..) :ciauz: :ciauz:

zEuSsE
03-10-2005, 22:09
si hai ragione cmq è un modem ethernet adesso provo come mi hai detto poi t faccio risapere grazie

zEuSsE
04-10-2005, 00:19
il comando viene eseguito ma nn succede niente :dhò: mi puoi aiutare??

zEuSsE
04-10-2005, 11:23
ho povato [sotto suggerimento] con il comando
dhclient eth0
ma mi dice che non esiste :master:
HELP PLEASE!!!

gianiaz
04-10-2005, 11:54
che non esiste cosa?

soggetto verbo complemento oggetto...


se non esiste dhcclient installalo
se non esiste eth0 allora vedi come ti viene riconosciuta la scheda di rete...

zEuSsE
04-10-2005, 12:06
il comando nn esiste ma io nn sò come fare a installarlo:( sn nuovo nuovo di linux aiutooooooo

fede_pg
04-10-2005, 12:23
Prova con

#ifdown eth0
#ifup eth0

il simbolo # vuol dire che devi eseguire i comandi come root.

Se la scheda è configurata per usare il dhcp (controlla questa impostazione da YAST come ti era stato consigliato), ifup chiamerà il client dhcp e riceverai l'indirizzo ip :) .

e soprattutto... niente panico :zizi:

S[p]|llo`
04-10-2005, 12:24
Originariamente inviato da zEuSsE
il comando nn esiste ma io nn sò come fare a installarlo:( sn nuovo nuovo di linux aiutooooooo
Comunque se continui così questo post durerà più o meno 200 pagine, senza che tu abbia capito come far funzinoare il modem....
Se posso darti un consiglio prima di postare fatti un giro sul sito della distro che ti sei installato, anche su google, qualcosa scappa sempre fuori... poi quando posti i tuoi problemi, te l'hanno detto dal primo post, fallo in maniera completa... detto questo... hai fatto come ti ha suggerito Trusty? Cioè hai configurato sotto yast il modem? Fatto questo hai lanciato la connessione? (Sotto Suse non mi ricordo come si chiama)...
Se hai fatto questo senza che il pc navighi puoi provare a vedere questi due file /etc/resolv.conf e /etc/ppp/resolv.conf (non lo so prova pico, o nano o kate, non so che c'è sotto la tua Suse)
pico (oppure kate) /etc/resolv.conf
pico /etc/ppp/resolv.conf
naturalmente entrambi come root
Se in questi due file sono del tipo
nameserver xxx.xxx.xxx.xxx
nameserver xxx.xxx.xxx.xxx allora è tutto apposto, altrimenti c'è qualcosa che no va, li devi mettere a mano tu (cambiano a seconda del tuo gestore).
Se ancora non dovessi navigare dai il comando ifconfig, e vedi se eth0 è stata caricata (forse è cosa migliore dare questo comando prima di tutti gli altri che ti ho detto, ma va bene anche così) ed anche ppp0, se così non fosse prova a dare ifconfig ppp0 up... se non hai nessun messaggio di errore aspetta un minutino e prova a navigare... (altrimenti c'è stato un problema col modem, nel senso che non è stato riconosciuto al boot, è spento, o robe più o meno simili) poi hai due possibilità
1)navighi->tutto ok
2)non navighi->spacca il modem, il pc, e il forno a microonde di tua madre, non risolve la situazione, ma almeno ti sfoghi!
:ciauz:

GNUbie
04-10-2005, 13:57
Originariamente inviato da zEuSsE
il comando nn esiste ma io nn sò come fare a installarlo:(

ma leggersi DUE righette prima di installare linux no?

Loading