PDA

Visualizza la versione completa : Debian - locales


Shenk87
05-10-2005, 19:32
salve a tutti, dopo che mia madre mi ha allegramente distrutto la slackware (2 scattate di contatore in 90 secondi), ho deciso di provare la debian, ho installato la sarge con il netinstall, e poi per avere kde 3.4, cambiando da stable in unstable nel sources.list ho cercato di aggiornarla alla sid. a dire la veritą nn so in che percentuale questo aggiornamento sia stato fatto, nn mi ha messo xorg


X -version
XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-14 20050601051219 fabbione@fabbione.net)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.29-pre2 i686 [ELF]
Build Date: 01 June 2005

This version of XFree86 has been extensively modified by the Debian
Project, and is not supported by the XFree86 Project, Inc., in any
way. Bugs should be reported to the Debian Bug Tracking System; see
<URL: http://www.debian.org/Bugs/Reporting >.

We strongly encourage the use of the "reportbug" package and command
to ensure that bug reports contain as much useful information as
possible.

Before filing a bug report, you may want to consult the Debian X FAQ:
XHTML version: file:///usr/share/doc/xfree86-common/FAQ.xhtml
plain text version: file:///usr/share/doc/xfree86-common/FAQ.gz

Module Loader present
OS Kernel: Linux version 2.6.8-2-386 (horms@tabatha.lab.ultramonkey.org) (gcc version 3.3.5 (Debian 1:3.3.5-12)) #1 Thu May 19 17:40:50 JST 2005

[/CODE]

cmq. il problema principale rimane locales. quando cerco di istallare qualcosa mi esce sempre questo scocciante warning ed inoltre qualche programma (firefox nn si avvia).
[CODE]
debian:/etc# firefox

(firefox-bin:4214): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
Extension System Warning: Failed to set up default extensions files probably because you do not have write privileges to this location. While you can run Firefox like this, it is recommended that you run it at least once with privileges that allow it to generate these initial files to improve start performance. Running from a disk image on MacOS X is not recommended.*** loading the extensions datasource
Extension System Warning: Failed to set up default extensions files probably because you do not have write privileges to this location. While you can run Firefox like this, it is recommended that you run it at least once with privileges that allow it to generate these initial files to improve start performance. Running from a disk image on MacOS X is not recommended.Extension System Warning: Failed to set up default extensions files probably because you do not have write privileges to this location. While you can run Firefox like this, it is recommended that you run it at least once with privileges that allow it to generate these initial files to improve start performance. Running from a disk image on MacOS X is not recommended.Extension System Warning: Failed to set up default extensions files probably because you do not have write privileges to this location. While you can run Firefox like this, it is recommended that you run it at least once with privileges that allow it to generate these initial files to improve start performance. Running from a disk image on MacOS X is not recommended.

e si ripete all'infinito.... :fagiano:


quando cerco di installare qualcosa č questa la tiritera

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "it_IT",
LC_ALL = (unset),
LANG = "it_IT@euro"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory


inoltre ho il problema che dopo l'aggiornamento il nel menu K č rimasto solo segnalibri , termina sessione e browser veloce. :biifu: :biifu:

ho provato dpkg-reconfigure locales , ma nn ho risolto niente
ciao e grazie a chi cercjerą di aiutarmi

andy caps
05-10-2005, 21:19
per locales devi installare i vari pacchetti di locales

tipo aspell-it hspell localeconf myspell-it

poi rifare la configurazione
per i menu prova a lanciare kbuildsycoca
che spesso sistema

altrimenti guarda d installare gli altri file di kde
probabilmente ha fatto un aggiornamento a meta o non ha finito la configurazione

dai un apt-get dist-upgrade
poi i soliti apt-get -f install dpkg --configure -a
per xorg avvia synaptic e guarda di installarlo da li o prova apt-get install x-window-system-core

U-bahn
05-10-2005, 23:50
Originariamente inviato da andy caps
[...]hspell[..]
:confused:
scusa andy caps..., ma cosa se ne fa di questo (http://www.ivrix.org.il/projects/spell-checker/)???

andy caps
06-10-2005, 00:19
:madai!?: si non se ne fa un gran che

io lo metto perche certe compilazioni tipo kde lo richiedono

Loading