PDA

Visualizza la versione completa : problema con apt-get su ubuntu


carlo2002
07-10-2005, 16:15
quando cerco di installare qualcosa ricevo questo messaggio

root@ubuntu:/ # apt-get install gftp
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

cosa devo fare? grazie

francofait
07-10-2005, 16:49
Originariamente inviato da carlo2002
quando cerco di installare qualcosa ricevo questo messaggio

root@ubuntu:/ # apt-get install gftp
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

cosa devo fare? grazie

Per installare pacchetti devi prima acquisire i privilegi root
con ubuntu:
sudo
tua password utente
apt-get install nomeprg
:D :D :D

U-bahn
07-10-2005, 17:00
Originariamente inviato da francofait
Per installare pacchetti devi prima acquisire i privilegi root
con ubuntu:
sudo
tua password utente
apt-get install nomeprg
:D :D :D
sembra che sia gi root :D

root@ubuntu:/ # apt-get install gftp

E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

@carlo2002: dal messaggio di errore, sembra tu stia tentando di fare apt-get con applicazioni tipo synaptic/dselect/aptitude/etc...gi aperte

carlo2002
07-10-2005, 17:02
ho capito, ma come si pu notare dal prompt ero gi come root :messner:

carlo2002
07-10-2005, 17:08
vero scusate, avevo synaptic aperto, comunque ho provato ad installare gftp e adesso mi dice questa cosa qui:

root@ubuntu:/home/carlo # apt-get install gftp
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gftp: Depends: gftp-gtk (= 2.0.18-10) but it is not installable
Depends: gftp-text (= 2.0.18-10) but it is not going to be installed
E: Broken packages


...c' mai qualcosa che vada dritto?
:(

GNUbie
07-10-2005, 17:53
credo di poter dire che ti manca una dipendenza non presente nei tuoi repository

eraclito
07-10-2005, 17:57
Originariamente inviato da GNUbie
credo di poter dire che ti manca una dipendenza non presente nei tuoi repository

si ma molto strano con gftp (io l'ho sempre istallato tranquillamente)

prova a postare il tuo source.list

carlo2002
07-10-2005, 18:46
eccolo
deb cdrom:[Kubuntu 5.04 _Hoary Hedgehog_ - Release i386 (20050407)]/ hoary main restricted
deb cdrom:[Ubuntu 5.10 _Breezy Badger_ - Alpha i386 (20050817)]/ breezy main restricted


## Uncomment the following two lines to fetch updated software from the network
# deb http://it.archive.ubuntu.com/ubuntu breezy main restricted
# deb-src http://it.archive.ubuntu.com/ubuntu breezy main restricted

## Uncomment the following two lines to fetch major bug fix updates produced
## after the final release of the distribution.
# deb http://it.archive.ubuntu.com/ubuntu breezy-updates main restricted
# deb-src http://it.archive.ubuntu.com/ubuntu breezy-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://it.archive.ubuntu.com/ubuntu breezy universe
deb-src http://it.archive.ubuntu.com/ubuntu breezy universe

deb http://security.ubuntu.com/ubuntu breezy-security main restricted
deb-src http://security.ubuntu.com/ubuntu breezy-security main restricted

deb http://security.ubuntu.com/ubuntu breezy-security universe
deb-src http://security.ubuntu.com/ubuntu breezy-security universe


deb ftp://it.archive.ubuntu.com/ubuntu/ breezy main restricted
deb-src ftp://it.archive.ubuntu.com/ubuntu/ breezy main restricted

GNUbie
07-10-2005, 19:07
## Uncomment the following two lines to fetch updated software from the network
# deb http://it.archive.ubuntu.com/ubuntu breezy main restricted
# deb-src http://it.archive.ubuntu.com/ubuntu breezy main restricted

## Uncomment the following two lines to fetch major bug fix updates produced
## after the final release of the distribution.
# deb http://it.archive.ubuntu.com/ubuntu breezy-updates main restricted
# deb-src http://it.archive.ubuntu.com/ubuntu breezy-updates main restricted



leggi il commento, traducilo e applicalo...

carlo2002
07-10-2005, 19:27
grazie raga successa una cosa straordinaria, ad un certo punto venuta fuori una finestrella che diceva di aggiornare il sistema, gli ho dato l'ok, ha caricato un'p di roba e adesso sembra che giri tutto a meraviglia :unz:

:ciauz:

Loading