PDA

Visualizza la versione completa : vfat e permessi


imente
09-10-2005, 13:16
io uso thunderbird contemporaneamente su winzozz e la mia gentoo...

ho messo i file di posta in una vfat e configurato entrambi i thunderbird allo stesso modo

fin qui tutto ok..

da win è tutto a posto, scarico e poi vedo...
da linux posso fare questo giochetto SOLO se uso thunderbird da root (faccio un terminale, su, thunderbird)

questo perchè non ho trovato modo di dare permessi al mio utente sulla vfat

questa è la stringa FSTAB
/dev/hdb6 /dati/scambio vfat noatime,users,umask=0007,gid=100 0 0

le cartelle DATI e SCAMBIO dove monto la vfat sono di proprietà dell'utente e con i permessi a 777

---

idee?
sennò continuo ad aprirlo con root :P

S[p]|llo`
09-10-2005, 13:34
Originariamente inviato da imente
[...]

questa è la stringa FSTAB
/dev/hdb6 /dati/scambio vfat noatime,users,umask=000 0 0
[...]
Prova così

imente
09-10-2005, 14:56
nn so cosa sia UMASK
ma comunque non funziona

niente permessi

S[p]|llo`
09-10-2005, 14:59
questo è il mio fstab (con cui non ho problemi a salvare in partizioni fat)
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda8 / reiserfs notail 0 1
/dev/hda2 /media/boot ext3 defaults 0 2
/dev/hda3 /media/aMule reiserfs defaults 0 0
/dev/hda6 /media/debian reiserfs defaults 0 2
/dev/hda7 /media/torrent ext3 defaults 0 2
/dev/hda1 /media/win ntfs umask=0222 0 0
/dev/hdd5 /media/mediaFilm vfat umask=000 0 0
/dev/hda9 /media/mediaMusic vfat umask=000 0 0
/dev/hdd3 /media/shareData vfat umask=000 0 0
/dev/hdd2 /media/shareLinux vfat umask=000 0 0
/dev/hdd1 /media/shareWin vfat umask=000 0 0
/dev/hda5 none swap sw 0 0
/dev/hdb /media/dvd iso9660 ro,user,noauto 0 0
/dev/hdc /media/masterizzatore iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy auto rw,user,noauto 0 0

imente
09-10-2005, 16:27
perfetto...

un ulteriore piccolo errore mio nella config di thunderbird

grazie :D

Loading