PDA

Visualizza la versione completa : PERL E IIS


lurens
11-10-2005, 15:14
Ciao a tutti,
sono un programmatore Perl, ma ahimè abitando in una zona dove non arriva ancora l'adsl, mi sono dovuto arrangiara facendo girare e interpretare gli script con IIS.
Il problema è il seguente, sto realizando un sito ma il codice, non accetta script perl da file esterni, per intederci, non accetta il "require miofile.pl", che solitamente si utilizza per rendere di più facile lettura script molto lunghi o che hanno molte parti in comune.

Qualcuno sa dirmi come mai?
cosa devo installare su IIS perchè gli script Perl accettino il "require"?

Grazie dell'attenzione
by Lorenzo
web: http://www.12bis.it
email: l.perotti@email.it

:bhò: :dhò: :confused: :master:

Mich_
11-10-2005, 15:21
Che c'entra IIS con l'ADSL?

E che c'entra il tuo computer?

Dove hai il server? Non a casa tua, immagino.
E` connesso alla rete con una linea seria?

Poi se ci metti 10 secondi o 1 minuto per caricare un file sul server non ha nulla a che fare con il linguaggio utilizzato dal server stesso.

Per quanto riguarda il Perl sotto IIS, non ho esperienza, ma puoi sempre cercare sul sito di MSDN: quando avevo probelmi con programmi microsoft ho sempre trovato le risposte e molto chiare.

lurens
11-10-2005, 15:34
Mi spiego meglio:
per motivi di linea lenta e costosa (a casa mia non arriva ancora l'adsl) ed ho quindi solo la 56K a dispo, ho configurato il mio pc in modo tale da poter far girare i miei script Perl in locale, senza dovermi collegare tutte le volte ad internet, e quindi all'ftp del server dove dover caricare i file per testarli....
ma il mio problema è non è il tipo di connessione ma il perchè il perl che viene correttamente interpreatato da IIS, non accetti il comando "require nomefile.pl", cioè l'inclusione dentro ad un file perl, diciamo quello "principale", di un altro file perl.
Intanto proverò a guardare su MSDN....
ma qualcuno sa darmi qualche altro consiglio?

Grazie dell'attenzione
by Lorenzo
web: http://www.12bis.it
email: l.perotti@email.it

shishii
14-10-2005, 19:33
Molto probabilmente c'è un problema di path per trovare il file da includere, per verificarlo usa path assoluti ad esempio:

require C:\percorso\script.pl;

Loading