PDA

Visualizza la versione completa : mplayer e wmv


nik600
14-10-2005, 20:18
ciao a tutti

quando cerco di vedere un file .wmv con mplayer ottengo questo



Playing Capodanno.wmv.
ASF file format detected.
VIDEO: [WMV3] 640x480 24bpp 1000.000 fps 0.0 kbps ( 0.0 kbyte/s)
Clip info:
comments:
================================================== ========================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 20005->176400 (160.0 kbit)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))
================================================== ========================
vo: X11 running at 1400x1050 with depth 24 and 32 bpp (":0.0" => local display)
================================================== ========================
Requested video codec family [wmv9dmo] (vfm=dmo) not available.
Enable it at compilation.
Requested video codec family [wmvdmo] (vfm=dmo) not available.
Enable it at compilation.
Cannot find codec matching selected -vo and video format 0x33564D57.
Read DOCS/HTML/en/codecs.html!
================================================== ========================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Video: no video
Starting playback...
A: 2.7 (02.6) 2.2%


dice enable it at compilation...io ho provato ad aggiungere --enable-dmo...ma nada!


[edit]
l'audio va...solo che non vedo nulla!

andy caps
14-10-2005, 20:47
se hai installato anche i codec di mplayer difficile che non vadano i wma

nik600
14-10-2005, 20:49
forse mi sono spiegato male

--enable-dmo

non va! dice che non un'opzione valida
non c' un'opzione per compilare tutti i driver?

andy caps
14-10-2005, 20:56
dai un ./configure --help

adesso non ho il sorgente per vedere

Ikitt
14-10-2005, 21:03
Originariamente inviato da nik600
forse mi sono spiegato male
--enable-dmo
non va! dice che non un'opzione valida
Infatti non esiste che io sappia (non in mplayer-1.0pre7*).
Devi usare --enable-win32codecs, insomma, l'opzione per abilitare i win32 codecs. i codec 'dmo' sono parte di quelli. Chiaramente poi devi installare anche i win32codecs nel sistema.


non c' un'opzione per compilare tutti i driver?
non che io sappia.

nik600
14-10-2005, 21:31
uff...ma http://www.mplayerhq.hu/ down?

andy caps
14-10-2005, 22:31
http://www4.mplayerhq.hu/homepage/design7/dload.html


prova un mirror

Loading