PDA

Visualizza la versione completa : Alice gate


DMM
23-10-2005, 11:20
Ciao a tutti...
ho bisogno di un vostro aiuto..ora vi spiego.
Sono in possesso del modem ALICE GATE (ADSL) quello a forma di disco con scritto 'Alice' nel centro..
mi sono comprato una scheda di rete economica della CNet (windows xp me la vede come CNet PRO200 PCI Fast ethernet Adapter).
Ho installato mandrake 9.2 l'installazione ha avuto successso ..
Accendo il modem , accendo il pc ed entro in linux mandrake...
a questo punto seguo una guida trovata in questo forum che dice di installare il pacchetto rp-pppoe ,lo installo, da root digito adsl-setup, inserisco i parametri, e digito adsl-start e qui sembra tutto funzionare (anche se a volte probabilmente nn trova il modem xk compaiono dei ' . ' che vanno avanti in segno di attesa)
digito adsl-status e compare questo errore:
ADSL-STATUS:LINK is down (can't read pppoe pid file /var/run/pppoe.conf-adsl.pid.pppoe)

che significa???

Ah..quando avvio mandrake che parte l'inizializzazione del sistema.. alla voce "Attivazione rete eth0: " sta li circa 2 minuti... poi compaiono delle voci strane tipo czip: 125.255.255.255 .. non so cosa significhi..
Le schede di rete sono tutte compatibili con linux?
Secondo voi devo prendere una scheda di rete diversa? me ne consigliate una?
nel pannello di controllo di mandrake nella sezione "rete ed internet"
linux sembra vedermi la scheda eth0 , ma dice che non gli stato assegnato nessun IP e non manco impostato il gateway..

Ragazzi sto sclerando con questi modem (pensate prima avevo il famoso fastrate poi l'ho cambiato appunto xk avevo bisogno di internet sotto linux!!!)

andy caps
23-10-2005, 11:34
da un terminale di root digita ifconfig e controlla che eth0 sia up

spesso il firewall che blocca la connessione

dai il comando
/etc/init.d/shorewall stop per fermarlo

poi controlla i dns in /etc/resolv.conf
metti

nameserver 212.216.112.112
nameserver 212.216.172.62

andy caps
23-10-2005, 11:42
per la scheda prova a scrivere


dmfe

nel file /etc/modprobe.preload

cosi trova il driver gia caricato e dovrebbe impiegare poco tempo

DMM
23-10-2005, 13:15
ok ora provo...
questi comandi sono validi anche per la suse 10.0 ??

andy caps
23-10-2005, 14:11
suse 10 ha la sua utility per configurare la connessione

puoi usare quella

altrimenti devi installare rp-pppoe e poi digitare
pppoe-setup per configurare e pppoe-start per conneterti

DMM
23-10-2005, 14:48
ora provo...
ti faccio sapere...Grazie mille!!

DMM
23-10-2005, 23:18
HO fatto alcune prove e pppoe-start o setup non funzionano (sia come root che come user)

ora viene il bello...
ho digitato il comando kinternet e dopo un paio di secondi compare il seguente errore:
Connection to local and remote server refused.
maybe SMPPD is not running or you are not a member of the group "dialout".
Also check the server setting in the dialog "various settings".

Al che ho indagato e andando nella gestione pacchetti , il demone smppd installato (nn so se parte all'avvio ma credo di si..come si fa a capirlo?)

sono andato nella gestione utenti e ho visto che l'utente fa parte del gruppo "dialout" x cui escludiamo anche la 2 possibile causa...

resta solo di verificare le impostazionei del server.. ma dove?
Datemi una mano please...

Possibile che non si pu capire se x lo meno la scheda di rete e il modem comunichino fra di loro?!?!

DMM
24-10-2005, 00:05
Ragazzi..ci sono quasi...

allora...

i miei problemi si sono quasi risolti... era il firewall che rompeva; l'ho disabilitato del tutto e ora, digitando KINTERNET dalla consolle, mi compare una "spinetta" vicino all'orologio" poi clikkando col destro del mouse, vado su "VISUALIZZA LOG" e mi compare sta roba:

SuSE Meta pppd (smpppd-ifcfg), Version 1.59 on linux.
Status is: disconnected
trying to connect to smpppd
connect to smpppd
Status is: disconnected
Interface is eth0.
Status is: connecting
pppd[0]: Plugin rp-pppoe.so loaded.
pppd[0]: RP-PPPoE plugin version 3.3 compiled against pppd 2.4.3
pppd[0]: Plugin passwordfd.so loaded.
pppd[0]: Timeout waiting for PADO packets
Timeout Waiting for PADO packets. Check your setup and cables and try again.
pppd[0]: Unable to complete PPPoE Discovery
Status is: disconnected
pppd[0] died: Connection terminated at peer's request (exit code 0)

e la connessione non ha successo...

qlk sa dirmi qlk cosa?!?

Grazie...

andy caps
24-10-2005, 01:26
se un modem e non un router devi configurare la scheda come statica prima

adesso probabilmente settata dhcp
dagli un ip tipo 192.168.1.1 e metti i dns (disattivando dhcp dallaconfigrazione della scheda

212.216.112.112
212.216.172.62

poi rifai la configurazione adsl da kinternet

kinternet poiti mette un icona a forma difreccia nella barra delle applicazioni e cliccandocise ha fatto tutto si connette

DMM
24-10-2005, 20:17
ma..in realt credo che faccia da router (il modem l'Alice gate)...

cmq ora tento con le configurazioni che mi hai detto..

ti faccio sapere..grazie ancora!!!

Loading