PDA

Visualizza la versione completa : disabilitare standby su xorg


pannikeos
26-10-2005, 10:00
hola hola .. sto cercando di capire come disabilitare lo standby dello skermo su xorg, qualkuno c'ha mai sbattuto la testa contro?

comunque disabilitare tutto ciò che è acpid (che non cmq non avvio) o apm (pure questo non avviato).

:ciauz:

francofait
26-10-2005, 12:29
Originariamente inviato da pannikeos
hola hola .. sto cercando di capire come disabilitare lo standby dello skermo su xorg, qualkuno c'ha mai sbattuto la testa contro?

comunque disabilitare tutto ciò che è acpid (che non cmq non avvio) o apm (pure questo non avviato).

:ciauz:

editi /etc/lilo.conf e nelle funzioni in append x il kernel poni
acpi=off apm=off
poi rilanci lilo -v x aggiornare il bootloader

Se usi grub invece editi /boot/grub/menu.lst ed aggiorni le funzioni addizionali x il kernel idem come sopra
Poi riavvi

pannikeos
27-10-2005, 12:06
tnx per la risposta, cmq ho capito non è standby, ma bensì un pseudo screensaver .. e non riesco a disabilitarlo.

per caso sai che fare ? :_P

:ciauz:

francofait
27-10-2005, 12:09
Originariamente inviato da pannikeos
tnx per la risposta, cmq ho capito non è standby, ma bensì un pseudo screensaver .. e non riesco a disabilitarlo.

per caso sai che fare ? :_P

:ciauz:

Configura schermo - Salvaschermo - disabilita avvio automatico

mcz
27-10-2005, 13:15
Guarda se in /etc/X11/xorg.conf hai l'opzione DPMS. Sr sì toglila, altrimenti il server X ti manda la schermata nera a prescindere dalle impostazioni dello screensaver dell'interfaccia grafica.

mcz :ciauz:

pannikeos
27-10-2005, 14:18
Option "blank time" "off"

io ho messo così, ma non sembra fungere

mcz
27-10-2005, 15:03
Io ho avuto un risultato positivo con tutti gli S.o che ho provato facendo così:

- disabilitando lo screensaver da KDE
- disabilitando il risparmio energetico dello schermo nel power management (Suse)
- togliendola la riga "option 'dpms'" da xorg.conf
- dando i seguenti comandi da shell:

#xset s off
#xset -dpms

e ha sempre funzionato.

mcz :ciauz:

pannikeos
27-10-2005, 16:01
uso blackbox :) e quindi devo confare direttamente da xorg.conf

Loading