PDA

Visualizza la versione completa : Debian: non va PPP


chaosd
28-10-2005, 09:54
ciao, non so il motivo ma non riesco a collegarmi a internet con la debian sarge
l'ho appena installata da zero, attivato il ppp ma quando lancio Kppp non fa niente, esce e basta
mi era gi successo ed avevo abbandonato dalla disperazione, e avevo notato che da root Kppp partiva ma non rilevava il modem (mi sa che il motivo di fondo proprio questo, nemmeno adesso ci riesco, infatti il rilevamento automatico fallisce nonostante io abbia un modem 56k su /dev/ttyS0, la COM1, e se gliela do manualmente non cambia nulla)

avete qualche suggerimento?

ah, paciugando ho cancellato /etc/ppp e adesso se lancio pppconfig mi dice:

/etc/ppp/peers non presente


che faccio? un guaio? non credo...



:messner:

faxvi
28-10-2005, 10:20
prova ad usare il servizio
pon dsl-provider pero prima di fare tutto cio devi eseguire un
pppoeconf per settare user - passawd e quant'altro..!

S[p]|llo`
28-10-2005, 10:25
Originariamente inviato da faxvi
prova ad usare il servizio
pon dsl-provider pero prima di fare tutto cio devi eseguire un
pppoeconf per settare user - passawd e quant'altro..!
:nonono: Questo per adsl


[...] ...ah, paciugando ho cancellato /etc/ppp e adesso se lancio pppconfig mi dice:
Questa non mi sembra proprio una furbata (usando un termine tennico)

faxvi
28-10-2005, 13:52
scusa ma nn risco a seguirti...che cosa vuoi dire?

chaosd
28-10-2005, 14:29
so che pppoe per l'adsl su schede ethernet e che non il mio caso

per /etc/ppp/peers posso sempre copiare i files che uso nella slackware, ma ci non porta ad una soluzione

andy caps
28-10-2005, 14:47
se kppp esce ci sono problemi nel pacchetto prova ad installare gnome-ppp o wvdial gkdial

prova a reinstallare i pacchetti di ppp
apt-get --reinstal install kppp ppp pppconfig

dai un dmesg | grep tty per vedere se le seriali hanno problemi

chaosd
03-11-2005, 10:08
scusate l'assenza
dunque successa una cosa inspiegabile: non so perch mi venuta l'idea che magari fosse la vecchissima scheda ethernet PCI che ho e che restava inutilizzata (e nemmeno configurata) facesse casino

l'ho rimossa e non cambiato nulla, ovvio no? ma preso dalla disperazione ho reinstallato la debian e ora PPP funziona!

SOLO CHE

kppp non parte! mi dice:

pixel@springfield:~$ kppp
bash: /usr/bin/kppp: Permission denied


adesso provo a paciugare con i permessi, ma la cosa incredibile che io vi sto scrivendo da Debian! mi sono collegato in un modo assurdo: lancio "base-config" da root, "configure and enable PPP"
lui si connette e tutto sembra andare normalmente

ovviamente una situazione inaccettabile!


consigli?



P.S.: come faccio a disconnettermi senza spegnere brutalmente il modem? :stordita:

chaosd
03-11-2005, 10:39
ho parzialmente risolto: per connettermi uso "pon" e disconnettermi "poff"

certo io preferivo il mio amato kppp ma non c' verso di farlo andare

l'unica cosa mi d fastidio il suono che il modem fa quando mi connetto, come faccio a toglierlo? in quale file devo mettere le mani?

alex86
03-11-2005, 11:30
aggiungi l'utente al gruppo kppp

chaosd
03-11-2005, 20:28
Originariamente inviato da alex86
aggiungi l'utente al gruppo kppp

ho provato, ma niente
ho messo anche i permessi per TUTTO all'utente :bh:

Loading