PDA

Visualizza la versione completa : [C++] Installare Allegro su Dev-C++


Linusss
31-10-2005, 16:07
Salve a tutti, ho scaricato l'ultima versione del dev-c++ la 4.9.9.2 e le librerie allegro (4.20).


Intanto quando faccio partire il dev-c++ mi viene furoi questo errore, che si riferisce alle variabili d'ambiente ma non so proprio cosa andare a toccare!!! mi date un mano? :cry:

http://img31.imageshack.us/img31/543/errore0df.jpg


Poi tra i file unzippati delle librerie allegro c' un file txt che spiega come installare le suddette librerie con il dev-c++, ma anche qui mi blocco dove dice questo :dh: :



3. Add 'c:\DevCpp\bin' to the beginning of your PATH environment variable
and set the environment variable MINGDIR to 'c:\DevCpp'. If you use
Windows 9x, you can add the lines

PATH=c:\DevCpp\bin;%PATH%
set MINGDIR=c:\DevCpp

to your 'c:\autoexec.bat' file and reboot. If you use Windows ME, you
can run 'msconfig', select the 'Environment' tab, then modify PATH and
add MINGDIR. If you use Windows NT/2k/XP, you can open the Control
Panel, click the 'System' applet, the 'Advanced' tab and finally the
'Environment' button, then modify PATH and add MINGDIR.


Test the installation by typing the following on the command line:
'gcc -v'. The answer should be similar to:

Reading specs from ../lib/gcc-lib/mingw32/3.2/specs
Configured with: ../gcc/configure --with-gcc --with-gnu-ld
--with-gnu-as --host=mingw32 --target=mingw32 --prefix=/mingw
--enable-threads --disable-nls --enable-languages=f77,c++,objc,ada
--disable-win32-registry --disable-shared
Thread model: win32
gcc version 3.2 (mingw special 20020817-1)

Cosa devo fare?
grazie :)

ps. ho win xp sp2!

gandalf45
31-10-2005, 22:55
Ciao,
che versione di dev-cpp hai scaricato? Con o senza Mingw?
Mi viene il sospetto che tu ti sia scaricato solo dev-cpp senza il resto :)

Fammi sapere

Linusss
01-11-2005, 12:40
Ciao ho installato la versione con gi il MING!

albgen
01-11-2005, 17:28
scarica il devpack che fa tutto lui
http://devpaks.org/details.php?devpak=1
:ciauz:

Linusss
01-11-2005, 18:13
Ciao! Grazie ora credo di aver risolto con Allegro, rimane x quel piccolo problemino che esce quando avvio Dev-C++, sai aiutarmi?

Grazie ancora

albgen
01-11-2005, 20:35
Originariamente inviato da Linusss
Ciao! Grazie ora credo di aver risolto con Allegro, rimane x quel piccolo problemino che esce quando avvio Dev-C++, sai aiutarmi?

Grazie ancora
credo che sia quello che ti ha scritto gandalf.
la versione con il compilatore mingwin incluso nel package distribuito, http://prdownloads.sourceforge.net/dev-cpp/devcpp-4.9.9.2_setup.exe
altrimenti si tratta di un errore di variabili d'ambiente.
per prima che ti possa suggerire altre cose mi devi dire se da dos riesci a compilare o no ?
prova a scrivere make oppure g++?

Linusss
01-11-2005, 21:18
Ma io ho scaricato installato proprio quel file, con il ming compreso.
Cmq scrivendo i comandi che mi hai detto mi dice che non sono riconosciuti come comandi interni o esterni.

Volevo dire una cosa, il dev-c++ l'avevo installato giorni fa e andava bene fin da subito, poi l'ho disinstallato xk nn riuscivo ad usare allegro, in seguito x riprovare l'ho reinstallato e ora da quell'errore, cosa pu essere?

albgen
01-11-2005, 23:22
Originariamente inviato da Linusss
Ma io ho scaricato installato proprio quel file, con il ming compreso.
Cmq scrivendo i comandi che mi hai detto mi dice che non sono riconosciuti come comandi interni o esterni.

Volevo dire una cosa, il dev-c++ l'avevo installato giorni fa e andava bene fin da subito, poi l'ho disinstallato xk nn riuscivo ad usare allegro, in seguito x riprovare l'ho reinstallato e ora da quell'errore, cosa pu essere?
vai su
panello di controllo->sistema->avanzate
poi
clicka su "variabili di ambiente"
nella tabella in basso denominata "variabili di sistema"
clicka su "Path", in fondo(alla fine di tutto quello che c' gi) al campo "valore variabile" inserisci cosi' come la vedi sotto con il punto-virgola(nel mio caso)
----------------------
;G:\PROGRAMMI\Dev-Cpp\bin
----------------------
cio la cartella dove stata installata devc++.
non mni riccordo bene ma credo che di default devc++ installa in C:\Dev-Cpp e quindi se fosse cosi' dovresti aggiungere
-------------------
;C:\Dev-Cpp\bin
-------------------

Linusss
02-11-2005, 13:39
Ciao c'era gi la path tra le variabili...cmq tra i men di dev-c++, in strumenti c' opzioni compilatore, cliccandoci mi da lo stesso errore, quindi mi sa che non settato bene...

In quelle opzioni c' set di compilazione da configurare ed c' solo defoult compiler, in teoria dovrebbe esserci i9l ming giusto? Se cos come faccio a metterlo?

Linusss
02-11-2005, 13:55
Ho reinstallato tutto da capo e ora va!!! ho provato a compilare hello world e funzia!!!

grazie ragazzi x la pazienza!

Loading