PDA

Visualizza la versione completa : Asterisk, Shypho e NAT


ettore8
21-11-2005, 12:04
Ciao a tutti!

Ho installato Asterisk su un pc con il quale voglio fare delle prove ...
ho un account Skypho e tramite X-lite riesco a connettermi tranquillamente e a ricevere telefonate.
Ho provato a configurare su Asterisk un Trunk verso Skypho ma non si collega ...
il problema è sicuramente il NAT infatti, su X-lite ho dovuto configurare STUN e X-Tunnels ... come devo fare per configurarli anche su Asterisk ?

Grazie a chi vorrà rispondere ...

Ciao

ettore

drhilbert
21-11-2005, 18:15
per essere sicuro che la NAT si ben configurata sul tuo asterisk box dovresti aggiungere nel sip.conf una riga dove dichiari il tuo indirizzo ip pubblico. Per farlo quello che ti consiglio di fare e' registrarti gratuitamente un dominio dinamico (lo puoi fare con www.dyndns.org) e usare quello come indirizzo ip esterno.

ecco quello che devi aggiungere nel sip.conf



nat=yes
externip=mio.dominio.com
localnet=192.168.0.0/255.255.255.0


dove chiaramente mio.dominio.com e' il dominio dinamico che ti sei registrato e 192.168.0.0/255.255.255.0 e' l'indirizzo della tua rete privata (attenzione non l'indirizzo ip del * box) e la corrispondente sottorete.

io l'ho configurato cosi' e funziona.

sul sito di skypho trovi una FAQ (http://www.skypho.net/index.php?option=com_content&task=view&id=100&Itemid=73&lang=it) interessante.

Questa sera se ho tempo pubblico tutto il mio file di configurazione...

ciao ciao

ettore8
21-11-2005, 19:11
Avevo già provato ...
precisamente io ho Asterisk@Home .... comunque, se tu hai modo di postare la tua configurazione, mi faresti un immenso piacere !!!

Grazie

ettore

primino
21-11-2005, 20:40
ma Asterisk@Home e'in italiano ?

drhilbert
21-11-2005, 20:45
Originariamente inviato da ettore8
Avevo già provato ...
precisamente io ho Asterisk@Home .... comunque, se tu hai modo di postare la tua configurazione, mi faresti un immenso piacere !!!

Grazie

ettore

anch'io ho asterisk@home. porta pazienza... stasera ho il turno di notte...

ciao ciao

fivendra
21-11-2005, 20:45
si c'è anche la linga italiana e comunque non è che ci sia difficoltà ad usarlo in inglese....
:ciauz:

drhilbert
21-11-2005, 20:46
Originariamente inviato da primino
ma Asterisk@Home e'in italiano ?

asterisk@home è multilingua. dalla prima schermata puoi scegliere la lingua tra cui c'è anche l'italiano...

non nego che una minima conoscenza di inglese aiuta soprattutto nell'interpretare le configurazioni che trovi su vari forum...


ciao ciao

ettore8
21-11-2005, 21:15
Per la lingua nessun problema :D

Grazie a tutti per l'interessamento ..
quando poi avrai voglia/tempo ... se posti la config :D :D

Grassie

:ciauz: :ciauz:

drhilbert
21-11-2005, 23:18
io ho cominciato a impostare asterisk@home dall'interfaccia web usando come guida, secondo me molto buona, in lingua inglese, il documento che si trova a questo indirizzo (http://members.optusnet.com.au/~bsharif/asterisk/AsteriskForDumbMe.htm).

Purtroppo però alcune modifiche richiedo di intervenire direttamente sui file di configurazione. Queste modifiche possono essere fatte entrando nella sezione "maintenance" e poi cliccando su "config edit". A questo punto ti si apre una finestra in cui sulla sinistra c'è l'elenco di tutti i file di configurazione.

Informazione generale, spesso troverai file di configurazione in gruppi da tre con queste caratteristiche:

file1.conf
file1_additional.conf
file1_costum.conf

il primo (quello senza _) rappresenta il file generale, il second (_additional) contiene le modifiche che vengono fatte dal pannello web, il terzo (_costum) contiene ulteriori personalizzazioni che l'utente può fare.

Come prima cosa verifica che il file sip_nat.conf contenga le seguenti righe:



nat=yes
externip=my.dyndomain.com
localnet=192.168.0.0/255.255.255.0


dove my.dyndomain.com è il tuo dominio che ti sei gratuitamente registrato su www.dyndns.org e localnet è l'indirizzo della tua rete con la corrispondente sottorete.

Ecco come ho impostato le cose per skypho

1. mi sono creato una "extension" interno configurando il mio port adapter, oppure lo si può fare anche con il softphone. Le impostazioni sulla schermata web devono essere + o - queste a secondo delle tue preferenze:




[200]
username=200
type=friend
secret=200
record_out=On-Demand
record_in=On-Demand
qualify=yes
port=5060
nat=yes
mailbox=200@default
host=dynamic
dtmfmode=rfc2833
context=from-internal
canreinvite=yes
callerid="200" <200>
disallow=all
allow=ulaw
allow=alaw
allow=g729


2. ho creato un trunk così:
nelle dial rules (ovvero come devono essere composti i numeri) ho inserito



11X
3XXXXXXX.
0ZXXXXX.


il primo per i numeri di emergenza
il secondo per i cellulari
e il terzo per i numeri fissi italiani (per gli stranieri uso un altro provider, ma questa è la lezione 2)

negli outgoing settings ho settato il trunk name in questo modo:



0123456789-out

dove 0123456789 è il mio numero skypho. il nome non ha importanza, ma così ti è più chiaro cosa fa.

nei peer details ho scritto


fromdomain=voip.eutelia.it
fromuser=0123456789
host=voip.eutelia.it
insecure=very
nat=yes
qualify=yes
secret=password
type=peer
username=0123456789


mi raccomando sostituisci password con la tua password di skypho e 0123456789 con il tuo numero!

gli incoming settings sono così:
user context = 0123456789 (ovvero il tuo numero skypho)
e negli user details ho scritto



context=from-sip-external
username=0123456789
type=user
secret=password
nat=yes
insecure=very
host=voip.eutelia.it
fromuser=0123456789
fromdomain=voip.eutelia.it
srvlookup=yes
realm=voip.eutelia.it


nella fondamentale registration string ho scritto


register=0123456789:password:0123456789@voip.eutel ia.it/0123456789


a questo punto, sulla finestra incoming calls, ho selezionato che in qualunque orario le chiamate entranti debbano venire indirizzate verso l'extension 200.

poi, ho creato un outbound routing, che ho chiamato skypho (ancora il nome non ha importanza) ho lasciato la password vuota e nel dial pattern ho inserito i seguenti codici:



0XXXXXXX.
3ZX.
11X


quindi dal menu a tendina ho scelto 0123456789-out.

in questo modo tutte le chiamate che iniziano con 0 o con 3 o con 11 sono instradate attraverso l'account 0123456789-out ovvero il tuo contratto skypho.

ci siamo quasi, l'ultimo sforzo e poi dovrebbe essere finita. vai nella finestra maintenance, seleziona "Config Edit" e dalla nuova finestra clicca su extension.conf. Fallo passare quasi tutto fino a quando arrivi alla sezione [from-sip-external]. Cancella tutto quello che c'è e scrivi:



[from-sip-external]

exten => _X.,1,Goto(from-pstn,s,1)



aggiorna il file cliccando sul bottone update e quindi in alto a destra su "Re-read configs".

A questo punto dovresti essere, come dicono gli americani, all set! configura il tuo telefono come descritto nella guida che ti ho consigliato all'inizio e prova a fare la prima chiamata in uscita magari al tuo telefono di casa. se il telefono suona sei a metà dell'opera. Prova a fare anche la verifica contraria tenendo le dita incrociate, e speriamo in bene...

Vista l'ora a cui ti sto scrivendo e visto che oggi ho fatto il doppio turno, potrei aver scritto un quantità di stupidaggini non indifferenti. se così fosse cercheremo di eliminarle tutte. okki?

ciao e in bocca al lupo...

ettore8
22-11-2005, 20:50
Beh ..grazie mille per la spiegazione dettagliatissima ...

la mia situazione è un pochino più complicata ...

la macchina * è dietro a due NAT ... uno che posso configurare mentre un altro no (Fastweb!) ... un NAT penso si possa *aggirare* nel modo che tu hai descritto ... l'altro lo configuro in modo da reindirizzare le porte al box * .... quali porte ?

Grazie ancora per la disponibilità !

Ciao

ettore

Loading