PDA

Visualizza la versione completa : Dipendenze k3b


Direct8210
23-11-2005, 03:49
Ho aggiornato la debian ma ora ho problemi con le dipendenze nel reinstallare k3b ...

I seguenti pacchetti hanno dipendenze non soddisfatte:
k3b: Dipende: k3blibs (>= 0.11.20) ma non sta per essere installato
Dipende: kdelibs4 (>= 4:3.3.2-1) ma non sta per essere installato
Dipende: libarts1 (>= 1.3.2) ma non sta per essere installato
Dipende: libqt3c102-mt (>= 3:3.3.3) ma non sta per essere installato
E: Pacchetto non integro

qualche consiglio?

Grazie!

andy caps
23-11-2005, 08:15
non sembra aggiornata questa debian
a cosa l'hai aggiornata ?
dai un apt-get dist-upgrade e controlla se deve finire

alkat
23-11-2005, 11:02
sto avendo anch'io problemi con kde e k3b su debian etch da ormai diverse (TROPPE!) settimane.

la situazione sempre questa:


debianix:/home/ale# apt-get install kde
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Alcuni pacchetti non possono essere installati. Questo pu voler
dire che stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o rimossi da incoming.

Poich stata richiesta solo una singola operazione molto facile che
il pacchetto semplicemente non sia installabile, si consiglia
di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
kde: Dipende: kde-amusements ma non sta per essere installato
Dipende: kdeaddons ma non installabile
E: Pacchetto non integro
debianix:/home/ale# apt-get install k3b
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Il pacchetto k3b non ha versioni disponibili, ma ma nominato da un altropacchetto.
Questo significa che il pacchetto manca, diventato obsoletoo disponibile solo all'interno di un'altra sorgente
E: Il pacchetto k3b non ha candidati da installare

il sources.list questo:


debianix:/home/ale# cat /etc/apt/sources.list
# MPLAYER
deb ftp://ftp.nerim.net/debian-marillat/ etch main

# SECURITY
deb http://secure-testing.debian.net/debian-secure-testing/ etch/security-updates main contrib non-free
deb-src http://secure-testing.debian.net/debian-secure-testing/ etch/security-updates main contrib non-free

# ETCH
deb ftp://debian.fastweb.it/debian/ testing main non-free contrib
deb-src ftp://debian.fastweb.it/debian/ testing main non-free contrib

e di k3b non c' traccia nemmeno qui:
http://packages.debian.org/testing/kde/
http://packages.debian.org/testing/allpackages

direi quindi che debian sta avendo qualche problema con kde...

.a.

Direct8210
23-11-2005, 12:42
S avevo gi provato a dare un dist-upgrade ma lui la vede aggiornata ... che fare adesso?
Ho provato anche ad andare su apt-get.org per cercare altri repository per k3b ma niente ... Altri consigli?

Per alkat: io nel sources.list ho qualche repository in pi, se vuoi te li posso dare, ma ti posso assicurare che la situazione non cambia comunque ...

alkat
23-11-2005, 12:46
Originariamente inviato da Direct8210
Per alkat: io nel sources.list ho qualche repository in pi, se vuoi te li posso dare, ma ti posso assicurare che la situazione non cambia comunque ...

s, lo so che non cambia se usi etch (testing).

tu che versione usi? sarge, etch o sid?

.a.

Direct8210
23-11-2005, 13:58
Ma non c' proprio un modo per risolvere questo problema di dipendenze?

alkat
23-11-2005, 14:19
Originariamente inviato da Direct8210
Ma non c' proprio un modo per risolvere questo problema di dipendenze?

aspettare.

oppure, lo installi da unstable. cambi nel tuo source.list le voci che puntanto a testing in unstable e installi k3b. poi risistemi il sources.list. anche se non ce l'hai detto, immagino tu stia usando etch/testing, giusto?

.a.

U-bahn
23-11-2005, 17:58
Originariamente inviato da Direct8210
Ma non c' proprio un modo per risolvere questo problema di dipendenze?

s,...a manina...:D

Direct8210
23-11-2005, 21:35
Come fai tu ogni volta che installi un pacchetto, giusto? :D
Scherzi a parte voleva solo essere una domanda retorica ...

francofait
23-11-2005, 22:17
debian non ha nessun problema kde su etch , ha semplicemente
tolto la versione 3.3.2 e l'ha sostitita a tutto tondo con kde3.4.2 . Visto che lo ha fatto fra domenica notte ed ieri , anche molto probabile che qualche pacchetto ancora manchi all' appello.

Loading