PDA

Visualizza la versione completa : risoluzione sbagliata e successivo errore all avvio


solid-snake
25-11-2005, 11:00
ciao a tutti, col mio portatile avrei un problema di risoluzione: non riesco ad impostare quella corretta ovvero 1280x800. ho provato a lanciare il comando xorgconfig x reimpostarla. solo che devo aver sicuramente sbagliato qualcosa e al riavvio la mia slackware 10.2 al boot si ferma su "x11". cioe carica le periferiche ma quando arriva al monitor si blocca. devo reinstallare tutto o c'e' soluzione + veloce?

U-bahn
25-11-2005, 14:10
puoi ridare #xorgconfig...oppure, più semplicemente:

#nano (o vi o quello che ti pare) /etc/xorg.conf :)

e cerchi le sezioni che ti interessano, nel tuo caso:


Section "Screen"
[...]
DefaultDepth ??
Subsection "Display"
Depth ??
Modes :dottò:
[...]


e, forse...
Section "Monitor"
[...]
HorizSync :dottò:
VertRefresh :dottò:
[...]

modificandole "a piacimento" (:incupito: )


:)

solid-snake
25-11-2005, 14:30
il fatto è che x dare quei comandi l avvio dovrebbe essere completo. io invece mi ritrovo la schermata d avvio in cui si vedono tutti i vari caricamenti: quando arriva a caricare "x11" si blocca

solid-snake
25-11-2005, 14:32
no è che qualcuno è cosi gentile da riuscire a trovarmi il manuale x il monitor del mio notebook hp pavilion zv5000 ? all acquisto del nb nn c era nessun manuale con le caratteristiche del monitor: alcuni mi hanno detto che x configurarlo sotto linux potrei/dovrei usare dei valori (in gradi?) orizzontali e verticali x determinare la risoluzione: ma io come faccio a saperli?

U-bahn
25-11-2005, 15:07
Originariamente inviato da solid-snake
il fatto è che x dare quei comandi l avvio dovrebbe essere completo. io invece mi ritrovo la schermata d avvio in cui si vedono tutti i vari caricamenti: quando arriva a caricare "x11" si blocca

cerca di caricare X anche con l'avvio in 'recovery mode' ?

solid-snake
25-11-2005, 15:20
e come si fa?

U-bahn
26-11-2005, 13:17
se usi grub ti basta aggiungere single in fondo alla riga
kernel /(boot/)?? root=/dev/?? ro

...oppure se hai il cd di una live...

hai provato a premere control+alt+backspace mentre cerca di caricarti X?

solid-snake
28-11-2005, 08:32
no nn avevo provato. stasera lo faccio

Loading