PDA

Visualizza la versione completa : [Debian] Problema con k3blibs


RokStar
28-11-2005, 20:27
Dunque, non mi installa k3blibs per un'incompatibilità con libavcodeccvs



# apt-get install k3blibs
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto

I seguenti pacchetti hanno dipendenze non soddisfatte:
k3blibs: Dipende: libavcodeccvs (>= 3:20051101-0.0) ma 3:20050427-0sarge0.1 sta per essere installato
E: Pacchetto non integro


Quindi mi sono detto, rimuovo libavcodeccvs e riprovo ad installare k3blibs ma



# apt-get remove libavcodeccvs
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
I seguenti pacchetti saranno RIMOSSI:
libavcodeccvs mozilla-mplayer mplayer-386 mplayer-fonts


perderei mplayer...

A me servono entrambi i software, quindi le soluzioni che si prospettano sono due:
1. faccio a meno di uno dei due;
2. compilo a mano uno dei due in modo da non avere problemi di dipendenze causati dal pacchetto.

Entrambe le soluzioni non mi sembrano ottimali. Esiste una via di mezzo per ovviare a ciò?

andy caps
28-11-2005, 21:59
prova a mettere per installare libavcodeccvs provvisoriamente un server della sid ed aggiornare
libavcodeccvs alla versione 20051101-0.0

poi ripristini il sources.list e riprova

nei tuoi server basta sostituire la parola stable con unstable poi dare un apt-get update

RokStar
29-11-2005, 10:19
Originariamente inviato da andy caps
prova a mettere per installare libavcodeccvs provvisoriamente un server della sid ed aggiornare
libavcodeccvs alla versione 20051101-0.0

poi ripristini il sources.list e riprova

nei tuoi server basta sostituire la parola stable con unstable poi dare un apt-get update
Ehm... è già una sid la debian che utilizzo, di conseguenza tutti i repository sono unstable. Non so perché per k3blibs viene richiesto un pacchetto di sarge :confused:

francofait
29-11-2005, 10:24
Originariamente inviato da RokStar
Ehm... è già una sid la debian che utilizzo, di conseguenza tutti i repository sono unstable. Non so perché per k3blibs viene richiesto un pacchetto di sarge :confused:
Prendi l'aggiornamento k3b dalla experimental, è completo e va alla grande.

Loading