PDA

Visualizza la versione completa : synaptic non installabile


jaso
30-11-2005, 18:35
ciao ragazzi ho provato a installre synatpic e questo il risultato:

apt-get install synaptic
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Alcuni pacchetti non possono essere installati. Questo pu voler
dire che stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o rimossi da incoming.

Poich stata richiesta solo una singola operazione molto facile che
il pacchetto semplicemente non sia installabile, si consiglia
di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
synaptic: Dipende: libgtk2.0-0 (>= 2.8.0) ma 2.6.10-2 sta per essere installato
Dipende: libpango1.0-0 (>= 1.10.1) ma 1.8.2-3 sta per essere installato
E: Pacchetto non integro
bestione:/home/alex#


e cosi come amule:
apt-get install amule
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Alcuni pacchetti non possono essere installati. Questo pu voler
dire che stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o rimossi da incoming.

Poich stata richiesta solo una singola operazione molto facile che
il pacchetto semplicemente non sia installabile, si consiglia
di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
amule: Dipende: libcrypto++5.2c2 ma non installabile
E: Pacchetto non integro


come risolvo?

ho debian sid

andy caps
30-11-2005, 21:44
:master: cambia sources.list ilpossibile che dia questi problemi

metti anche il mio

http://andycaps.it/sources.list

jaso
01-12-2005, 18:16
alex@bestione:~$ cat /etc/apt/sources.list

#deb cdrom:[Debian GNU/Linux testing _Etch_ - Official Snapshot i386 Binary-1 (20051110)]/ etch contrib main

#deb cdrom:[Debian GNU/Linux testing _Etch_ - Official Snapshot i386 Binary-1 (20051110)]/ etch contrib main

deb ftp://ftp.it.debian.org/debian/ unstable main
deb-src ftp://ftp.it.debian.org/debian/ unstable main
alex@bestione:~$


questo il mio sources.list che cosa che non va?

KaZaA
01-12-2005, 19:00
D lo stesso errore anke a me...dopo l'ultimo aggiornamento mi ha disinstallato synaptic e mi kiede libgtk2.0-0 (>= 2.8.0) e libpango1.0-0 (>= 1.10.1) x reinstallarlo...ke esoso ke apt-get...

U-bahn
01-12-2005, 19:13
soluzione...

scaricate i seguenti pacchetti (vengono dalla experimental, fate un po' voi :bh: ):


http://ftp.it.debian.org/debian/pool/main/s/synaptic/synaptic_0.57.6_i386.deb
http://ftp.it.debian.org/debian/pool/main/p/pango1.0/libpango1.0-0_1.10.1-1_i386.deb
http://ftp.it.debian.org/debian/pool/main/p/pango1.0/libpango1.0-common_1.10.1-1_i386.deb
http://ftp.it.debian.org/debian/pool/main/g/gtk+2.0/libgtk2.0-0_2.8.8-1_i386.deb
http://ftp.it.debian.org/debian/pool/main/g/gtk+2.0/libgtk2.0-bin_2.8.8-1_i386.deb
http://ftp.it.debian.org/debian/pool/main/g/gtk+2.0/libgtk2.0-common_2.8.8-1_all.deb

...assicuratevi di avere apt e apt-utils aggiornate alla 0.6.43..
e date
#dpkg -i libgtk2.0-0_2.8.8-1_i386.deb \
libgtk2.0-bin_2.8.8-1_i386.deb libgtk2.0-common_2.8.8-1_all.deb \
libpango1.0-0_1.10.1-1_i386.deb libpango1.0-common_1.10.1-1_i386.deb\
synaptic_0.57.6_i386.deb

:ciauz:

KaZaA
01-12-2005, 19:38
Risolto...grazie mille U-Bahn :D :D

RokStar
02-12-2005, 19:25
Originariamente inviato da andy caps
:master: cambia sources.list ilpossibile che dia questi problemi

metti anche il mio

http://andycaps.it/sources.list
Ho letto la tua source.list.

Ma i pacchetti presi un po' in giro dalla unstable, sarge ed experimental non fanno casino con le dipendenze? :master:

Se mi dici che quello un source.list che fa bene il suo lavoro integro i server che mancano alla mia source.list.

jaso
02-12-2005, 20:36
ok avete risolto per synaptic ma per amule?

apt-get install amule
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Alcuni pacchetti non possono essere installati. Questo pu voler
dire che stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o rimossi da incoming.

Poich stata richiesta solo una singola operazione molto facile che
il pacchetto semplicemente non sia installabile, si consiglia
di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
amule: Dipende: libcrypto++5.2c2 ma non installabile
E: Pacchetto non integro

U-bahn
02-12-2005, 21:01
libcrypto++5.2c2...dalla testing

#wget ftp.it.debian.org/debian/\
pool/main/libc/libcrypto++/libcrypto++5.2c2_5.2.1c2-8_i386.deb
#dpkg -i libcrypto++5.2c2_5.2.1c2-8_i386.deb
#apt-get install amule

......:D.....

Loading