PDA

Visualizza la versione completa : installazione programmi


newscripter
08-12-2005, 17:59
ciao ragazzi sono nuovo nel campo e scusate anticipatamente se le mie domande risulteranno molto banali...
cmq io ho un serio problema con l'installazione di un qualsiasi programma per esempio con i pacchetti .tar.gz
ogni volta che faccio ./configure mi da dei problemi e so che dipende dal fatto che mi mancano delle librerie o altri elementi o non so cos'altro. come faccio a sapere cosa mi manca e di cosa ho bisogno?
dato che l'argomento molto vasto, a qunto ne so, invece di cercare spiegazioni qui, potete consigliarmi dove trovare la documentazione riguardante queto argomento specifico?

grazie mille

andy caps
08-12-2005, 18:05
l'installazione dei programmi varia da distro a distro
la cosa migliore usare i tool della tua

ogni distribuzione ha del tool per scaricare cercare ed installare i programmi direttamente dai server

compilare i sorgenti richiede una conoscenza minima del sistema e di linux spesso
bisogna avere i tool per compilare

gcc make binutils cpp automake autoconf etcetera
e installare precedentemente le librerie che servono al programma
se ad esempio un programma riguarda le gtk installare le gtk compreso magari anche i -dev o -devel

newscripter
08-12-2005, 18:26
per curiosita ho provato ad installare ubuntu... so che nuova e magari ancora acerba come distro ma deriva dalla debian...insomma ero curioso...
non so forse faccio piu fatica ad imparare con questa versione?
ne avevo provate altre ma mi fermavo sempre allo stesso punto quando ora di compilare i file...heheh
ora sono deciso ad imparare anche perch una cosa fondamentale...sarebbe come usare windows senza il mouse...heheh
bhe se avete altri suggerimenti da darmi li apprezze altrimenti grazie lostesso :) ciao

andy caps
08-12-2005, 19:09
per installare i programmi con ubuntu basta cercarli e installarli con apt o synaptic :bh:

al massimo devi correggere il /etc/apt/sources.list per avere tutti quanti i programmi a disposizione

nei server di ubuntu c' tutto quello che in genere si usa :bh:

cerca nel forum ubuntu sources.list

alkat
08-12-2005, 19:16
Originariamente inviato da newscripter
per curiosita ho provato ad installare ubuntu... so che nuova e magari ancora acerba come distro ma deriva dalla debian...insomma ero curioso...

sar acerba la distro (e aspettati di essere fucilato da qualche ubuntomaniac per quest'affermazione) ma il sistema di installazione dei pacchetti uno dei migliori che ci sia in giro: apt-get.

se impari ad usare quello non hai assolutamente bisogno di compilare (a meno che tu non abbia richieste ed esigenze veramente esotiche).




ne avevo provate altre ma mi fermavo sempre allo stesso punto quando ora di compilare i file...heheh
ora sono deciso ad imparare anche perch una cosa fondamentale...sarebbe come usare windows senza il mouse...heheh

se ritieni che usare una distribuzione senza saper compilare un programma sia come "usare windows senza il mouse" mi sa che sei proprio fuori strada... ma proprio tanto.

io, da che uso Debian, non ho mai avuto bisogno di compilare un solo programma. credo mi sia capitato qualche volta con Archlinux o con altre distro meno ricche di pacchetti precompilati, ma se usi Ubuntu non dovresti proprio averne bisogno: ti complicheresti solo inutilmente la vita.

comunque, se proprio ti vuoi "divertire", nei file che scarichi e che vuoi compilare dovresti trovare tutte le istruzioni del caso e le relative dipendenze da installare in un file README o INSTALL o simile.

ad ogni modo, c' talmente tanto da imparare su Linux che non perderei tempo dietro la compilazione di programmi visto che praticamente ogni distribuzione ha un buon programma per la gestione dei pacchetti.

.a.

newscripter
09-12-2005, 00:24
grazie per le informazioni :)

newscripter
09-12-2005, 01:44
ho provato a usare apt-get per il programma licq.deb
ho digitato: ovviamnte nella cartella dove c' il pacchetto:
apt-get install licq.deb parte e il risultato :

root@xxx:/home/xxx/programmi # apt-get install licq.deb
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
E: Impossibile trovare licq.deb

ho fatto anche l'update di apt perch ho letto che meglio farlo ma mi da sempre la stessa cosa

dimenticavo... ho provato ad accedere al /etc/apt/sources.list per fare delle modifiche che ho trovato online... ma mi dice sempre: acces denied anche se mi loggo come root...
perch succede cio?

ho provato un altra soluzione ma ho buttato benzina sul fuoco: il risultato il seguente:

root@xxx:/home/xxx/programmi # dpkg -i licq.deb
Selezionato il pacchetto licq, che non lo era.
(Lettura del database ... 58581 file e directory attualmente installati.)
Spacchetto licq (da licq.deb) ...
dpkg: problemi con le dipendenze impediscono la configurazione di licq:
licq dipende da libc6 (>= 2.3.5-1); comunque:
La versione di libc6 nel sistema 2.3.2.ds1-20ubuntu13.
licq dipende da libgcc1 (>= 1:4.0.2); comunque:
La versione di libgcc1 nel sistema 1:4.0-0pre6ubuntu7.
licq dipende da libgpg-error0 (>= 1.1); comunque:
La versione di libgpg-error0 nel sistema 1.0-1.
licq dipende da libssl0.9.8 (>= 0.9.8a-1); comunque:
Il pacchetto libssl0.9.8 non installato.
licq dipende da libstdc++6 (>= 4.0.2-4); comunque:
Il pacchetto libstdc++6 non installato.
licq dipende da licq-plugin-qt | licq-plugin; comunque:
Il pacchetto licq-plugin-qt non installato.
Il pacchetto licq-plugin non installato.
dpkg: errore processando licq (--install):
problemi con le dipendenze - lasciato non configurato
Sono occorsi degli errori processando:
licq

alkat
09-12-2005, 08:41
Originariamente inviato da newscripter
ho provato a usare apt-get per il programma licq.deb
ho digitato: ovviamnte nella cartella dove c' il pacchetto:
apt-get install licq.deb parte e il risultato :

mica tanto ovviamente... apt-get non cerca i pacchetti nelle cartelle in cui lo avvii.

forse meglio se cerchi di capire come funziona:
http://www.debian.org/doc/manuals/apt-howto/index.it.html




root@xxx:/home/xxx/programmi # apt-get install licq.deb
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
E: Impossibile trovare licq.deb

ho fatto anche l'update di apt perch ho letto che meglio farlo ma mi da sempre la stessa cosa


quello non pu essere il nome di un pacchetto. con apt-get devi specificare il nome corretto del pacchetto che vuoi installare (nel tuo caso licq) - in alternativa, installa synaptic cos hai un'ottima interfaccia grafica per apt.



dimenticavo... ho provato ad accedere al /etc/apt/sources.list per fare delle modifiche che ho trovato online... ma mi dice sempre: acces denied anche se mi loggo come root...
perch succede cio?


questo strano. esattamente cosa fai per "accedere" a quel file?

normalmente, basta che ti autentichi come root e poi lanci un qualunque editor di testo, esempio:
# kwrite /etc/apt/sources.list
oppure
# gedit /etc/apt/sources.list
o ancora
# nano /etc/apt/sources.list

e cos per tutti gli altri mille mila editor disponibili.




ho provato un altra soluzione ma ho buttato benzina sul fuoco: il risultato il seguente:

root@xxx:/home/xxx/programmi # dpkg -i licq.deb
Selezionato il pacchetto licq, che non lo era.
(Lettura del database ... 58581 file e directory attualmente installati.)
Spacchetto licq (da licq.deb) ...
dpkg: problemi con le dipendenze impediscono la configurazione di licq:
licq dipende da libc6 (>= 2.3.5-1); comunque:
La versione di libc6 nel sistema 2.3.2.ds1-20ubuntu13.
licq dipende da libgcc1 (>= 1:4.0.2); comunque:
La versione di libgcc1 nel sistema 1:4.0-0pre6ubuntu7.
licq dipende da libgpg-error0 (>= 1.1); comunque:
La versione di libgpg-error0 nel sistema 1.0-1.
licq dipende da libssl0.9.8 (>= 0.9.8a-1); comunque:
Il pacchetto libssl0.9.8 non installato.
licq dipende da libstdc++6 (>= 4.0.2-4); comunque:
Il pacchetto libstdc++6 non installato.
licq dipende da licq-plugin-qt | licq-plugin; comunque:
Il pacchetto licq-plugin-qt non installato.
Il pacchetto licq-plugin non installato.
dpkg: errore processando licq (--install):
problemi con le dipendenze - lasciato non configurato
Sono occorsi degli errori processando:
licq

ma scusa un attimo, da dove hai scaricato quel licq.deb? non ha molto senso andare in giro per la rete a cercare pacchetti strani.

prima prova con:
# apt-get install licq

se non trova nulla, allora cerca informazioni specifiche per Ubuntu nel loro sito (ci sar di sicuro una lista dei repository) oppure vai su www.apt-get.org, cerchi il pacchetto e aggiungi (anche solo temporaneamente) il server al tuo sources.list.



prima di fare qualunque altra cosa per, cerca di capire come funziona apt-get altrimenti continui a girare a vuoto per nulla.

.a.

newscripter
09-12-2005, 09:40
ah scusa io ho scritto licq.deb per abbreviare in realta il nome comprende anche la versione ora non ricordo (sto scrivendo da windows non riesco andare a vedere) cmq l'ho scaricato dal sito ufficiale licq.

cmq provo a documentarmi mi rendo conto che le cose da sapere sono un po intanto grazie per le dritte e scusate la mia ignoranza
portate pazienza :zizi: :zizi:

ciao

Loading