PDA

Visualizza la versione completa : salvare dns su mandriva


supertrack
08-12-2005, 19:28
Ho avuto problemi a collegarmi a internet con l'adsl di alice su linux, e dopo molte ricerche ho capito che modificando i dns avrei risolto il problema. Infatti una volta inseriti la connessione funziona, però dopo il riavvio o li rimetto o non funziona, Sono nuovo di linux, uso tutto su interfaccia grafica, senza i comandi adsl start o altro. Uso il configura computer del kde. Come faccio a salvarli?
Grazie dell'aiuto!

andy caps
08-12-2005, 21:02
da configura il computer puoi metterli nella configurazione guidata

per salvarli pero' se non lo hai fatto la prima volta devi scriverli in /etc/resolv.conf e poi commentare con il segno ## davanti la riga usepeerdns in /etc/ppp/options

puoi farlo anche da interfaccia grafica basta che fai il login di root in un terminale con il comando

su
+ la passwd di root
poi basta scrivere konqueror in quella consolle ed andare a modificare i files

supertrack
10-12-2005, 16:18
Ho fatto tutto quello che hai detto tu, però non cambia nulla, al riavvio il file resolv.conf conserva i dns, mentre nella modalità grafica i dns non ci sono...devo precisare che il file all'avvio non c'è se non in modalità resolv.conf.save..solo dopo che resetto la connessione e la rifaccio riuscendomi a collegare il file risulta così:

nameserver 62.94.0.1
nameserver 62.94.0.2
# MADE-BY-RP-PPPOE

# ppp temp entry
nameserver 85.37.17.8 # ppp temp entry
nameserver 151.99.125.1 # ppp temp entry

E' corretto?

Trovo resolv.conf.save
nameserver 62.94.0.1
nameserver 62.94.0.2
# MADE-BY-RP-PPPOE

# ppp temp entry

Trovo anche resolv.conf.bat
nameserver 212.216.112.112
nameserver 212.216.172.62


e anche Resolv.conf in etc/ppp/ è
nameserver 212.216.112.112
nameserver 212.216.172.62

Invece il per il file pppoe.conf avevo messo i due ## dove dicevi tu, ma da quando ho provato a fare la configurazione da shell con adsl-setup, non mi da più i comandi di prima! Magari quando riavvio torna apposto visto che i comandi da shell li ho dati in questa sessione.
Cmq i dns che ho dato sono 62.94.0.1 e 2, mentre quelli che iniziano con 212 li avevo messi dall'installazione da shell!
Dimmi quello che devo fare, non posso fare casini ogni volta che devo collegarmi..

supertrack
10-12-2005, 16:20
Scusa ho sbagliato file, quello che dicevi tu era option

lock
noauth
noipdefault
##usepeerdns
è come dicevi tu no??

mykol
10-12-2005, 20:21
non credo che il file sia /etc/reslv.conf.save

sto .save alla fine credo che glie l'abbia appiccicato l'editor che hai usato per modificarlo.

Rinominalo in modo corretto e fai come ti ha detto andy caps.

Gli altri file non toccarli.

Loading