PDA

Visualizza la versione completa : Mandriva2005 - USB e Modem


Anuelicon
12-12-2005, 20:10
Ciao a tutti, so che sono stati postati gi alcuni thread sulla configurazione di Linux per modem USB ma io credo di avere un problema leggermente diverso e vorrei un supporto da gente sicuramente pi esperta di me.
La disribuzione la Mandriva 2005LE, il modem USB Speedtouch 330 THOMSON colore silver.
Ho fatto diversi tentativi nella speranza di andare finalmente in internet con Linux ma nessun esito positivo.
Eppure mi sembra di avere tutto quello che mi serve, ho il firmware scaricato dal sito ufficiale di speedtouch, ho installato correttamente tutti i pacchetti che mi servivano:
# liblinux-atm
# ppp-pppoatm
...ce ne sono altri ??
Ho seguito varie strade...utilizzando anche uno script speedtouchconf.sh cherichiede anche bc ...
Credo che il problema non risieda nella configurazione sbagliata ma proprio nelle porte USB.
Infatti, nonostante connesso al computer, il modem non da alcun segno di vita...Al boot si accendono per un istante i due led verdi e poi si spengono e cos restano...Come se le porte USB non fossero alimentate...Nemmeno la chiavetta USB viene riconosciuta!
Inoltre ho notato che il boot del sistema estremamente pi lento quando ho il modem USB collegato...Ci metto infatti pi o meno 2 minuti per arrivare al login, se invece il modem rimane scollegato risolve tutto in 45 secondi...Per voi normale ??
Potete aiutarmi a risolvere i miei problemi per favore??io non so pi dove mettere le mani.
Grazie a tutti...
:ciauz:

andy caps
12-12-2005, 21:38
scrivi i mouduli in

/etc/modprobe.preload
con un editor di testo da root
scrivendoli li poi il sistema viene forzato a caricarli al boot

scrivi per le porte
uhci-hcd
ehci-hcd
ohci-hcd

poi per la chiavetta
usb-storage

prova a mettere anche per il modem
speedtch

Meskalamdug
12-12-2005, 22:34
http://xoomer.virgilio.it/meskalamdug/speedtouch.html

Prova e fammi sapere.

Anuelicon
13-12-2005, 10:28
Buongiorno...per prima cosa vi ringrazio per le risposte tempestive :)

Andy caps
Ho provato a inserire nel file modprobe.preload quello che mi hai suggerito, al boot non cambia niente, si comporta come prima sia nel fattore tempo (che molto pi lungo quando c' il modem) sia nel fattore LED del modem che rimangono spenti.
Se ti pu essere di aiuto chiedimi pure qualche file di log da postare o da inviarti, lo farei io ma non so quale potrebbe essere utile e dove andare a prenderlo.
/var/log/syslog lunghissimo...non mi sembra il caso di postarlo qui :rollo:
Comunque non so se conta qualcosa ma al boot, premendo ESC per i dettagli, ci sono sempre state le voci
Inizializzazione del controller uhci-hcd [OK]
Inizializzazione del controller ehci-hcd [OK]
Monto il filesystem USB
(qui ci mette un sacco di tempo per darmi l'OK ma alla fine lo da)

Meskalamdug
Ho dato un'occhiata alla tua pagina, sicuramente una gran guida, dettagliata e tra l'altro con screenshoot sicuramente utili, ma io non ho mai ricompilato il kernel, so che una procedura abbastanza delicata

:oVVoVe: sei proprio sicuro che non ci sia un altro modo?
Inoltre nonostante la tua guida sia scritta bene ne vorrei sott'occhio una della mia distribuzione prima di cominciare questa procedura. Ho notato inoltre dal titolo che fai riferimento al modem Alcatel...Il mio THOMSON non c' nessuna differenza tra i due (per quanto riguardala configurazione)??
Seguendo comunque la tua guida mi sono fermato alle prime righe poich
/etc/rc.d/rc.hotplug
da me non esiste e non so se ho i sorgenti del kernel (come lo verifico??)

forse se ci fosse un'altra strada sarebbe meglio :cry:

:ciauz: :ciauz: :ciauz:

Meskalamdug
13-12-2005, 21:10
Originariamente inviato da Anuelicon
Buongiorno...per prima cosa vi ringrazio per le risposte tempestive :)

Andy caps
Ho provato a inserire nel file modprobe.preload quello che mi hai suggerito, al boot non cambia niente, si comporta come prima sia nel fattore tempo (che molto pi lungo quando c' il modem) sia nel fattore LED del modem che rimangono spenti.
Se ti pu essere di aiuto chiedimi pure qualche file di log da postare o da inviarti, lo farei io ma non so quale potrebbe essere utile e dove andare a prenderlo.
/var/log/syslog lunghissimo...non mi sembra il caso di postarlo qui :rollo:
Comunque non so se conta qualcosa ma al boot, premendo ESC per i dettagli, ci sono sempre state le voci
Inizializzazione del controller uhci-hcd [OK]
Inizializzazione del controller ehci-hcd [OK]
Monto il filesystem USB
(qui ci mette un sacco di tempo per darmi l'OK ma alla fine lo da)

Meskalamdug
Ho dato un'occhiata alla tua pagina, sicuramente una gran guida, dettagliata e tra l'altro con screenshoot sicuramente utili, ma io non ho mai ricompilato il kernel, so che una procedura abbastanza delicata

:oVVoVe: sei proprio sicuro che non ci sia un altro modo?
Inoltre nonostante la tua guida sia scritta bene ne vorrei sott'occhio una della mia distribuzione prima di cominciare questa procedura. Ho notato inoltre dal titolo che fai riferimento al modem Alcatel...Il mio THOMSON non c' nessuna differenza tra i due (per quanto riguardala configurazione)??
Seguendo comunque la tua guida mi sono fermato alle prime righe poich
/etc/rc.d/rc.hotplug
da me non esiste e non so se ho i sorgenti del kernel (come lo verifico??)

forse se ci fosse un'altra strada sarebbe meglio :cry:

:ciauz: :ciauz: :ciauz:
Devi semplicemente adattarla alla mdk,visto che e' riferita a slack.
Tu ti scarichi i firmware per lo speedtouch argento,li metti in lib/firmware(se non ce la crei),poi editi i file options,e resolv.conf come indicato per la guida e dai pppd
la parte del kernel la puoi anche ignorare..

Anuelicon
15-12-2005, 11:16
Ciao Meskalamdug ...ho seguito le tue indicazioni.
Ti spiego passo per passo cosa ho fatto e cosa successo
PREMESSA: Ho reinstallato l'intera Mandriva, visto che avevo fatto diversi tentativi. Ho installato anche i moduli necessari: pppoatm e liblinuxatm

Ho dovuto creare la cartella /lib/firmware perch non esisteva, poi ho copiato i 2 file per il mio modem (silver della thomson) all'interno.
Ho attaccato il modem, e qui successa una cosa un po strana... comparsa una finestra di Kwrite dispositivo in ascolto /dev/pts
Il messaggio diceva Disabling IRQ #21...lo stesso messaggio comparso nella shell che avevo aperto...Da li non si mosso, ho aspettato un bel po per vedere se magari era questione di tempo...Essendo bloccato ho aperto un'altra schell per editare tutti i file...
Ah, i led del modem hanno fatto un lapeggio fulmineo appena collegato e poi sono rimati accesi fissi.
Ho editato i file seguento esattamente la tua guida, quindi tutto quello che ci sta in /etc/ppp (non l'ho dovuta creare, esisteva gi)
Ho messo a posto anche i dns...
lancio pppd
questo quello che mi dice :

pppd: /usr/lib/pppd/2.4.4b1/plugins/pppoatm.so: cannot open shared abject file: No such file or directory

pppd: Couldn't load plugin /usr/lib/pppd/2.4.4b1/plugins/pppoatm.so

e mi ritorna al prompt.
Gli stessi errori me li segnala anche se il modem non attaccato, quindi suppongo che nemmeno ci dialoga.
Un'ultima segnalazione...se ho il modem collegato non riesco ad entrare nel centro di controllo...una volta inserita la password di root resta fermo sull'immagine dell'attesa...devo chiudere la sessione, staccare il modem e loggarmi di nuovo...cos funziona tutto...Secondo voi cosa c' che non va nel mio USB che lo disturba cos tanto ?!?!
:cry:
Ciao a tutti e grazie

Anuelicon
15-12-2005, 11:37
AIUTO
Ho un'altra scolvolgente segnalazione di MALFUNZIONAMENTO.
ho risolto il poblema del pppd segnalato nel mio post di 5 minuti fa...in pratica nel file optins bastava mettere plugin pppoatm.so senza l'indirizzo assoluto /usr/...ecc
infatti ho provato a lanciare pppd da shell e mi ha dato:

Plugin pppatm.so loaded
PPPoATM plugin_init
PPPoATM serdevname - remove unwanted options
PPPoATM setdevname_pppoatm - SUCCESS:8.35

Non avevo il modem attaccato ma non penso fosse un problema quindi euforico ho riattaccato il modem alla stessa porta usb di prima...NIENTE !!!
Non successo nulla...Nessuna segnalazione su shell e le luci sono rimaste spente per una decina di secondi, poi la luce rossa dell'USB del modem ha cominciato a lampeggiare...ha lampeggiato per 1 minuto circa e si spenta...ecos rimasto tutto.
Se rilancio pppd mi scrive esattamente le stesse cose di prima ma essendo tutti i LED spenti dubito che l'ADSL sia allineata :dott:
:master: :master: :master:
Quindi ora il mio problema che se attacco il modem non resta pi acceso :(

Meskalamdug
15-12-2005, 19:20
Originariamente inviato da Anuelicon
Ciao Meskalamdug ...ho seguito le tue indicazioni.
Ti spiego passo per passo cosa ho fatto e cosa successo
PREMESSA: Ho reinstallato l'intera Mandriva, visto che avevo fatto diversi tentativi. Ho installato anche i moduli necessari: pppoatm e liblinuxatm

Ho dovuto creare la cartella /lib/firmware perch non esisteva, poi ho copiato i 2 file per il mio modem (silver della thomson) all'interno.
Ho attaccato il modem, e qui successa una cosa un po strana... comparsa una finestra di Kwrite dispositivo in ascolto /dev/pts
Il messaggio diceva Disabling IRQ #21...lo stesso messaggio comparso nella shell che avevo aperto...Da li non si mosso, ho aspettato un bel po per vedere se magari era questione di tempo...Essendo bloccato ho aperto un'altra schell per editare tutti i file...
Ah, i led del modem hanno fatto un lapeggio fulmineo appena collegato e poi sono rimati accesi fissi.
Ho editato i file seguento esattamente la tua guida, quindi tutto quello che ci sta in /etc/ppp (non l'ho dovuta creare, esisteva gi)
Ho messo a posto anche i dns...
lancio pppd
questo quello che mi dice :

pppd: /usr/lib/pppd/2.4.4b1/plugins/pppoatm.so: cannot open shared abject file: No such file or directory

pppd: Couldn't load plugin /usr/lib/pppd/2.4.4b1/plugins/pppoatm.so

e mi ritorna al prompt.
Gli stessi errori me li segnala anche se il modem non attaccato, quindi suppongo che nemmeno ci dialoga.
Un'ultima segnalazione...se ho il modem collegato non riesco ad entrare nel centro di controllo...una volta inserita la password di root resta fermo sull'immagine dell'attesa...devo chiudere la sessione, staccare il modem e loggarmi di nuovo...cos funziona tutto...Secondo voi cosa c' che non va nel mio USB che lo disturba cos tanto ?!?!
:cry:
Ciao a tutti e grazie
Che kernel stai usando?
Sei sicuro di aver messo i firmwares corretti?
Prova gli altri firmrwares,appena attacchi il modem devono lampeggiare le lucine.

andy caps
15-12-2005, 20:19
con madriva probabilmente devi arrestare anche il firewall se attivo

/etc/init.d/shorewall stop
/etc/init.d/iptables stop

prova anche a vedere se ci sono errori sulle usb

dmesg | grep usb

oppure
tail /var/log/messages

assicurati di avere installato tutti i files necessari da terminale dai

urpmi -y usb (ed installa i vari usbutils usbview )


urpmi -y atm ( ed installa i vari ppp-pppoatm linux-atm
urpmi usbutils usbview ppp-pppoatm
sulla mandiva cooker ho visto che si trova anche il pacchetto specifico speedtouch

urpmi -y speedtouch se lo trova

Anuelicon
16-12-2005, 09:28
Buongiorno a tutti...allora vediamo, sono pronto a relazionarvi ci che successo.
I firmware sono sicuro chesiano giusti Meskalamdug, quando ho seguito una guida (mi pare che fosse quella su www.linux-usb.org) ho effettuato il controllo, infatti se collego il modem e accendo il computer si pu vedere in
/proc/bus/usb/device
che presente un Vendor=THOMSON Rev=4
Varie fonti su internet e tutte le guide trovate (compresa la tua) affermano che il modello Revision 4 quello color argento (proprio come il mio) quindi sono sicuro al 100% di avere con me il firmware corretto.
Il kernel il 2.6.11.
Penso di aver ottenuto dei risultati (non buoni ma almeno visibili) con i consigli di Andy...
premetto che avevo gi provveduto a disabilitare tutti i firewall durante le mie prove precedenti.
Tutti i file che mi hai citato sono presenti sul mio sistema...anche facendo
urpmi -y speedtouch
dice:E' gi tutto installato
Ho notato invece errori nei log.
Ho eseguito in un'altra shell il comando
tail -f /var/log/message
e subito dopo ho collegato il modem alla porta USB...
Vi posto di seguito i messaggi del kernel:

Message from syslogd@ZEUS at Fri Dec 16 09:02:30 2005 ...
ZEUS kernel: Disabling IRQ #21
Dec 16 09:02:30 ZEUS kernel: usb 1-2: new full speed USB device using uhci_hcd and address 2
Dec 16 09:02:30 ZEUS kernel: irq 21: nobody cared!
Dec 16 09:02:30 ZEUS kernel: [dump_stack+30/32] dump_stack+0x1e/0x20
Dec 16 09:02:30 ZEUS kernel: [<c0103c8e>] dump_stack+0x1e/0x20
Dec 16 09:02:30 ZEUS kernel: [__report_bad_irq+43/144] __report_bad_irq+0x2b/0x90
Dec 16 09:02:30 ZEUS kernel: [<c019117b>] __report_bad_irq+0x2b/0x90
Dec 16 09:02:30 ZEUS kernel: [note_interrupt+144/176] note_interrupt+0x90/0xb0
Dec 16 09:02:30 ZEUS kernel: [<c01912a0>] note_interrupt+0x90/0xb0
Dec 16 09:02:30 ZEUS kernel: [__do_IRQ+261/272] __do_IRQ+0x105/0x110
Dec 16 09:02:30 ZEUS kernel: [<c0190d55>] __do_IRQ+0x105/0x110
Dec 16 09:02:30 ZEUS kernel: [do_IRQ+28/48] do_IRQ+0x1c/0x30
Dec 16 09:02:30 ZEUS kernel: [<c010519c>] do_IRQ+0x1c/0x30
Dec 16 09:02:30 ZEUS kernel: [common_interrupt+26/32] common_interrupt+0x1a/0x20
Dec 16 09:02:30 ZEUS kernel: [<c0103822>] common_interrupt+0x1a/0x20
Dec 16 09:02:30 ZEUS kernel: handlers:
Dec 16 09:02:30 ZEUS kernel: [pg0+546001936/1068971008] (usb_hcd_irq+0x0/0x80 [usbcore])
Dec 16 09:02:30 ZEUS kernel: [<e0d40410>] (usb_hcd_irq+0x0/0x80 [usbcore])
Dec 16 09:02:30 ZEUS kernel: [pg0+546001936/1068971008] (usb_hcd_irq+0x0/0x80 [usbcore])
Dec 16 09:02:30 ZEUS kernel: [<e0d40410>] (usb_hcd_irq+0x0/0x80 [usbcore])
Dec 16 09:02:30 ZEUS kernel: [pg0+546001936/1068971008] (usb_hcd_irq+0x0/0x80 [usbcore])
Dec 16 09:02:30 ZEUS kernel: [<e0d40410>] (usb_hcd_irq+0x0/0x80 [usbcore])
Dec 16 09:02:30 ZEUS kernel: Disabling IRQ #21
Dec 16 09:02:31 ZEUS kernel: speedtch: Unknown symbol release_firmware
Dec 16 09:02:31 ZEUS kernel: speedtch: Unknown symbol request_firmware
Dec 16 09:02:31 ZEUS modprobe: FATAL: Error inserting speedtch (/lib/modules/2.6.11-6mdk/kernel/drivers/usb/atm/speedtch.ko.gz): Unknown symbol in module, or unknown parameter (see dmesg)
Dec 16 09:02:31 ZEUS usb.agent[21276]: ... can't load module speedtch
Dec 16 09:02:31 ZEUS usb.agent[21276]: missing kernel or user mode driver speedtch
Dec 16 09:02:32 ZEUS modprobe: FATAL: Error inserting speedtch (/lib/modules/2.6.11-6mdk/kernel/drivers/usb/atm/speedtch.ko.gz): Unknown symbol in module, or unknown parameter (see dmesg)
Dec 16 09:02:32 ZEUS usb.agent[21279]: ... can't load module speedtch
Dec 16 09:02:32 ZEUS usb.agent[21279]: missing kernel or user mode driver speedtch
Dec 16 09:02:32 ZEUS kernel: speedtch: Unknown symbol release_firmware
Dec 16 09:02:32 ZEUS kernel: speedtch: Unknown symbol request_firmware
Dec 16 09:02:37 ZEUS kernel: usb 1-2: modprobe timed out on ep0out
Dec 16 09:02:37 ZEUS kernel: speedtch: probe of 1-2:1.1 failed with error -12
Dec 16 09:02:37 ZEUS kernel: usbcore: registered new driver speedtch
Dec 16 09:02:42 ZEUS kernel: usb 1-2: grep timed out on ep0in
Dec 16 09:02:47 ZEUS kernel: usb 1-2: grep timed out on ep0in
Dec 16 09:02:47 ZEUS kernel: usb 1-2: string descriptor 0 read error: -110
Dec 16 09:02:52 ZEUS kernel: usb 1-2: grep timed out on ep0in
Dec 16 09:02:57 ZEUS kernel: usb 1-2: grep timed out on ep0in


L'ultimo messaggio usb 1-2: grep time out on ep0in lo ripete in continuazione finch non stacco il modem...
Cos' questo ep0in ??? Comunque quel FATAL e i successivi can't load module speedtch...tutti messaggi che non promettono molto bene...
Non so come gestire questi errori, attendo consigli e istruzioni.
Grazie mille
ciao

Loading