PDA

Visualizza la versione completa : Problema condivisione cartella con Samba


lucisetti
22-12-2005, 11:06
Buongiorno a tutti,

ho fedora core 4 e sto cercando di condividere una cartella con samba che si trova in questo path /var/www/html/SITO ma dopo aver riavviato samba la cartella non Ŕ ancora visibile da un pc windows.
Se invece condivido una cartella creata nuova nel root path /SITO questa riesco a vederla da windows normalmente. Chiaramente a tutte e due avevo giÓ impostato il chmod 777.

Cosa pu˛ accadere ?

Grazie

Lucia

nik600
22-12-2005, 11:17
ciao

mi posti il pezzetto di configurazione dello share di samba?

dovrebbe essere una cosa tipo questa:



[nome_cond]
Comment = commento alla condivisione
path = /var/www/html/SITO
public = yes
writable = yes
browsable = yes


cmq, credo che il problema sia nel fatto che tu hai dato un 777 a /var/www/html/SITO ma l'utente non riesce ad arrivare a /var/www/html prova dai i permessi di lettura (solo lettura) a questa directory x tutti

lucisetti
22-12-2005, 11:57
Si le righe del file smb.conf sono identiche a quelle da te indicate.

Le cartelle /var, /var/www, /var/www/html hanno anche loro i permessi di sola lettura all'utente autorizzato da samba ad accedere alla condivisione "adm". Tra l'altro come ti dicevo prima con le stesse impostazioni sulla cartella /SITO riesco ad accedere tranquillamente.

Potrebbe essere qualche restrizione relativa ad apache ?

Grazie

Lucia

nik600
22-12-2005, 12:01
non penso...

hai dato un'occhio ai log di samba?

dovresti trovarli sotto /var/log/samba/

guarda :

- smbd.log
- ip_host-samba.log
- name_host-samba.log

e nota se ti dice qualcosa

ma dal client non vede la connessione o non ti lascia entrare?

lucisetti
22-12-2005, 12:12
Dal client di windows vedo la cartella condivisa, ma quando tento di entrare windows mi dice "Non si dispone delle autorizzazioni necessarie per accedere... Contattare l'amministratore del sistema ..."

Lucia

nik600
22-12-2005, 13:03
fai questa prova, prova loggati sul sever (magari via ssh) con lo stesso utente che tenta di accedere alle condivisioni (samba ti fa anche da PDC?) e provi a fare un cd /path/cartella

guarda se riesci

PS: i log? li hai guardati?

Teuzzo
22-12-2005, 16:36
Prova ad eseguire il comando 'testparm' e posta il risultato.

lucisetti
23-12-2005, 08:50
Buongiorno a tutti,

questo seguente Ŕ il testo del log di samba:

[2005/12/23 08:38:22, 0] rpc_server/srv_pipe.c:api_pipe_bind_req(993)
api_pipe_bind_req: unknown auth type 9 requested.
[2005/12/23 08:38:23, 0] smbd/service.c:make_connection_snum(615)
'/var/www/html/SITO' does not exist or is not a directory, when connecting to [SITO]
[2005/12/23 08:38:23, 0] smbd/service.c:make_connection_snum(615)
'/var/www/html/SITO' does not exist or is not a directory, when connecting to [SITO]
[2005/12/23 08:38:24, 0] smbd/service.c:make_connection_snum(615)
'/var/www/html/SITO' does not exist or is not a directory, when connecting to [SITO]

... in realtÓ la cartella SITO esiste.
e quest'altro Ŕ il testo del risultato del testparm:

# Global parameters
[global]
workgroup = GW1GROUP
server string = Samba Server
username map = /etc/samba/smbusers
log file = /var/log/samba/%m.log
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = /etc/printcap
dns proxy = No
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
cups options = raw

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[SITO]
path = /var/www/html/SITO
valid users = adm
read only = No

Grazie

Lucia

Teuzzo
23-12-2005, 09:52
Dal logo sembra che la directory SITO non esista. Sei sicuro di aver scritto il nome giusto?
Nel file /etc/samba/smbusers c'Ŕ l'utente adm?
Inoltre hai creato l'utente samba con smbpasswd -a utente?

lucisetti
23-12-2005, 11:00
Rispondo tra le righe.

L'utente "adm" c'Ŕ nel file smbusers.

Lo stesso utente, nonchŔ tutta la configurazione che ho effettuato Ŕ stata fatta tramite il tool di Fedora 4 che si trova in Desktop --> Impostazioni di sistema --> Impostazioni del Server --> Utenti Samba .

... anche con SSH da windows accedo in quella maledetta cartella /var/www/html/SITO e ci scrivo anche.

Grazie

Lucia

Loading