PDA

Visualizza la versione completa : firefox 1.5 e java


Shenk87
23-12-2005, 23:14
ho installato java (creato il collegamento...) in about:plugins dice yes . ma nn carica le applet, o meglio esce scritto "applet started" ma in realtā rimane tutto bianco. c'č una soluzione? con l'1.0 funzionava tutto ok :)

cacao74
23-12-2005, 23:28
ho fatto quanto segue, proprio ora, dopo aver letto il tuo post e non ho alcun problema nell'utilizzare applet java.


cacao74@winnie:~$ cd firefox/
cacao74@winnie:~/firefox$ cd plugins/
cacao74@winnie:~/firefox/plugins$ ln -s /usr/lib/java/jre/plugin/i386/ns7/libjavaplugin_oji.so

Avvio il browser e scelgo una applet tra le tante da qui:
http://www.html.it/java/

Riferimenti di ambiente


cacao74@winnie:~$ cat /etc/slackware-version
Slackware 10.2.0

cacao74@winnie:~$ uname -r
2.6.15-rc5

cacao74@winnie:~$ java -version
java version "1.5.0_04"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_04-b05)
Java HotSpot(TM) Client VM (build 1.5.0_04-b05, mixed mode, sharing)

cacao74@winnie:~$ cd firefox/

cacao74@winnie:~/firefox$ ./firefox -V
Mozilla Firefox 1.5, Copyright (c) 1998 - 2005 mozilla.org


ciao

Shenk87
24-12-2005, 14:12
ciao

/usr/lib/java/jre/plugin/i386/ns7/libjavaplugin_oji.so

nn esisteva, siccome nn riuscivo a trovare su synaptic la jre, ho installato da installer java 1.5 in /opt, e ho fatto il link



debian sid

$ uname -r
2.6.8-2-386
// che ho intenzione di aggiornare presto

nicola@debian:/opt/jre1.5.0_06$ java -version
java version "1.4.2" ...
// nn ho linkato questa, che nn la trovo, ma l'ultima


cacao74@winnie:~$ cd firefox/
la versione di firefox č quella dei repos unstable
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051217 Debian/1.5.dfsg-2 Firefox/1.5


ciao e buon natale :ciauz: :ciauz:

cacao74
24-12-2005, 14:32
Dovresti trovare la jre nei repository, "contrib" o "non-free", se non sbaglio.

ciao :)

buone feste!

Shenk87
24-12-2005, 15:00
niente... quei repos ce li avevo giā, avevo installato java-common. la cosa strana č che ho installato (scompattato) firefox 1.0 e con un link allo stesso plugin, funge... lo stesso prob lo dā con la verisone 1.5 scaricata da mozilla.org

Loading