PDA

Visualizza la versione completa : eciadsl & ark


SupernovaITA
24-12-2005, 19:18
ciao a tutti!

sono alle primissime armi con linux e sto cercando di far funzionare il mio modem webpower di alice..

ho scaricato ed installato correttamente i driver eciadsl, ma il tentativo di connessione fallisce con un timeout..

a questo punto ho tentato di estrarre con ark nella cartella /etc/eciadsl i file di sincronizzazione che ho scaricato da flashtux (come suggerito dalle guide sul sito) ma il programma dice ke non ho i permessi per scrivere in quella cartella..

come devo fare?

grazie e ciauz

andy caps
24-12-2005, 21:29
devi farlo da root
o da terminale di root

tar xzvf nome file scompatta un tar.gz

tar xjvf nome file scompatta un tar.bz2
ad esempio


cp nome-file /etc/eciadsl/ lo copia in /etc/eciadsl

farthest
25-12-2005, 16:10
che distro usi?
io uso mandriva, ed uso quei driver con lo stesso modem, IPM datacom webpower targato Telecom.

Timeout??
In intendi il timeout nella sincronizzazione?

Io per la sincronizzazione uso un filtro adsl e collego il modem alla parte del filtro che si dovrebbe collegare il telefono non dove c' scritto modem.

:ciauz:

SupernovaITA
26-12-2005, 18:10
prima di tutto auguri a tutti!

grazie ad entrambi per la risposta..
dunque ho risolto il problema alla radice con un chmod sulla cartella :D

con eciadsl-probe-synch ho provato i vari synch ed ho trovato quello giusto: riesco a connettermi ad internet (le luci del modem sn rosse e fisse) ma se provo ad aprire una pagina non carica niente..

cosa pu essere?

grazie!

ps. ho mandriva free 2006

andy caps
26-12-2005, 19:12
possono essere i dns che mancano in /etc/resolv.conf
il firewall se attivo
/etc/init.d/shorewall stop per fermarlo

o un eventuale gateway impostato

route -n per vedere cosa mette sotto la colonna gateway

SupernovaITA
26-12-2005, 21:59
allora..

1) in resolv.conf sn elencati i dns impostati nell'interfaccia di mandrake..

2) il file del firewall ke dici tu nella cartella /etc/ non presente

3) nella colonna gateway ci sono solo degli zeri..

cmq credo ke i dns funzionino, perch riesco a fare dei ping..

ma ho una domanda: dopo aver installato i driver eciadsl, in cui imposto login, pass dns ecc ecc, devo modificare anche qualk di particolare (ad esempio dal pannello di controllo)?

andy caps
26-12-2005, 23:32
se riesci a pingare allora probabilmente il firewall

apri il centro di controllo di mandrake ( mcc come comando da terminale ) e dal menu sistema > servizi disattiva e ferma le caselle di iptables e shorewall al boot

poi prova a cambiare i dns prima di avviare il browser per fare un esperimento

farthest
27-12-2005, 18:33
Allora vai in firewall, nel centro di controllo, e imposta il firewall con la porta ppp0
:ciauz:

SupernovaITA
29-12-2005, 21:38
scusate se vi esaspero ma non sn ancora riuscito :dh:

x andy caps:

in un altro tuo post ho letto ke i dns di alice sn 212.216.112.112 e 212.216.172.62 ..
nell'installazione dei driver ho visto ke come opzioni c' sia "telecom italia" ke "alice telecom".. avendo io alice flat ho scelto "alice telecom" che per ha dns diversi da quelli citati sopra..

cosa devo scegliere allora?

in ogni caso posto il risultato della connessione..

[EciAdsl 1/5] Setting up USB support...

Preliminary USB device filesystem is OK

[EciAdsl 2/5] Uploading firmware...

eciadsl-firmware: success
firmware loaded successfully

[EciAdsl 3/5] Synchronization...

Progress indicator is 01 No Signal !
Progress indicator is a0 No Signal !
Progress indicator is a1 Training...
Progress indicator is a1 Training...
Progress indicator is 43 Training...
Progress indicator is a4 Training...
Progress indicator is a4 Training...
Progress indicator is 74 Training...
Progress indicator is a6 Training...
Progress indicator is 77 Training...
Progress indicator is 6b Training...
Progress indicator is 01 No Signal !
Progress indicator is a0 No Signal !
Progress indicator is a1 Training...
Progress indicator is a1 Training...
Progress indicator is 43 Training...
Progress indicator is a4 Training...
Progress indicator is a4 Training...
Progress indicator is 74 Training...
Progress indicator is a6 Training...
Progress indicator is 77 Training...
Progress indicator is 75 Training...
Progress indicator is aa Training...
Progress indicator is 72 Training...
Progress indicator is ad Training...
eciadsl-synch: success
Synchronization successful
Mounting devpts filsystem...
mount: devpts gi montato o /dev/pts occupato
failed to mount

[EciAdsl 4/5] Connecting to provider...

using channel 12
Using interface ppp0
Connect: ppp0 <--> /dev/pts/1
sent [LCP ConfReq id=0x1 <magic 0xfcd65314>]
rcvd [LCP ConfReq id=0x1 <auth pap> <magic 0x5848f2ae>]
sent [LCP ConfAck id=0x1 <auth pap> <magic 0x5848f2ae>]
sent [LCP ConfReq id=0x1 <magic 0xfcd65314>]
rcvd [LCP ConfAck id=0x1 <magic 0xfcd65314>]
sent [PAP AuthReq id=0x1 user="serravalli.luciano@tin.it" password=<hidden>]
rcvd [PAP AuthAck id=0x1 ""]
PAP authentication succeeded
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
rcvd [IPCP ConfReq id=0x1 <addr 192.168.100.1>]
sent [IPCP ConfAck id=0x1 <addr 192.168.100.1>]
rcvd [LCP EchoReq id=0x1 magic=0x5848f2ae f2 ae 00 00]
sent [LCP EchoRep id=0x1 magic=0xfcd65314 00 00 00 00]
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
rcvd [IPCP ConfNak id=0x1 <addr 80.183.6.222> <ms-dns1 85.37.17.52> <ms-dns3 151.99.125.1>]
sent [IPCP ConfReq id=0x2 <addr 80.183.6.222> <ms-dns1 85.37.17.52> <ms-dns3 151.99.125.1>]
rcvd [IPCP ConfAck id=0x2 <addr 80.183.6.222> <ms-dns1 85.37.17.52> <ms-dns3 151.99.125.1>]
local IP address 80.183.6.222
remote IP address 192.168.100.1
primary DNS address 85.37.17.52
secondary DNS address 151.99.125.1
Connection successful

[EciAdsl 5/5] Setting up route table...

Waiting for ppp0...
Adding default route... default route to ppp0 already exists
[root@localhost ~]#

grazie ciauz

andy caps
29-12-2005, 23:26
:bh: mi sembra strano

dai questi comandi prima di tentare la connessione

/etc/init.d/iptables stop
/etc/init.d/shorewall stop
route del default gw ppp0

Loading