PDA

Visualizza la versione completa : xscreensaver mi rifiuta la password!!! AIUTO!!!


anima.salva
10-01-2006, 00:31
Sono su Ubuntu... sul portatile funziona tutto ok, sul fisso la stessa (o quasi) ubuntu se faccio lock screen, quando cerco di sbloccare lo schermo non mi riconosce la password!!! E sono STRACERTO di averla inserita correttamente... niente caps lock o errori banali simili...

nei log trovo varie righe del tipo:

Jan 9 23:50:22 localhost xscreensaver[14919]: (pam_unix) authentication failure; logname= uid=1000 euid=1000 tty=:0.0 ruser= rhost= user=alessandro
Jan 9 23:50:24 localhost unix_chkpwd[15130]: check pass; user unknown
Jan 9 23:50:24 localhost xscreensaver[14919]: (pam_unix) authentication failure; logname= uid=1000 euid=1000 tty=:0.0 ruser= rhost= user=root
Jan 9 23:50:26 localhost xscreensaver[14919]: FAILED LOGIN 3 ON DISPLAY ":0.0", FOR "alessandro"

Vi prego AIUUTTOOOOOOOOO!!!!!!!! Siccome sul portatile ubuntu non da prob qualcuno di voi sa suggerirmi cosa posso aver sbagasciato??? L'unica diff é che sul fisso ho samba, ma non credo di aver toccato nulla di che... é una scocciatura non da poco... :dhò:
AIUTO!!!

anima.salva
10-01-2006, 01:06
:messner:

anima.salva
10-01-2006, 02:05
Dopo ore di sbattimento ho capito.. il prob. era il file /etc/shadow. A quanto pare i permessi settati su di essi erano giusti (640) ma non il gruppo, infatti erano root:root (owner e gruppo), mentre ho letto che devono essere root:shadow.
E così funge tutto.. ma cosa mi può aver cambiato i permessi di quei file? Io non li ho mai toccati.. inoltre un piccolo piacere.. chi ha altre distro (ubuntu escluse) mi può dire se é giusto che il gruppo di /etc/shadow sia shadow anziché root? Non vorrei che questa fosse una soluzione che funziona ma poco sicura...
Grazie...

Meskalamdug
10-01-2006, 06:05
Originariamente inviato da anima.salva
Dopo ore di sbattimento ho capito.. il prob. era il file /etc/shadow. A quanto pare i permessi settati su di essi erano giusti (640) ma non il gruppo, infatti erano root:root (owner e gruppo), mentre ho letto che devono essere root:shadow.
E così funge tutto.. ma cosa mi può aver cambiato i permessi di quei file? Io non li ho mai toccati.. inoltre un piccolo piacere.. chi ha altre distro (ubuntu escluse) mi può dire se é giusto che il gruppo di /etc/shadow sia shadow anziché root? Non vorrei che questa fosse una soluzione che funziona ma poco sicura...
Grazie...
E' root:shadow
con permessi 640 su slack

farthest
10-01-2006, 08:30
:confused:
a me sono così:

maurizio@Titano ~/$ ll /etc/shadow
-r-------- 1 root root 680 dic 24 15:57 /etc/shadow

no problem :nonono:

anima.salva
10-01-2006, 19:35
ok grazie a tutti, ora sono più tranquillo.. mi resta solo la curiosità di sapere quale programma o cos'altro mi ha modificato i permessi di quei file, visto che io non l'ho mai fatto ne ho avuto intrusioni di sorta (ne sono certo al 99,9 %...)....
mah...
:master:

Loading