PDA

Visualizza la versione completa : [Debian] Non riesce ad upgrade


RokStar
13-01-2006, 13:47
Come da oggetto, ormai da un paio di settimane la mia debian non riesce a fare l'upgrade con apt-get dist-upgrade.

Se faccio un bel apt-get clean, tolgo tutte le repository aggiuntive e ricomincio con un apt-get update && apt-get dist-upgrade possibile che si risolva tutto?

Altra cosa.. ieri sera ho dovuto chiudere la sessione Xorg perch era stranamente pesante. Ho quindi lanciato il comando startx e mi morto il processo dandomi errore nei driver Fglrx di ATI dicendo qualcosa tipo parameters mismatch. Ho quindi provato a reinstallare i driver ATI ma il risultato il medesimo. Per riavviare X ho dovuto creare il Device ATI2 utilizzando i driver radeon inclusi con Xorg... Per rimettere a posto i driver proprietari (che gestiscono molto meglio le applicazioni OpenGL) non so proprio come fare (erano anche le due di notte e ci ho perso poco tempo dietro...).

:ciauz:

andy caps
13-01-2006, 14:53
qualche file rimane sempre in sospeso con la versione piu vecchia ( non aggiornato ) ma non un problema

se dai i soliti dpkg --configure -a e apt-get -f install in genere risolve quasi tutto

per fglrx controlla che kernel hai in uso e controlla che abbia finito di aggiornarti xorg
con l'ultimo xorg anchio ho dovuto reinstallare i driver nvidia perche dava qualche problema

RokStar
13-01-2006, 15:01
I pacchetti che non hanno dipendenze soddisfatte:

k3b: Dipende: libdbus-qt-1-1c2 (>= 0.60) ma non installato
kdelibs: Dipende: kdelibs-data (>= 4:3.5.0-3) ma 4:3.4.3-2 installato
kdelibs4c2a: Dipende: kdelibs-data (> 4:3.5.0) ma 4:3.4.3-2 installato
libk3b2: Dipende: libdbus-qt-1-1c2 (>= 0.60) ma non installato

Ho provato a cercare a mano i pacchetti da cui dipendono ma su apt-get.org non trovo la versione richiesta :bh:

andy caps
13-01-2006, 15:05
che server hai ?

il problema di k3b era stato risolto qualche giorno fa

RokStar
13-01-2006, 15:10
# cat sources.list
deb http://debian.fastweb.it/debian/ unstable main contrib non-free
deb-src http://debian.fastweb.it/debian/ unstable main non-free contrib
deb ftp://ftp.nerim.net/debian-marillat/ sid main
deb http://www.linex.org/sources/linex/debian/ sarge linex
deb http://http.us.debian.org/debian/ ../project/experimental main contrib non-free
deb http://mirror.pusling.com/debian/unstable/ ./
deb-src http://mirror.pusling.com/debian/unstable/ ./
#deb http://people.debian.org/~rene/openoffice.org/2.x/ ./
deb http://ftp.debian-unofficial.org/debian sarge main contrib non-free restricted
deb-src http://ftp.debian-unofficial.org/debian sarge main contrib non-free restricted
#deb http://debian.oceighty.net/debian unstable main
deb http://www.fbriere.net/debian/dists/stable ./
deb-src http://www.fbriere.net/debian/dists/stable ./

andy caps
13-01-2006, 15:22
mi sembra strano perche sono anche le mie piu o meno

dai qualche apt-get -f dist-upgrade e dopo che hai aggiornato il resto con i soliti dpkg --configure -a prova un apt-get --reinstall install k3b

se non finisci l'aggiornamento non va

Loading