PDA

Visualizza la versione completa : [JAVA/JSP] Errore in compilazione JSP e percorsi librerie


simopes
13-01-2006, 16:49
Salve a tutti
Problema: quando compilo il mio jsp avente anche dei file java, mi dà un'eccezione e nel compilare mi dice:

StandardWrapperValve[debugjsp]: Servlet.service() for servlet debugjsp threw exception
java.lang.NoClassDefFoundError: com/sun/jimi/core/component/JimiCanvas
java.lang.NoClassDefFoundError: com/sun/jimi/core/component/JimiCanvas

Qualcuno ha idea del motivo di ciò?Help please...

floyd
13-01-2006, 16:52
semplice
il package jimi non è nel classpath usato da tomcat
mettilo in $TOMCAT/common/lib se devi renderlo visibile a tutte le webapp di tomcat

simopes
13-01-2006, 16:57
Ehm...scusami ma sono alle prime armi: mi potresti illuminare sul come fare ciò che hai detto?

(scusa per la domanda banale)
:master:

simopes
13-01-2006, 17:03
up??

alka
13-01-2006, 17:11
Originariamente inviato da simopes
up??
Un up dopo 5 minuti? :rollo:

simopes
13-01-2006, 17:16
no...sai il motivo?è che sto all'università dove ora ho internet ma tra un po' devo andarmene via e in appartamento non ho internet.
Se non risolvo il problema devo rimanere tutto il finesettimana fermo ed attendere lunedì per ricomincairfe.
Tutto qua.
:)

floyd
13-01-2006, 17:19
se usi jimi vuol dire cha hai un jar (o zip o classi) che metti nel classpath per compilare
prendi il jar e copialo nella directory che dicevo
di solito $TOMCAT è c:/programmi/apache software foundation/tomcat 5.x

simopes
13-01-2006, 17:55
Ho un file zip in cui all'interno Ho com/sun/jimi/core/component e qui un file Jbuilder di JimiCanvas
,l'ho provato a mettere in

C:\Borland\JBuilder2005\thirdparty\jakarta-tomcat-5.0.27\
common\lib

ma l'esito è sempre lo stesso.
Dici che sempre un .jar?......
Non saprei dove trovarlo.........?
:dhò: :dhò: :dhò:

floyd
13-01-2006, 17:59
ho capito
nel project pane in alto a sinistra tasto destro sulla webapp
properties
content
dependencies
nella lista metti include all sulla riga di jimi
fai partire tomcat

simopes
13-01-2006, 18:08
Spero non ti metterai a ridere:
il valore era già settato in quel modo, però c'è JimmyPro, non Jimmy.
Che faccio?
Scusami per il disturbo e grazie per la pazienza!
:cry:

Loading