PDA

Visualizza la versione completa : [Debian] impedire l'aggiornamento di certi pacchetti


alkat
16-01-2006, 02:18
Ciao,
ho installato su Debian Sid OpenOffice scaricato dal sito ufficiale di OOo ma ora ogni volta che faccio dist-upgrade, apt vuole aggiornarmi anche OpenOffice.org rimuovendo quello che ho installato per sostituirlo con quello contenuto nei repository Debian.

C'Ŕ un modo per evitare che alcuni pacchetti vengano aggiornati?

Sull'Apt-Howto si consiglia di usare aptitude:


3.9 Bloccare i pacchetti

Come si Ŕ visto nella precedente sezione aptitude marca
automaticamente i pacchetti per l'aggiornamento. Se si vuole bloccare
un pacchetto alla versione attualmente installata si pu˛ chiedere di
impostare un pacchetto come bloccato. Questo si ottiene premendo il
tasto "=". I pacchetti bloccati appaiono in questo modo:

ih alien 8.41 8.41

In questo esempio il pacchetto alien viene mantenuto alla versione
8.41 anche se una nuova versione Ŕ presente su una delle sorgenti di
APT, notare il carattere h sulla sinistra. Per rendere il pacchetto
nuovamente aggiornabile marcarlo per l'installazione. ╚ possibile
impostare i pacchetti come bloccati anche con l'interfaccia a riga di
comando, eseguendo:

# aptitude hold pacchetto1 pacchetto2 ...

Ma poi facendo apt-get dist-upgrade, cerca comunque di sostituire OOo.

Su Debian Reference si consiglia invece:


2.2.11 Evitare l'aggiornamento dei pacchetti
Esistono due modi per evitare l'aggiornamento di un pacchetto, tramite
dpkg o, da Woody in poi, tramite APT. Con dpkg, dovete solo esportare
la lista dei pacchetti selezionati con:

dpkg --get-selections > selections.txt

DopodichŔ modificate il file risultante selections.txt, cambiando la
riga che contiene il pacchetto da mantenere, tipo libc6, da:
libc6 install
a:
libc6 hold

Salvate il file e ricaricatelo nel database di dpkg con:

dpkg --set-selections < selections.txt

Se conoscete il nome del pacchetto da mantenere, basta eseguire:
echo libc6 hold | dpkg --set-selections
Questo processo evita l'aggiornamento dei pacchetti al momento
dell'installazione di ciascun file.

Ma neanche questo funziona.

Non ho provato con dselect; qualcuno mi sa consigliare qualcosa?

.a.

U-bahn
16-01-2006, 02:27
prova ad inserire...
Package: <pacchetto>
Pin: version <versione>
Pin-Priority: 999
..in /etc/apt/preferences (potrebbe/dovrebbe funzionare, ma fai comunque attenzione)

Loading