PDA

Visualizza la versione completa : [fc4]come cavolo installo amsn 0.95


iBat
19-01-2006, 16:05
premessa: sono niubbo totale

allora, ho amsn 0.94 e voglio mettere lo 0.95.. pensavo fosse facile: scarico l'rpm per fedora core 4 , faccio rpm -i blablabla.rpm e si installa, giusto? :stordita:

e invece no :cry:

se scrivo "amsn" nella shell mi parte ancora lo 0.94 :dh:

qualcuno mi scrive le istruzioni passo passo? :fagiano:

grazie :)

iox84
19-01-2006, 19:06
hai provato con yum?



yum localinstall path/tuo/rpm


Oppure sempre con yum prova ad aggiornare il pacchetto con il comando:


yum upgrade amsn


Si consiglia sempre di utilizzare yum, risolve le dipendenze ed evita casini.
Se non ti piace riga comando esegui il comando


yum install yumex

Che ti installa un'interfaccia grafica di yum (io non l'ho mai provata)

andy caps
19-01-2006, 20:05
strano che non te lo aggiorni

installa magari con yum tk8.4-dev tcl8.4-dev

poi controlla con

ls -ls /usr/bin | grep amsn e controlla che cosa hai

iBat
19-01-2006, 20:13
adesso riavvio con linux e provo.. intanto mi potete dire come si disinstalla un pacchetto? ho rpovato a fare

yum -e amsn

non mi da nessun errore, per amsn rimane :confused:

andy caps
19-01-2006, 20:16
se lo hai installato manualmente devi usare l'rpm usato

rpm -e nomerpm

iBat
19-01-2006, 20:32
Originariamente inviato da andy caps
se lo hai installato manualmente devi usare l'rpm usato

rpm -e nomerpm

si son stupido, volevo scrivere rpm -e amsn,ho fatto quello infatti :stordita:

iBat
19-01-2006, 20:35
Originariamente inviato da iox84



yum upgrade amsn



"Could not find update match for amsn"
:(



facendo invece yum localinstall blablabla.rpm mi da:

Installed: amsn.i686 0:0.95-3.fc4
Complete!

ma se faccio
[daniele@localhost ~]$ amsn

mi avvia ancora la versione precedente
:dh:

andy caps
19-01-2006, 20:38
prova a reinstallarlo con l'opzione
rpm -ivh e guarda che dice

altrimenti installa tk e tcl -devel poi scarica il cvs e compilalo con ./configure make make install

il cvs in genere il migliore

iBat
19-01-2006, 20:41
edit.



altrimenti installa tk e tcl -devel poi scarica il cvs e compilalo con ./configure make make install

il cvs in genere il migliore

ora provo :fagiano:
come si fa? :stordita:

andy caps
19-01-2006, 21:45
in un terminaledi root digita

yum install tk-devel.i386
yum install tcl-devel.i386


le installa poi da terminale dopo avere scompattato il pacchetto di amsn
devi entrarci
cd msn

poi dare i comandi
./configure
make
make install

naturalmente dopo esserti loggato come root nella consolle con il coamando su

Loading