PDA

Visualizza la versione completa : nessun suono


Geppo Hylar
21-01-2006, 14:22
Non sento alcun suono,, ne dalla scheda audio integrata della mia scheda madre, che dalla scheda pci sound blaster.
Come mai? eppure da arts control tool, vedo che a volte il segnalatore va su.

andy caps
21-01-2006, 15:07
dai un apt-get install alsa-base alsa-utils aumix poi dai il comando alsaconf e configura la tua scheda

poi controlla con il comando alsamixer che i volumi siano alti

se non va incolla un lsmod | grep snd
e un lspci

Geppo Hylar
21-01-2006, 15:45
Originariamente inviato da andy caps
dai un apt-get install alsa-base alsa-utils aumix poi dai il comando alsaconf e configura la tua scheda

poi controlla con il comando alsamixer che i volumi siano alti

se non va incolla un lsmod | grep snd
e un lspci

Andy, intanto ti ringrazio perchŔ installando quei pacchetti ora quando apro e chiudo una finestra sento un breve suono. Ma tentando di aprire un semplice MP3 con noatun, non gira.
Inoltre, per curiositÓ, dove li avrei dovuti attaccare "lsmod | grep snd ed lspci" ?

andy caps
21-01-2006, 15:54
lsmod e lspci sono comandi da dare nel terminale di root
dicono le periferiche e i driver caricati

noatun manchera' dei codec per gli mp3

dai un apt-cache search mp3 ed installa un po di software

tipo

apt-get install amarok xine-ui gxine lame kdemultimedia juk

Geppo Hylar
21-01-2006, 19:11
Quasi perfetto Andy, ora riesco ad ascoltare anche gli MP3, ma il fatto anomalo che accade, Ŕ che se riavvio il pc, i suoni spariscono nuovamente.
Al riavvio il lettore MP3, vedo che gira, ma non produce alcun suono, ed anche tutti i suoni associati all'apertura o chiusura delle cartelle non funzionano pi¨.
Poi rilanciando il comando "alsaconf" torna tutto operativo. Il problema Ŕ che se rispengo il pc, devo ripetere l'operazione.
Ho fatto varie prove e tutte danno lo stesso esito. :master:
il mixer sembra ok!
mistero dell'informatica?

Lardoman 2.0
21-01-2006, 19:20
Ho avuto un problema simile ed era il mixer che non era configurato bene :stordita:

Attiva tutti gli "output" e mettili al massimo volume e dovrebbe andare

Poi ,sempre dal mixer, vai su "impostazioni --> configura Kmix" e attiva l'opzione "ripristina i volumi all accesso".In questo modo ti verranno salvati :ciauz:

andy caps
21-01-2006, 19:33
probabilmente dovresti anche scriver e il modulo da caricare in un file

digita un
lsmod

in un terminale di root
cosi poi ti dico cosa scrivere in /etc/modules

scrivendolo li il driver viene caricato all'avvio

digita anche un
aumix -S
quando i volumi sono a posto

Geppo Hylar
22-01-2006, 13:55
Originariamente inviato da Lardoman 2.0
Attiva tutti gli "output" e mettili al massimo volume e dovrebbe andare

Poi ,sempre dal mixer, vai su "impostazioni --> configura Kmix" e attiva l'opzione "ripristina i volumi all accesso".In questo modo ti verranno salvati :ciauz:

La cosa strana Ŕ che se vado nel mio mixer Ŕ gia attiva questa opzione. :(

Geppo Hylar
22-01-2006, 14:00
Originariamente inviato da andy caps
digita un lsmod


debian:~# lsmod
Module Size Used by
snd_via82xx 26660 2
snd_ac97_codec 59268 1 snd_via82xx
snd_pcm_oss 48168 0
snd_mixer_oss 16640 2 snd_pcm_oss
snd_pcm 85384 3 snd_via82xx,snd_pcm_oss
snd_timer 23300 1 snd_pcm
snd_page_alloc 11144 2 snd_via82xx,snd_pcm
snd_mpu401_uart 7296 1 snd_via82xx
snd_rawmidi 23204 1 snd_mpu401_uart
snd_seq_device 7944 1 snd_rawmidi
snd 50660 10 snd_via82xx,snd_ac97_codec,snd_pcm_oss,snd_mixer_o ss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,s nd_seq_device
soundcore 9824 2 snd
ipv6 229892 8
af_packet 20872 2
pcspkr 3816 0
analog 10784 0
floppy 54992 0
parport_pc 33348 0
parport 37320 1 parport_pc
pci_hotplug 30640 0
via_agp 8832 1
agpgart 31784 1 via_agp
ehci_hcd 27908 0
eth1394 19976 0
uhci_hcd 29328 0
usbcore 104164 4 ehci_hcd,uhci_hcd
gameport 4736 2 snd_via82xx,analog
via_rhine 19848 0
mii 4864 1 via_rhine
via_ircc 20368 0
irda 167360 1 via_ircc
crc_ccitt 2432 1 irda
ohci1394 32004 0
capability 4872 0
tsdev 7168 0
mousedev 9996 1
commoncap 7168 1 capability
evdev 9088 0
sr_mod 15780 0
sbp2 22408 0
ieee1394 100408 3 eth1394,ohci1394,sbp2
psmouse 17800 0
ide_cd 38176 0
cdrom 35740 2 sr_mod,ide_cd
genrtc 9332 0
ext3 109544 1
jbd 54552 1 ext3
ide_generic 1664 0
via82cxxx 12956 1
ide_disk 16768 3
ide_core 125028 4 ide_cd,ide_generic,via82cxxx,ide_disk
sd_mod 20480 0
ata_piix 7812 0
libata 36228 1 ata_piix
scsi_mod 115148 4 sr_mod,sbp2,sd_mod,libata
unix 26036 272
font 8576 0
vesafb 6688 0
cfbcopyarea 3840 1 vesafb
cfbimgblt 3200 1 vesafb
cfbfillrect 3712 1 vesafb


Originariamente inviato da andy caps
digita anche un aumix -S
quando i volumi sono a posto

debian:~# aumix -s
aumix: l'opzione richiede un argomento -- s
aumix 2.8 uso: aumix [-<opzione di canale>[[+|-][<valore>]]|<livello>|
R[ecord]|P[lay]|q[uery]] [-dhILqS] [-C <file schema di colori>] [-f <file rc>]

opzioni di canale:
v: volume principale x: mix monitor
b: bassi W: PCM 2
t: acuti (treble) r: registra
s: sintetizzatore i: guadagno di ingresso
w: PCM o: guadagno di uscita
p: altoparlante PC 1: linea 1
l: linea 2: linea 2
m: microfono 3: linea 3
c: CD

altre opzioni:
C: start in curses mode (and optionally specify color scheme)
d: regola un dispositivo diverso da /dev/mixer
f: specifica un file per salvare e leggere le impostazioni
(valore predefinito: ~/.aumixrc o /etc/aumixrc)
h: questo messaggio di aiuto
I: avvia in modalitÓ interattiva dopo aver eseguito funzioni non interattive
L: legge impostazioni
q: interroga tutti i canali e stampa le loro impostazioni
S: salva le impostazioni

andy caps
22-01-2006, 14:58
scrivi da root con un editor nel file
/etc/modules cosi

snd_via82xx
soundcore
snd_pcm
snd_ac97_codec
snd_mixer_oss

poi da terminale di root digita
aumix -w 80 -p 80 -v 80

poi aumix -S
e riavvia

dovrebbe andare

aumix -S la esse Ŕ maiuscola

Loading