PDA

Visualizza la versione completa : Problema con VSFTPD


BaHaMuT_ZeR0
29-01-2006, 16:41
Ho un problemone che non riesco a risolvere....dalla sera alla mattina vsftpd non mi funziona + come dovrebbe!

Se tento di collegarmi al server FTP non mi esce la lista delle cartelle!

Uso FileZilla da un client Windows e i comandi sono questi

Stato: Connesso a 192.168.1.13 ...
Stato: Connesso con 192.168.1.13. In attesa del messaggio di benvenuto...
Risposta: 220 Benvenuto in ftp.local
Comando: USER p2p
Risposta: 331 Please specify the password.
Comando: PASS ***
Risposta: 230 Login successful.
Comando: FEAT
Risposta: 211-Features:
Risposta: EPRT
Risposta: EPSV
Risposta: MDTM
Risposta: PASV
Risposta: REST STREAM
Risposta: SIZE
Risposta: TVFS
Risposta: 211 End
Comando: SYST
Risposta: 215 UNIX Type: L8
Stato: Connesso
Stato: Lettura elenco cartelle in corso...
Comando: PWD
Risposta: 257 "/home/p2p"
Comando: TYPE A
Risposta: 200 Switching to ASCII mode.
Comando: PORT 192,168,1,11,6,213
Risposta: 200 PORT command successful. Consider using PASV.
Comando: LIST
Risposta: 425 Failed to establish connection.
Errore: NON E' POSSIBILE LEGGERE L'ELENCO DELLE CARTELLE
Comando: TYPE I
Risposta: 200 Switching to Binary mode.
Comando: REST 0
Risposta: 350 Restart position accepted (0).

Io non ho cambiato assolutamente nulla...cosa pu essere successo? X completezza vi posto anche VSFTPD.CONF

### MAIN
# server stand alone
listen=NO
# porta demone
listen_port=21
# porta dati
connect_from_port_20=YES
# interfaccia
#listen_address=10.0.0.1
# dis/abilita ftp in modalita' passiva
#pasv_enable=NO
# banner di benvenuto
ftpd_banner=Benvenuto in ftp.local
# banner da file
#banner_file=/path
# permette di caricare profili di configurazione personalizzati a
# seconda dell'utente loggato. Guardare man vsftpd.conf.
#user_config_dir=/etc/vsftpd_user_conf

### ACCESSI
# nega accesso anonimo
anonymous_enable=NO
# permette l'accesso agli utenti locali
local_enable=YES
# chroota tutte le utenze che accedono
#chroot_local_user=NO
# path di chroot
secure_chroot_dir=/var/run/vsftpd
# permette l'accesso alle sole utenze specificate nel
# file userlist e nega l'accesso a tutti gli altri.
#userlist_enable=YES
#userlist_deny=NO
#userlist_file=/etc/vsftpd.user_list

# CONNESSIONI
# Tempo di timeout per la connessione
connect_timeout=60
# Tempo massimo di attesa per trasferimento dati in fase
# di stallo superato il quale il client viene kikkato
data_connection_timeout=300
# kikka dopo sec di inattivita' (nessun comando impartito dal client)
idle_session_timeout=300
# massime connessioni simultanee dallo stesso ip (default = infinite)
#max_per_ip=3
# limite velocita' di trasferimento dati in kb/sec (0 = infinite)
local_max_rate=0
# max numero di client possibili connessi in simultanea (0 = infinite)
max_clients=0
# max numero di connessioni dallo stesso ip (0 = infinite)
max_per_ip=3

### DIRECTORY E FILES
# permette upload e scrittura files/cartelle in generale
write_enable=YES
# permette download
download_enable=YES
# permette il dir/ls
dirlist_enable=YES
# stampa messaggio al client ogni qual volta entra in una
# dir. Guardare l'opzione message_file in man vsftpd.conff
dirmessage_enable=YES
# nega l'accesso ai file/directory (no copia, no download, no upload etc)
#deny_file={*.mp3,*.mov,.private}
# rendi invisibili i file
#hide_file={*.mp3,.hidden,hide*,h?}
# directory di default per l'utente appena loggato
#local_root=/path

### LOGS
# path file di log generico
vsftpd_log_file=/var/log/vsftpd.log
# attiva log per file s/caricati
xferlog_enable=YES
# path
xferlog_file=/var/log/xferlog
# Logga richieste e risposte del protocollo FTP
#log_ftp_protocol=YES

### ALTRI
# This string is the name of the PAM service vsftpd will use.
pam_service_name=vsftpd
# RSA certificate to use for SSL encrypted connections.
rsa_cert_file=/etc/ssl/certs/vsftpd.pem


E' troppo strano sto fatto....si sballato tutto dalla sere alla mattina :dh:

cacao74
29-01-2006, 17:06
Verifica nuovamente la configurazione lato client, ftp attivo/passivo e firewall.

ciao

BaHaMuT_ZeR0
29-01-2006, 17:22
grazie cacao74 x l'interessamento......

Purtroppo sono un p novellino di Linux e non so bene da dove incominciare..cmq ho appena provato a mettere PROFTPD e mi d lo stesso problema...riesco ad entrare nell'FTP SERVER ma non mi visualizza le cartelle!

Se mi dici cosa vedere ti posto l'output :cry:

BaHaMuT_ZeR0
29-01-2006, 17:27
ma pork....

ho appena provato a collegarmi al SERVER direttamente dal server e l funziona

peppe@debian:~$ ftp localhost
Connected to localhost.localdomain.
220 ProFTPD 1.2.10 Server (Debian) [127.0.0.1]
Name (localhost:peppe): peppe
331 Password required for peppe.
Password:
230 User peppe logged in.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
200 PORT command successful
150 Opening ASCII mode data connection for file list
-rw------- 1 peppe peppe 1899007 Dec 23 18:41 clients.met
-rw------- 1 peppe peppe 365 Dec 23 18:41 cryptkey.dat
drwxr-xr-x 3 peppe peppe 264 Dec 26 14:20 noip-2.1.1
-rw-r--r-- 1 peppe peppe 71210 Jan 9 2004 noip-duc-linux.tar.gz
-rw------- 1 peppe peppe 61 Dec 23 18:42 preferences.dat
-rw------- 1 peppe peppe 326 Dec 23 18:42 server.met
226 Transfer complete.
ftp>

Pu essere d'aiuto x risolvere il mio problema? :messner:

cacao74
29-01-2006, 17:31
Originariamente inviato da BaHaMuT_ZeR0
Uso FileZilla da un client Windows

Originariamente inviato da cacao74
Verifica nuovamente la configurazione lato client, ftp attivo/passivo e firewall.


Originariamente inviato da BaHaMuT_ZeR0
Se mi dici cosa vedere ti posto l'output
Io ipotizzo una errata configurazione lato CLIENT!

Poi mi sbagliero'...

Loading