PDA

Visualizza la versione completa : MEPIS, VIM e altro


trillullero
02-02-2006, 09:14
Ciao a tutti, ho mepis 3.3 installato su un laptop asus A6000.
Come con tutte le distro con kernel inferiore al 2.6.14 non funziona l'audio ma non è questo il problema.
Ho localizzato la tastiera in italiano e, sia in console non emulata che in X funzionano tutti i tasti accentati etc.
Quando apro VI...macello. Non è che non funzionano i tasti accentati, ma fa cose strane, difficili da spiegare.
A cosa può essere dovuto questo comportamento bizzarro?
Qual'è il file di configurazione di VI?

Altra cosa poco felice è che ieri, facendo un xconfig su di un kernel 2.6.15 mepis si è INCHIODATA! Solo facendo la configurazione, non compilando il kenrel.

Mah!? :master:

trillullero
02-02-2006, 09:24
Altra cosa che ho dimenticato di scrivere prima:
ho una partizione con reiserfs (hda7).
La monto in /mnt/hda7 con
mount -t reiserfs /dev/hda7 /mnt/hda7

la directory /mnt/hda7 assume i seguenti permessi
rwxr-xr-x root root
e non riesco a scrivere come utente normale. I permessi dovrebbero essere 777.

Se aggiungo l'opzione rw
mount -t reiserfs -o rw /dev/hda7 /mnt/hda7
Non cambia nulla. In effetti anche prima era montata in lettura scrittura ma solo per root.

PS:
l'opzione users mi permette solo di montare e smontare la partizione con un qualsiasi utente ma non ha niente a che fare con i permessi di scrittura.

Agendo su fstab non cambia nulla.

Come ottenere i permessi 777 dopo aver montato la directory?

eddis
02-02-2006, 09:43
Per quanto riguarda Vi, prova con Vim, aggiungendo che dovresti crearti un file .vimrc dove dovresti copiarti /usr/share/vim/vim63/vimrc_example.vim (se è presente),
quindi: cp /usr/share/vim/vim63/vimrc_example.vim .vimrc.

Per i permessi, se non ti crea ulteriori problemi, perchè non provi direttamente con chmod sulla partizione montata?

trillullero
02-02-2006, 09:52
Per i permessi, se non ti crea ulteriori problemi, perchè non provi direttamente con chmod sulla partizione montata?

Ho provato a cambiare owner e permessi alla directory prima di montarla ma poi vengono ripristinati.
Immagino che avvenga la stessa cosa se lo faccio quando è montata.
Al successivo mount (o reboot) i permessi dovrebbero tornare come prima. Uso il condizinale perchè non ho fatto la prova ma credo di non sbagliare. Dev'esserci una sorta di umask da passare come opzione di montaggio specifica per reiserfs, ma non so quale sia.
Con man mount non ho trovato quello che sto cercando.

Immagino che vada nella home dell'utente.
cp /usr/share/vim/vim63/vimrc_example.vim ~/.vimrc.

E se questo file risolve i miei problemi, come posso farlo diventare "globale"? Mi spiego meglio, come posso fare in modo che ogni utente che creo usi questo file? E' sufficiente metterlo in /etc/vimrc ?

Ciao!

eddis
02-02-2006, 10:17
Io uso partizioni Reiserfs montate da /etc/fstab senza nessun umask, perchè Reiserfs non vuole nessun umask.
I permessi li imposto regolarmente con la partizione montata.
Per capirci, il comportamento di cui parliamo non ha nulla a che vedere con quello delle partizioni fat32 montate come vfat fs, che questa sia una cosa buona o meno, non importa, ma funziona così.
Poi, scusa, ma non capisco perchè non provi, anzichè "credere di non sbagliare".
Se poi esistano altre problematiche particolari per le quali tutto questo non funzioni, nel tuo caso, non ti so dire.
Comunque, questa è una riga del fstab, relativa ad una delle partizioni di cui sopra:
/dev/hda10 /hd_c reiserfs defaults 1 2
e i permessi e l'owner li imposto a partizione montata.
Questo, ripeto, è un vantaggio ed uno svantaggio, a seconda dei punti di vista. Sinceramente, anch'io avrei preferito un "umask", se è questo il tuo problema, ma, se guardi la documentazione di reiserfs, non troverai un bel nulla in proposito.
Se ti va, guarda qui
http://www.namesys.com/mount-options.html
e se trovi qualcosa di nuovo, faccelo sapere :D

Per il discorso .vimrc, si, hai ragione, ho omesso la tilde, era la home dell'utente, quindi.
Penso che /etc/vimrc dovrebbe funzionare, ma non ho mai provato, anche perchè non ho ancora avuto esperienza di altri utenti in un sistema, così desiderosi di usare l'editor in questione. Ad averceli!... Nel caso, beato te!

:ciauz:

trillullero
02-02-2006, 10:38
Poi, scusa, ma non capisco perchè non provi, anzichè "credere di non sbagliare".
Non ho il pinguino sottomano, tutto li.
Questa sera provo.


Penso che /etc/vimrc dovrebbe funzionare, ma non ho mai provato, anche perchè non ho ancora avuto esperienza di altri utenti in un sistema, così desiderosi di usare l'editor in questione

Più che necessità è curiosità.

Grazie per quanto scritto.
Se incontro altri porblemi mi faccio risentire.
Ciao!

Geppo Hylar
02-02-2006, 19:35
Anche io ho lo stesso problema.

Originariamente inviato da eddis

Comunque, questa è una riga del fstab, relativa ad una delle partizioni di cui sopra:
/dev/hda10 /hd_c reiserfs defaults 1 2
Non ho capito bene il discorso, ma la soluzione sta nel mettere default ? e quegli 1 e 2 cosa vogliono dire?

trillullero
03-02-2006, 09:58
Avevi ragione eddis, è sufficiente cambiare i permessi QUANDO LA PARTIZIONE E' MONTATA. Poi ai successivi mount i permessi rimangono gli stessi.

Ora porgo un'altro nel quesito:
il mio fstab imposta l'opzione noauto ad hda7 (anche ad altre pat.).
Io volgio che tale partizione sia montata al boot e quindi passare l'opzione auto.
Ho editato fstab ma questo viene riscritto ad ogni reboot (e forse anche quando vengono aggiungti dispositivi). Scusate il forse ma, come al solito, non ho linux sotto mano. (La prova dei permessi l'ho fatta ieri all'1 di notte).
Quindi, se fstab viene riscritto al rebboot, come faccio "FISSARE" un'impstazione?
E' una cosa che cambia da distro a distro o lo fanno tutte?

Ciao :unz:

mykol
03-02-2006, 10:38
la stessa domanda anche per una knoppix installata.

Loading