PDA

Visualizza la versione completa : Webcam Philip Toucam Fun II


ame
08-02-2006, 00:35
Ho acquistato la webcam Philip Toucam Fun II PCVC830K che risulta supporta da linux http://www.vanheusden.com/setpwc/
Ho installato la patch relativa al kernel prese dal seguente sito http://www.saillard.org/linux/pwc/ come avvio xawtv -c /dev/video0 lo schermo resta grigio, partendo dal presupposto che ho installato come built-in nel kernel,Ho provato ad installare i pwc-10.0.11 ma quando vado a dare make ricevo il seguente errore

root@Ares /usr/src/pwc-10.0.11 # make
make -C /lib/modules/2.6.15-demone/source SUBDIRS=/usr/src/pwc-10.0.11 modules
make[1]: Entering directory `/usr/src/linux-2.6.15'
CC [M] /usr/src/pwc-10.0.11/pwc-v4l.o
/usr/src/pwc-10.0.11/pwc-v4l.c: In function `pwc_video_do_ioctl':
/usr/src/pwc-10.0.11/pwc-v4l.c:371: error: `v4l2_ioctl_names' undeclared (first use in this function)
/usr/src/pwc-10.0.11/pwc-v4l.c:371: error: (Each undeclared identifier is reported only once
/usr/src/pwc-10.0.11/pwc-v4l.c:371: error: for each function it appears in.)
make[2]: *** [/usr/src/pwc-10.0.11/pwc-v4l.o] Error 1
make[1]: *** [_module_/usr/src/pwc-10.0.11] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.15'
make: *** [all] Error 2
Avete qualche idea per risolvere?

ame
08-02-2006, 11:38
Pwc ora è installato come modulo:


root@Ares ~ # lsmod
Module Size Used by
pwc 47612 0

quando lancio xawtv -c /dev/video0 ecco l'output da shell


demone@Ares ~ $ xawtv -c /dev/video0
This is xawtv-3.95, running on Linux/i686 (2.6.15-demone)
WARNING: Your X-Server has no DGA support.
seteuid(root): Operation not permitted
v4l-conf had some trouble, trying to continue anyway
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format =7): Invalid argument
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format =5): Invalid argument
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format =4): Invalid argument
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format =1): Invalid argument
ioctl: VIDIOCMCAPTURE(frame=0;height=120;width=160;format =13): Invalid argument

Lo schermo resta griggio avete qualche idea per risolvere il problema

ame
08-02-2006, 22:07
up

virusbye
08-02-2006, 22:36
Hai provato a dare un "chmod 777 /dev/video0" prima di lanciare xawtv?

ame
08-02-2006, 22:38
demone@Ares ~ $ ls -al /dev/video0
lrwxrwxrwx 1 root root 10 2006-02-08 11:37 /dev/video0 -> v4l/video0

gio14
08-02-2006, 22:38
Io ho una webcam philips Toucam Pro e ho fatto così, ho scompattato il pacchetto pwc-10.0.11 sono entrato nella dir. che ha creato ho dato make & make install, ho caricato il modulo in modo permanente e a funzionato tutto alla perfezione (prova con gnomemeeting oppure camorama)

ame
08-02-2006, 22:42
Come vedi io non riesco ad installarlo pwc-10.0.11 mi da errori al make, mi da schermo griggio con camstream,amsn,kopete,xawtv. Non so più che fare

gio14
08-02-2006, 22:45
Prova ad aggiungere l'utente al gruppo video

ame
08-02-2006, 23:00
già fatto,ma non cambia niente

gio14
08-02-2006, 23:06
Senti io non l'ho compilato come patch del kernel, ma per suo conto (lui ovviamente crea i binari del driver) poi dando make install va ha posizionarli nella dir /lib/eccetera/eccetera poi lo installi con modprobe oppure riavvii se il nome del modulo è gia in /etc/modules

p.s.
il modulo pwc del kernel non mi è mai funzionato (a parte la prima volta che lo avevano inserito nel kernel) mi a sempre dato la schermata grigia nonostante non mi dava errore

Loading