PDA

Visualizza la versione completa : [Ubuntu] Network is unreachable..


dvd100
19-02-2006, 14:20
ho installato ubuntu 5.10 ma non riesco a collegarmi a internet con l'adsl.. ho il modem telecom D-link 302T collegato su ethernet nella scheda di rete integrata sulla scheda madre.. ho messo 192.168.0.1 come ip dell ascheda di rete, 255.255.255.0 come subnet e 192.186.1.1 come gateway.. però se provo a pingare (anche il modem) mi dice network is unreachable e il browser mi da connection refused.. Aiuto!

mykol
19-02-2006, 14:30
perchè non hai messo IP e gateway della stessa classe (es. 192.168.1.xxx) ? comunque con

# ifconfig eth0 192.168.1.2 up ti dovrebbe settare l'IP della scheda ethernet e poi con

# ping 192.169.1.1 ti dovrebbe rispondere il router.

se non lo fa prova

# ifconfig

e dovresti veder comparire, tra l'altro, l'IP della scheda appena inserito.

poi devi mettere in /etc/resolv.conf i DNS, così

nameserver 212.216.112.112
nameserver 212.216.172.62

sostituendo eventualmente i numeri con i DNS del tuo provider.

Prova anche a lanciare netcardconfig ed a mettere i valori da lì. (Debian e le debian-based usano quell'utility per la configurazione della rete)

dvd100
19-02-2006, 17:25
niente da fare..
se faccio ifconfig eth0 192.168.1.2 up mi da:
SIOCSFADDR Permission denied
SIOCSFFLAGS Permission denied
SIOCSFFLAGS Permission denied

e non pinga.. etc/resolv.conf me lo apre in sol alettura (non so come modificarlo) e cmq ci sono già i dns del mio provider..

inoltre netcardconfig non va!

sopadj1
19-02-2006, 17:58
devi essere root

dvd100
19-02-2006, 18:04
e non lo sono dopo il log con la password di root? come faccio a farlo?

mykol
19-02-2006, 18:05
ifconfig lo devi dare da console di root (apri la consolle, scrivi su, poi dai invio, metti la password e dai di nuovo invio). oppure fai precedere i vari comandi da sudo

esempio

$ sudo ifconfig ....

anche il file da modificare lo devi aprire come root o farlo precedere da sudo. Esempio

$ sudo kate (oppure un altro editor)

oppure

# su kate

( "#" è il simbolo di root, "$" è il simbolo dell'utente. Quando il prompt è $ sei utente e puoi modificare i file solo nella tua home, quando compare # sei root e puoi modificare qualsiasi cosa. Root usalo solo per lo stretto indispensabile, ad esempio non per navigare in internet !)

prova anche a dare un dmesg | grep eth. Io ottengo questo, in cui si vede chiaramente che è riconosciuta la scheda eth0.


[giorgio@MDK10 giorgio]$ dmesg | grep eth
eth0: VIA Rhine II at 0xe400, 00:0a:e6:51:99:51, IRQ 11.
eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 45e1.
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
eth0: Promiscuous mode enabled.
device eth0 entered promiscuous mode
eth0: Promiscuous mode enabled.
eth0: Promiscuous mode enabled.
eth0: Promiscuous mode enabled.
eth0: no IPv6 routers present
[giorgio@MDK10 giorgio]$

ed anche un lspci

[giorgio@MDK10 giorgio]$ lspci
...........................
..........................
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
............................
[giorgio@MDK10 giorgio]$

se per caso questi comandi non funzionano, dalli da root

dvd100
19-02-2006, 18:08
perfetto grazie ora provo.. perciò quando uso da interfaccia grafica sono sempre utente e mai root?

francofait
19-02-2006, 18:15
Originariamente inviato da dvd100
perfetto grazie ora provo.. perciò quando uso da interfaccia grafica sono sempre utente e mai root?

Sei con ubuntu , per ottenere i privilegi root x l'applicativo da usare , direttamente da X
da esegui comando con wm Gnome:
' gnomesu nomeprogramma ' (richiede la password utente ed avvia direttamente una sessione 'nomeprogramma' con privilegi root)

da esegui comando con wm Kde:

'kdesu nomeprogramma ' (idem sopra)

dvd100
19-02-2006, 23:04
ok allora sono riuscito a far pingare il modem.. ma non entra ancora in internet..

inoltre se faccio: su, invio e mi chiede la password non la scrive (il cursore rimane fermo) e quindi non mi fa entrare..

submax82
19-02-2006, 23:46
il modem dlink và configurato via web all'indirizzo 192.68.1.1 ... user e password sono "admin"

ti consiglio di trsformarlo in router con questi firmware www.dlinkpedia.net

p.s. anche io ho lo stesso modem "trasformato" a router...

Loading