PDA

Visualizza la versione completa : gprs easy connect + fedora core 4 + nokia 6230


ccccc
24-02-2006, 18:58
ciao a tutti.
dopo aver installato i pacchetti rpm necessari (moduli perl) ho installato GPRS easy connect. Il programma è semplice da configurare: ho inserito il modello del mio telefono (nokia 6230), il nome dell'account al quale connettermi (TIM ibox) e basta. il numero da chiamare e le varie stringhe necessarie da inserire dovrebbero essere impostate automaticamente una volta scelto operatore e modello di telefono. Occorre poi selezionare la porta giusta (quella alla quale il telefono è connesso tramite il cavo usb dku2). Con mio grande stupore, quando ho collegato il telefono è comparsa una nuova porta selezionabile dal menu a tendina di Gprs easy connect. Allora ho provato senza troppe speranze ad effettuare la connessione e finalmente... si è connesso!!! Bè comunque era ora.... Purtroppo la mia euforia è stata prontamente frenata... Quando sono passato ad aprire Firefox per provare a collegarmi ad un sito per verificare se funzionava, il browser non trova nessun sito persino google, persino effettuando una ricerca dalla barra aposita. Non riesco a capire perchè. potrebbe avre a che fare con l'impostazione del firewall?
Come posso fare a risolvere il problema? era quasi fatta...

Ah... aggiungo un ul'teriore informazione che però non penso che centri molto: quando faccio partire GPRS-easy-connect mi dà un warning a causa della versione dei moduli perl che ho instalato:
************************************************** **************
#gprsec

***This build of Glib was compiled with glib 2.6.6, but is currently running with 2.6.4, which is too old. We'll continue, but expect problems!
*** This build of Gtk2 was compiled with gtk+ 2.6.10, but is currently running with 2.6.7, which is too old. We'll continue, but expect problems!
************************************************** **************

ps. non sono esperto di unix quindi sono gradite spiegazioni semplici

ASPETTO UNA RISPOSTA AL PIU' PRESTO RINGRAZIANDO IN ANTICIPO CHI VOGLIA RISPONDERE.


CIAO

andy caps
24-02-2006, 20:37
puoi provare ad inserire i dns del provider in /etc/resolv.conf o anche nell'interfaccia di easy gprs se possibile

altrimenti devi controllare se i pachetti sono estradati verso un interfaccia di rete se presente ( eth0 o eth1 )

route -n se è presente un gateway impostato lo dice
e se vedi un gateway diverso da 0 0 0 0 devi rimuoverlo

es
route del default gw 192.168.1.0 se mette questo

altrimenti se hai un firewall devi fermarlo

ccccc
24-02-2006, 22:21
dunque,

1- i dsn sono impostati in gprs easy connect e sono:

Server DNS Primario: 213.230.155.94
Server DNS Secondario: 213.230.130.222

non so se ti possano essere utili per aiutarmi...


2- ti invio il messaggio che ottengo con 'route -n':

***************************************
Destination Gateway Genmask Flags Metric Ref Use Iface
169.254.0.0 * 55.255.0.0 U 0 0 0 lo
[root@localhost userC]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.6.6.6 * 255.255.255.255 UH 0 0 0 ppp0
169.254.0.0 * 255.255.0.0 U 0 0 0 lo
default 10.6.6.6 0.0.0.0 UG 0 0 0 ppp0
[root@localhost userC]#
***************************************
chiedo scusa ma riesco a metterlo bene in colonna...
il primo lo ottengo quando non sono connesso. il secondo dopo avere stabilito con successo la connessione. io ci capisco poco... ma come hai detto tu, in effetti ci sono dei getway diversi da 0.0.0.0. devo rimuoverli? ma come si fa?... beata ignoranza...!
Ti riporto anche l'errore che ottengo da firefox: inserendo per esempio l'indirizzo www.google.com e dando invio mi dice 'www.google.com non reperibile.Ricontrollare il nome e provare di nuovo'


3- Ricordo che in windows avevo un problema simile e poi era solo il firewall, nel quale non era stato sbloccato il permesso al programma explorer. Speravo che anche sta volta fosse così...Anche se comunque non saprei come controllare il firewall. io uso fedora core 4 e come interfaccia predefinita utilizzo gnome come si controlla il firewall?


grazie per avermi risposto..fammi sapere

a presto,
ciao

andy caps
25-02-2006, 00:48
prova a dare il comando

/etc/rc.d/init.d/iptables stop
per vedere se ripende da quello
fedora dovrebbe avere iptables come firewall

controlla la collonna del gateway

il valore in basso deve essere 0 0 0 0

scrivi i valori della colonna del gateway uno sopra l'altro qui

dai comunque
ifconfig eth0 down se hai una scheda di rete

ccccc
25-02-2006, 03:42
Il comando che mi hai consigliato dà l’esito seguente:

**********************************
[root@localhost userC]# /etc/rc.d/init.d/iptables stop
Azzerare le regole del firewall: [ OK ]
Impostazione delle catene su policy ACCEPT:filter [ OK ]
Scaricamento dei moduli iptables: [ OK ]
[root@localhost userC]#
**********************************

ho poi provato di nuovo a connettermi ma niente da fare, si connette ma il browser non funge

ti riporto altri output di comandi che ho provato

******************************************
[root@localhost userC]# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1880 errors:0 dropped:0 overruns:0 frame:0
TX packets:1880 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1656260 (1.5 MiB) TX bytes:1656260 (1.5 MiB)

ppp0 Link encap:Point-to-Point Protocol
inet addr:217.201.130.89 P-t-P:10.6.6.6 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:57 errors:0 dropped:0 overruns:0 frame:0
TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:2999 (2.9 KiB) TX bytes:3411 (3.3 KiB)
************************************************** ****

ho anche dato il comando ifconfig eth0 down

ma niente da fare...

ti riporto la tabella getway (se ho capito bene vuoi che te la riporti nel messaggio?)

col comando route dà

Getway

[root@localhost userC]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.6.6.6 * 255.255.255.255 UH 0 0 0 ppp0
169.254.0.0 * 255.255.0.0 U 0 0 0 lo
default 10.6.6.6 0.0.0.0 UG 0 0 0 ppp0
[root@localhost userC]#
************************************************** *****

Ti riporto con più precisione la colonna gatetway

Geteway

*
*
10.6.6.6

andy caps
25-02-2006, 11:42
sembra vada tutto bene
io provarei a cercare altri dns

prova a scrivere in /etc/resolv.conf

nameserver 85.37.17.5
nameserver 85.38.28.77
non sono i dns di tim mobile ma puoi provare

poi puoi provare a dare il comando
route del default gw 10.6.6.6
e riprovare

ccccc
25-02-2006, 15:59
Allora, innanzi tutto sei un grande:

sono riuscito a farlo funzionare ... finalmente!!!

ti spiego i passaggi che ho fatto

1- per quanto riguarda il gateway non sono capace a configurarlo e dal man di ‘route’ non ci capisco molto... comunque forse non sarà necessario (leggi oltre)

2- per quanto riguarda invece il file ‘/etc/resolv.conf’
l’ho aperto con l'editor ‘vi’ ed era vuoto!!! (significa forse che i dns non erano impostati? Anche se dall’interfaccia grafica di gprs easy connect risultavano
apposto? Chissà?).
Bene il problema deve essere nascosto qui. Infatti ho editato il file come
avevi consigliato con i dns che hai specificato e quando ho effettuato la
connessione è andata alla grande: il sito di google ha risposto, si collega
finalmente.

Resta solo un problema non trascurabile: io ho la necessità di collegarmi a Tim Ibox con la quale ho una scheda prepagata altrimenti spenderei un capitale.
Quindi per prima cosa devo impostare i dns giusti.
( è così o mi sbaglio? posso collegarmi a Tim ibox usando anche altri dns? se hai voglia di spiegarmi questo particolare...grazie)

Ho provato ad editare il solito file /etc/resolv.conf mettendo i ‘nameserver’ di TIM Ibox invece dei tuoi. Il file risulta il seguente:

************************************************** **

nameserver 213.230.155.94
nameserver 213.230.130.222
~
~

************************************************** **

funziona tutto bene ma non sono sicuro...mi spiego meglio:

ha importanza l’ordine in cui vengono inseriti i dns? (primario secondario?)

Infine ti riporto anche il file di gprs e.c. Che contiene le impostazioni dell’apn (solo la riga che interessa a ‘noi’):

************************************************** ***
235 ----- TIM (ibox - 3G Italy) ------- ibox.tim.it ----- (*) ---------- (*) ---------- 213.230.130.222 ------------ 213.230.155.94
************************************************** ***

ps.
E’ tutto sulla stessa riga.
dall’interfaccia grafica di gprs e.c. Risulta

dns primario = 213.230.155.94
dns secondario = 213.230.130.222

la mia domanda è in che ordine vanno inseriti nel file ‘/etc/resolvconf’ ?

In ultimo la domanda più importante: come faccio ad assicurarmi che si a tutto giusto? Al fine di non trovarmi il credito telefonico in rosso?

Grazie infinite!!!

fammi sapere, a presto

ciao.

ccccc
27-02-2006, 01:18
Ho provato un po' a navigare ...
sembra funzionare ...

anche se mi piacerebbe capire come configurare al meglio
la connessione inmodo da renderla il più veloce e stabile possibile.

Spero che tu mi risponda per togliermi i dubbi che avevo espresso nel messaggio precedente...

avevi letto le mie domande?

aspetto una risposta...senza fretta naturalmente

Ringrazio in anticipo, a presto,

ciao.

andy caps
27-02-2006, 01:56
in genere si mette il primario sopra ed il secondario sotto ma non è importante

i dns non possono influire sulla tariffazione
devi guardare sul sito di tim

comunque ti faccio consigliare da un amico che si connette solo con la flat di tim mobile e si intende di tariffe

chiama comunque tim e chiedi a loro se possono formirti info

gielle1958
27-02-2006, 08:53
[QUOTE]Originariamente inviato da ccccc
Resta solo un problema non trascurabile: io ho la necessità di collegarmi a Tim Ibox con la quale ho una scheda prepagata altrimenti spenderei un capitale.
Quindi per prima cosa devo impostare i dns giusti.
( è così o mi sbaglio? posso collegarmi a Tim ibox usando anche altri dns? se hai voglia di spiegarmi questo particolare...grazie)

Ti rispondo io su sollecitazione di Andy.
Prima cosa devi essere certo di aver settato correttamente l' APN di tim che è ibox.tim.it e questo,se non ricordo male,devi settarlo su gprs easy connect.
Passo due devi attivarti una delle due promo di tim o la maxi tim web facile recharge o la maxi tim web time recharge.
Costo della prima 20 € della seconda 25.
Differenze: con la prima hai a disposizione 500 Mb da consumarsi entro 30 gg dalla attivazione a navigando anche 24 h su 24.
Se la rinnovi prima della scadenza hai un bonus di altri 500 Mb ed arrivi ad un 1 Gb da consumarsi a h 24 in un mese.
Con la seconda hai a disposizione 9 GB al mese ma hai dei limiti di orario per navigare.Dalle 09 am alle 17 (se non ricordo male) pm.
Sabato e domenica nonchè festivi h 24.
Fuori dalla APN e dalle 2 promo spendi circa 40 € a mega.
Per ulteriori informazioni chiama il 119 tasto 5 e poi tasto 3.
Ciao e happy surfing. :ciauz:

Loading