PDA

Visualizza la versione completa : Stampare con CANON LBP-1120. Magari...


Paramir
04-03-2006, 15:54
Salve, sono mesi che soffro tentando di far funzionare questa maledetta stampante sotto Mepis (non č stato possibile neanche con Suse ad essere sinceri) ma non c'č versi; il massimo che ho ottenuto č di riuscire a fargliela vedere ed a installare i suoi driver (presi dalla canon convertiti in .deb con alien). Tutto sembra funzionare se non che non stampa nulla neanche la pagina di prova. L'unica cosa che noto di strano č che me la monta sulla porta parallela invece che su usb.

Ho seguito le istruzioni sui vari siti che trattano l'argomento ma niente. In particolare:
http://www.linuxprinting.org/show_printer.cgi?recnum=Canon-LBP-1120
http://www.boichat.ch/nicolas/capt/

Qualcuno sa come poter risolvere?

Ciao

andy caps
04-03-2006, 19:23
se hai installato i driver capt http://www.boichat.ch/nicolas/capt/
dovrebbe andare
una volta installati poi controlla che le usb siano attive ed i moduli caricati

lsusb per sapere se vede la stampante

lsmod per vedere se i vari uhci-hdc ehci-hdc ohci-hdc usblp sono presenti
poi rimuovo la stampante e riconfigurala da http://localhost:631

scegliendo usb come porta /dev/usb/lp0 come percorso

Paramir
04-03-2006, 19:30
Dunque:

Comando lsusb:
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 002: ID 04a9:262b Canon, Inc. LaserShot LBP-1120 Printer
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 0ac8:301b Z-Star Microelectronics Corp. ZC0301 WebCam
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

Comando lsmod:
Module Size Used by
usblp 9856 0
binfmt_misc 8200 1
lp 8132 0
ipt_state 1536 50
ipt_REJECT 3968 4
ipt_limit 1920 6
ipt_LOG 5248 6
ip_conntrack_ftp 5872 0
ip_conntrack 41260 2 ipt_state,ip_conntrack_ftp
nfnetlink 4632 1 ip_conntrack
iptable_filter 2304 1
ip_tables 16640 5 ipt_state,ipt_REJECT,ipt_limit,ipt_LOG,iptable_fil ter
nls_iso8859_1 3968 1
nls_cp437 5632 1
thermal 10888 0
ibm_acpi 24192 0
processor 19008 1 thermal
fan 3460 0
button 5008 0
battery 7684 0
ac 3460 0
md_mod 53972 0
dm_mod 43704 0
spca5xx 629392 0
videodev 6912 1 spca5xx
sworks_agp 6688 0
amd_k7_agp 6156 0
ali_agp 4864 0
sis_agp 5892 1
ati_agp 5900 0
joydev 7232 0
nvidia_agp 5532 0
evdev 6912 0
irtty_sir 6528 0
snd_intel8x0m 16396 7
snd_intel8x0 30492 3
sir_dev 13996 1 irtty_sir
snd_ac97_codec 82976 2 snd_intel8x0m,snd_intel8x0
snd_ac97_bus 2304 1 snd_ac97_codec
irda 151740 2 irtty_sir,sir_dev
floppy 50372 0
snd_pcm_oss 46496 0
crc_ccitt 1920 1 irda
8139too 21248 0
via_agp 7424 0
parport_pc 28484 1
parport 27720 2 lp,parport_pc
yenta_socket 21516 1
rsrc_nonstatic 9856 1 yenta_socket
pcmcia 28476 0
firmware_class 7424 1 pcmcia
snd_mixer_oss 17024 3 snd_pcm_oss
snd_pcm 80008 6 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_ oss
psmouse 29828 0
serio_raw 5252 0
pcspkr 1668 0
snd_timer 22660 1 snd_pcm
snd 51300 21 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_ oss,snd_mixer_oss,snd_pcm,snd_timer
pcmcia_core 31376 3 yenta_socket,rsrc_nonstatic,pcmcia
sbp2 19204 0
i2c_sis96x 4484 0
ohci1394 27316 0
rtc 9524 0
soundcore 7008 3 snd
i2c_core 15248 1 i2c_sis96x
snd_page_alloc 10248 3 snd_intel8x0m,snd_intel8x0,snd_pcm
8139cp 16000 0
intel_agp 17820 0
mii 4224 2 8139too,8139cp
agpgart 25160 8 sworks_agp,amd_k7_agp,ali_agp,sis_agp,ati_agp,nvid ia_agp,via_agp,intel_agp
ohci_hcd 16388 0
shpchp 36160 0
pci_hotplug 21940 1 shpchp


Sono abbastanza new di linux, ma mi sembra che al primo comando dia risposta positiva, ma nel secondo ci capisco poco...

Grazie...

andy caps
04-03-2006, 19:44
se hai le usb 2 devi probabilmente dare un modprobe ehci-hcd per caricare il driver
poi provare a configurare la stampante da localhost come ti ho detto se hai installato tutti i files di cups

Paramir
04-03-2006, 19:49
modprobe ehci-hcd, mi dice che "not found"
La configuarazione l'ho fatta da localhost.

andy caps
04-03-2006, 20:09
lo devi dare da root il comando
prova eventualmete
modprobe ehci_hcd

Paramir
05-03-2006, 01:33
Non ne vuole proprio sapere di quel modulo...

andy caps
05-03-2006, 10:37
mo sembra strano che non ci sia il modulo per le usb2

controlla con modprobe -l | grep ehci se esiste

dai anche un dmesg | grep ehci per vedere se hai porte usb2

comunque io disinstallerei i driver che hai installato con alien

prova con i driver consigliati da linuxprinting o anche
con questo pacchetto
(ddiwrapper - Support for Windows printer drivers under Linux)

la suse č l'unica distribuzione ad averlo
č una specie di ndiswrapper per le stampanti canon
dovresti averlo sui cd

Paramir
05-03-2006, 12:09
modprobe -l | grep ehci: lo esegue e torna al prompt
dmesg | grep ehci: idem

I driver usb li dovrei avere visto che ho anche un box esterno usb con un hd che funziona benissimo.

Riproverņ senza i driver originali canon ma l'ultima volta non ha funzionato.

Per quell'altro come faccio ad usarlo se č sul cd di suse? Ora ho mepis.

andy caps
05-03-2006, 12:25
yast -i ddiwrapper per installarlo ( o cercalo con yast
poi guarda il manuale

man ddwrapper o ddwrapper --help
o prova a lanciarlo direttamente ddwrapper
probabilmente ti chiedera' i driver di windows

Loading