PDA

Visualizza la versione completa : Driver ati Server X bloccato


Vagolando
06-03-2006, 17:34
Ciao a tutti,
ho un ubuntu breezy e una scheda ati 9600 radeon. Dopo aver provato i driver che l'ubuntu rilascia per le schede grafiche ati e aver constatato che non funzionano ho provato i driver proprietari dell'ATI.
Non solo non funziona l'accelerazione grafica, ma al riavvio nel momento di caricare la schermata per accedere al sistema mi compare questa scritta:
"impossibile avviare il server X (la tua interfaccia grafica). Probabilmente non è configurato correttamente. Vuoi vedere l'output grafico del server X per diagnosticare il" e non riesco a selezionare l'opzione sì, mi rimanda al login testuale.
Qualcuno ha qualche idea altrimenti devo riinstallare tutto.
Grazie
Ciao

sacarde
06-03-2006, 19:00
che dice il file di log

/var/log/Xorg.0.log

vedi degli errori? (EE)





p.s.
oppure prova a riconfigurare e testare un'altro xorg.conf

Xorg -configure
Xorg -conf ./xorg.conf.new

Vagolando
07-03-2006, 10:41
Il file di log non dà errori qualch warning ma nulla di così fatale.
Il problema è che non parte più X.

Vagolando
07-03-2006, 10:56
Ho già anche ripristinato con il vecchio xorg, ma quando dò lo startx mi dice:
xauth: creating new authority file /root/.serverauth.5635

sacarde
07-03-2006, 17:58
nel log di X ci deve essere un errore.....



p.s.
come avvii la tua ubuntu ?

Vagolando
08-03-2006, 14:40
La avvio normalmente. Quando tenta di caricare X si pianta, mi chiede se voglio vedere il file di errore, ma poi mi mostra file senza niente e parto in modalità testuale.
Dal fiel di errore direi che non riesce a creare il modulo. Problema di compatibilità di gcc?

sacarde
08-03-2006, 17:57
con che runlevel si avvia ?

dai utente e password da finestra grafica ?

mi immagino non root !

Vagolando
09-03-2006, 12:25
non ce l'ho la finestra grafica, quindi suppongo parta come init 3.
Sembra non riesca a creare i moduli per l'fglrx.

sacarde
09-03-2006, 12:33
mi fai vedere il file di errore?

Loading